Solar Input No Longer Working on EB3A with .09 & .10 Firmware

Starting another thread because the last one was about the problems with the UPS function not working properly.

Well, I’ve run into another problem with this .09 & .10 firmware. A few days ago I was able to charge both EB3A’s via solar with no issues, but nothing was hooked up to AC or DC then, just charging outside. Today, I had a light plugged in AC, hooked up the exact same panel and cable to PV, and got nothing, the Alarm says PV Undervoltage. After removing the light, turning off AC & DC, turning off the station and back on, the solar still won’t work. On the other EB3A I made sure nothing was plugged into the AC & DC was off, and the solar input is working on that one.

There’s quite a few people over at Bluetti Reddit having the same problem: https://www.reddit.com/r/bluetti/comments/vpvdsg/downgrade_firmware/

Buggy. This really needs sorting out.

1 Like

Troubleshooting update -

Trying to find a way to reset that PV Undervoltage. Just turning the unit on and off then plugging in solar didn’t work. Took inside, plugged something into AC and ran it down to 98%, plugged in the power cord to charge up to 100%, unplugged then ran it down to 97%. Took outside, power off, hooked up the solar panel and it began working. Actually got a peak of 99w input on that BougeRV 130w suitcase panel (loving this panel so far).

So by charging up to 100% via power cord and then running down the battery and trying solar, it seems to have reset itself. I’m hesitant to use either DC or AC while solar charging now which isn’t good at all. I sure hope they’re working on a fix for this.

I did email Bluetti about this and the other problem some of us are having with the UPS. Hoping others email them also. Here’s their email address: service@bluettipower.com

2 Likes

I’d be curious to know how many volts you measure at the tail end DC7909 connector when you get the PV Undervoltage error.

I’m an elderly gal who doesn’t have much knowledge about volts and amps, bxm. I did buy a multimeter but couldn’t figure out how to use the dang thing so gave up on that gadget (lol).

I saw the same issue when using a 50ft 10AWG extension, it would trip the PV under voltage error, however would charge from a PV200 panel without the extension.

For voltage, without the extension which would charge was ~ 22v at the connector. With the extension, the connector also measures ~22v.

For me however if I unplugged the solar cable from the EB3A, the error code would automatically clear. I didn’t need to restart the device.

I’m glad to hear that you still have the ability to use solar to charge, hopefully once you try another cable the error won’t pop up - hopefully. There’s still others who weren’t quite as lucky as me in resetting the PV Undervoltage - they still can’t charge via solar now. Here’s the link over at Bluetti Reddit: https://www.reddit.com/r/bluetti/comments/vpvdsg/downgrade_firmware/?utm_source=share&utm_medium=web2x&context=3

I’m finding it takes more watts now to register on the EB3A. Experimented with a single 50W panel and no go. It likes my 200W panel thought and with both in parallel I get peak of 153W. Does not help I’m sure that I am using a 30ft DC8mm extension cord. This new firmware sure played around with charge settings…for the worse I think.

1 Like

Vinman, it shows you have something plugged in AC and are using solar at the same time - that’s something I did but got the Undervoltage error thingy and had to troubleshoot my way out of that, while others who had my problem still can’t use solar. All this stuff is crazy!

yeah i have no issue charging and discharging at the same time but something is up with input because just now as the sun was going down I caught my EB3A panel displaying 0W input but on my app it showed 6W when I engaged the AC input because my battery level was low.

To me, looks like the input wattage the EB3A reads is not true or consistent.

One thing I forgot to mention was this - on the app while monitoring the solar input with nothing turned on or plugged in for AC or DC, sometimes the Grid icon would briefly flash blue, on and off, about every second or so, and sometimes even the AC would quickly flash blue on and off, all while only charging with solar. I hope it’s something buggy in the app and not with the station.

Just got my new unit and have the same problem no charge with solar Panel 120W, also did firmware update .
I have a small Jackery solar Panel that works.
Suppose to wait for resolution since I’m simple user!
Appreciate any help
Carlos

2 Likes

Discharge to 0% by powering a load. Recharge to 100%. The state of charge indicator seems to change to an arificial % during the update and needs a complete charge / discharge cycle to re-set

Having the same issues with my EB3A as well.

1 Like

Having same issue after firmware update this morning. Tried the above troubleshooting and still not able to charge via solar, PV Undervoltage alarm on app.

I just tried the the above troubleshooting and still not able to charge via DC, PV Undervoltage alarm on the app. This occurred before and after all the firmware updates.

1 Like

Masaugi1, earlier today they put out a new Arm firmware of .10, did you already update to that version? We have storms over here so I can’t do any testing with the .10 firmware.

What is the voltage coming from your solar panel(s)?

Didn’t know about the .10 ARM update and just updated. Prior to updating my INPUT warning was flashing with a shaded panel and after updating it is no longer flashing. Not sure if coincidental as the EB3A rebooted after the update. Will have to monitor to see what effect the new ARM update has.

1 Like

Just checked mine, it won’t charge on a single 100w or a single120w panel but will charge fine when 2 panels are in parallel. Must be an amp issue as the voltages won’t change when the panels are in parallel but the amps will increase.

Eric, that’s interesting to hear that you still can’t charge with a single 100w or 120w panel - are you on the new firmware version of Arm .10 (just released today)? I sure wish they had release notes for these firmware updates so we know what bugs they fix.

I can’t test yet because our weather conditions are poor, hopefully by the weekend it’ll clear.