UPS Problem on EB3A

Well I am sad to report the new firmware did not fix the issue. I experienced the AC reboot (you can hear the clicking relay) tonight several times and the AC button remains lit supplying power after the incident. I even have my charge rate to silent in hopes of keeping the rate of charge down. This and a weird TEMP warning problem where when charging to 100 percent from a low state won’t clear and you have to shut down the EB3A to clear it.

I feel .09 and 10 firmware may be buggier than .05!

Guess I may have to put in a UPS in between the EB3A and my computer. Not a happy camper with this product as far as the UPS Bypass feature is concerned! :frowning_with_open_mouth:

1 Like

Does Bluetti support even read these forms? I know they don’t respond to e-mails to because I sent one on June 27th informing them of the problem and then another on June 29th and still have not heard back. This is he 4th solar generator I have purchased from Bluetti. Now that I know they don’t support their products I won’t be buying any more from them. So if I can return this product, I’ll be the not so proud owner of 3 Bluetti solar generators. Yes, I’m frustrated with the situation, just like the rest of you. If any of you know of a way to get Bluetti’s attention on this, please let us know.

@Vinman strange.

I’ve been running a Wyze cam thru my EB3a via AC, since 8:06am yesterday (so roughly 24 hours now) while also plugged into the wall to test the UPS issues. And the camera hasn’t turned off or reset once. Thru a killawatt the cam pulls only 2-3watts, obviously too little to display on the EB3A.

But am I not experiencing this “UPS issue” because the draw is too low or what? I’m sure my router/modem setup draws slightly more (probably around 20-30w) but shouldn’t this appliance and setup compare and show if there was an issue??

1 Like

Not sure about this Wyze cam and if there was an AC power disruption how it would affect it and it may be too low of a draw. For my computer at least the duration is long enough it turns off the computer. For comparison I am running about 130 W constant and when i do notice it happening it is when the EB3A is ramping up like 150W input to charge the battery and the fans are running high speed then after the AC disruption all is back to normal. I think the battery has to dip a bit below 100 percent to say 99 for the charge cycle to kick in. You can try a DC load as well say charge your phone to drop the percent down a bit but again this issue is random but for my experience I don’t go through 2 days straight without it happening at least once.


I updated to the latest firmware (with fingers crossed). Now using EB3A in UPS mode to charge a couple of AA batteries at very low power. Been running for more than an hour, so I think the update worked. I think the inverter is running because the top of the unit is warm, but there are no noises and the fan has not come on.

(Starting another thread Solar Input Not Working on EB3A since this one is mainly about the UPS problems but will leave this comment here)

Well, I’ve run into another problem with this .09 & .10 firmware. A few days ago I was able to charge both EB3A’s via solar with no issues, but nothing was hooked up to AC or DC then, just charging outside. Today, I had a light plugged in AC, hooked up the exact same panel and cable to PV, and got nothing, the Alarm says PV Undervoltage. On the other EB3A I made sure nothing was plugged into the AC & DC was off, and the solar input is working on that one. I thought I lucked out after seeing quite a few others having the same problem with not being able to charge via solar, but seems not.

Buggy. This really needs sorting out.

1 Like

@Jayling have you tried updating to the new .10/.10 firmware by chance??

@m.briney Yes, I updated the firmware to .10 Arm yesterday, but our weather has turned sour over here so it’ll be awhile before I can do any testing - need some sun! lol

1 Like

@Jayling keep us posted! I’m gonna try and do more testing on it later with my variable power supply simulating Solar. We’ve got some nasty storms here in Michigan right now too!!

1 Like

@m.briney I did forget to update this thread about the ‘Solar Input No Longer Working on the EB3A’. I was able to troubleshoot my way out of that problem. Here’s what I did:

Troubleshooting update -

Trying to find a way to reset that PV Undervoltage. Just turning the unit on and off then plugging in solar didn’t work. Took inside and charged up to 100% with the power cord, unplugged then ran it down to 97%. Took outside, power off, hooked up the solar panel and it began working. Actually got a peak of 99w input on that BougeRV 130w suitcase panel (loving this panel so far).

So by charging up to 100% via power cord and then running down the battery a bit then trying solar, it seems to have reset itself.

Since after that I had been scared to use AC and try to charge via solar at the same time, I put on my big girl pants the next day and tested again - first I made sure I was getting good solar input (90 some watts) on the unit with nothing plugged in AC or DC, unplugged solar input, then I plugged something into AC, and then plugged in solar - it worked without issue.

1 Like

@Jayling hell yea that’s great news. :metal: sometime these units can be finicky and need that “cycle” to completely reset the internals. That along with them working on the firmware and putting out updates, are making this unit one of my favs so far!

1 Like

Update: So far on ARM .10 it has been stable, no UPS issues so far. Will see how it goes the next few days.


Vinman, are you still using that external UPS device in between the computer/monitor and the power station, or is everything now just plugged into the EB3A?

I’ve removed it for now. My electronics are plugged back direct into the EB3A.

1 Like

Hello all. I just received my EB3A and joined the forum. Before I ordered the unit I checked the forum and saw that some have had issues with the UPS feature functioning properly. This was a concern for me as I want to use the EB3A for a UPS for my desktop PC in addition to a solar generator. I also noted that some have updated the firmware and have developed other operating issues or the units have been bricked.

I ordered the unit from Amazon and it arrived on Tuesday. I downloaded the Bluetti app on my phone. The initial charge was 65%. I chargeed it to 100% using the AC wall charger. I then discharged it down to 5% running a AC fan using ~ 31 watts. I then recharged it to 100% using the AC wall charger. At that point the app activated and I was able to use the app.

I’ve tested the AC output and the DC usb ports charging phones and watches. All okay. I then tested the UPS function with a 9 watt led lamp connected to the unit. Plugged the lamp into the AC output and plugged the EB3A into the AC wall input. All good. Then unplugged the unit from the AC wall input. The lamp flickered briefly but stayed lit. Good so far but the real test is with the desktop PC. I plugged the desktop into the fully charged EB3A and powered it drawing between 45 and 90 watts. I then plugged the unit into the AC wall outlet and the UPS light activated on the EB3A. I was charging the EB3A and running the desktop at the same time (pass thru). Now for the big test. I held my breath and pulled the plug from the AC wall outlet and the desktop kept humming along without a glitch. It actually worked. Quite frankly, I was happily surprised. I repeated the power outage test multiple times with no issues.

I next tested the solar charging option using a Rockpal 100 watt portable solar panel. Connected it to the 8 mm input and it generated a maximum of 85 watts into the EB3A. I connected a fan to the AC output and it ran drawing 31 watts while solar charging. The solar charging test was a success.

The only issue that I noted (others have also) is that the the fan buzzes on fan startup at low rpm’s before it ramps up in speed. I contacted Bluetti and they advised that they are aware of this and that they’re looking for a fan replacement.

I’m running the stock firmware which came with the unit. It is “5702” and “5602”. As the unit operates fine for my purposes (other than the fan buzz) I won’t be updating the firmware.

Maybe I’m just lucky …


Thanks for the feedback.

To clarify your test did not deal with what the issue was. You have to leave your AC power device in permanently to the EB3A and watch for an AC disruption. Also a 9W lamp is not something that you readily tell if the AC got disrupted, you need something that cannot tolerate a disruption such as a computer,modem or router which will reboot or shut off if the AC is off for too long for its liking.

Removing the AC input cord to force it to use battery on the ineverter will always work but was not the issue. It was when you were using the AC in BYPASS mode (ac input) 24/7 the EB3A can temporarly lose AC to it’s AC outlets and relay will be heard clicking.

1 Like

Thanks for the clarification Vinman. I’ll setup the EB3A with my desktop PC and see if it will run 24/7 while in by-pass mode without any interuptions. I’ll report back.

To be honest I updated my EB3A straight to .05 when i got it and then .09 and both firmware levels had issues. Not sure about .02 but if you start to have issues i would update to .10 ARM .10 DSP.
So far for me it is stable.

1 Like

I’ve been running the EB3A in UPS mode for~ 3-1/2 hours using between 50-90 watts on my desktop PC with no issues on version .02. However, as you stated it has taken over one day before the AC output has dropped out. The EB3A gets warm ~ 105 degrees and the battery drops from 100% - 99%. When at 100% the input watts equal the output watts but when the charge drops to 99% the input watts increase to recharge the battery back to 100%. Do you think that I should update the firmware? How does the firmware get updated Thanks.

I’m charging using the low silent mode.