Solar Input No Longer Working on EB3A with .09 & .10 Firmware

Nope, still on 9 & 10

Right now its charging on a single 200w panel just fine which makes sense if the lower amps of the smaller panels are the issue.

Update to ARM .10. That may fix the issue with solar input.

1 Like

In the 2nd post in this thread it said it was charged to 100% with AC but charging via solar didn’t work. Isn’t that like filling up a gas tank and not being able to put in more? Sounds to me the unit is working just fine.

Exactly like that if already full. And charging speed would also be affected if 80% or more full depending on firmware version.

360Guy, you may have missed this, “plugged in the power cord to charge up to 100%, unplugged then ran it down to 97%. Took outside, power off, hooked up the solar panel and it began working.” Prior to using the power cord to charge up to 100%, there was an error of PV Undervoltage when trying to use solar, the way I got it to reset was to use the ac power cord to charge up to 100%, then drained the battery a bit to test if solar would work, and it did.

Yep, 10/10 fixed it. Its now charging on a single 100w panel through a high cloud cover.


Right, all of a sudden no way panels that were working prior to .09 ARM update started failing. It was .10 ARM that fixed the solar input issue. Want to give it more days to test but so far I am happy with .10ARM. It seems stable with charge input issues detecting low wattage input better now and also my temp issue when full charging from a low percentage while using the inverter seems to be manageable now. Temp comes on at 100% put then goes away so I am please with .10ARM and ,10 DSP.


Data point: Updated to ARM .10 this morning and ran my EB3A from 100% to 85% inside. Placed new 100W folding panel outside when the sun was behind a cloud and a tree. Plugged the panel into the generator and saw 000W from reflected light. Waited for the panel to get full sun and got up to 85W out of the 100W panel. Recharged to 100% in about an hour while also charging a small tablet at 5W on the USB-A output. Did not try the AC output.

Additional: Have not received solar cables from Bluetti. The ITEHIL Solar Panel, 100W 18 Volt Monocrystalline Solar Panel Kit i bought from Amazon came with a cable and adapters that work fine.


I received the Bluetti solar cable yesterday. Looks like MC4 inputs to 8mm on the EB3A side. Have not tested because my panels with MC4 connectors are higher voltage than I want to try.

What voltage are your panels?

My portable panels are in the 12-18 range and work fine. I also have a few 360W roof panels that are about 45Voc. The EB3A solar input limit is 28V. I do not want to test the over-voltage protection.

Right, the 360W are too high, it may damage the EB3A.

Same issue here. EB3A with PV120 panel. On a partially cloudy day, the panel put out 90W when first plugged in and then higher, hitting 120W for a second and then bounced around between 95-105W for the next 2 minutes or just long enough for me to think wow, this is great before going to 0W and displaying PV Undervoltage (while also flashing INPUT). Note it got progressively more cloudy in those 2 minutes but it still should have shown an input charge, no way these panels were reading zero charge.

While examining the charge state via the app, I noticed there was a firmware update (I had already done a previous update).
After update:
ARM v2057.11
DSP v2056.10

Fully charged the unit via AC and then discharged to 80%. Still won’t charge via the solar panel.

As also suggested, currently discharging EB3A to zero with a 400W draw via a tortilla maker. Made a tortilla and with cheese, now just waiting for the unit to fully discharge, I think it’s been about 40-45 min with 13% battery left. The weird buzzing noice before the fan ramp up is tolerable but would be better without it. Will recharge fully and try tomorrow when the sun is out.

What kind of cheese on the tortilla?

1 Like

LOL, just a mix of shredded Mexican cheese.

Note the solar charging is working today. 94W at 10AM an a sunny morning. Put the panels in partial shade and wattage was 15-50W depending on the amount of shade. Even powered a 200w kettle while charging just to make sure there were no charging errors. So, solar charging seems to be working now after discharging the battery.

Only one thing to note and I’m not sure if it is just me not understanding how the Bluetti VP charging works or if there is another issue. While charging via the panel, I would get AC low voltage and AC low frequency alarms popping up on the app and UPS was flashing on the display. If I turnon the AC button so the inverter kicks in, the error messages stop. Turn off the inverter and the app shows 9-15W and the error codes pop up again. Checked all cable connections and they had no effect. Couldn’t see anywhere in the manual that said the AC inverter had to be on while charging via solar, maybe I missed it or is it a firmware glitch?

AC inverter does not have to be on during any type of charging.

1 Like

Thanks for the info. Now just I’m wondering why I have the error. Anyone else have the same AC low voltage issue when solar charging?

TaterTot, I’m no longer getting the PV Undervoltage errors in the latest .11/.10 firmware, but when I’m solar charging I do have the AC output on as it’s doing pass-through charging. I don’t know if I’d get the same error as you if I tried to solar charge with AC output off.

1 Like

TaterTot, today I disconnected my AC stuff to test if I’d get the low voltage and low frequency alarms with flashing UPS like you did, so I turned off AC (no green light), and my solar charging was doing fine at about 113-120w (though up and down because of how cloudy it is here today). No alarms or errors here. Again, I’m on the .11/.10 firmware.