EB3A shows overload when not overloaded

ARM: v2062.05
DSP: v2056.10

@bluetti_mbtb114gmailcom Thank you. The firmware has been pushed. Please update it and check if the problem can be solved. Looking forward to your update.

I attempted the upgrade and received “Upgrade Failure” - the unit no longer accepts a charge from the grid or outputs AC.

I am also seeing a A006 fault now.

Please advise.

@Goldi I’m sorry for the inconvenience caused. Please contact the after-sale support to repair/replace the device.

@BLUETTI_CARE Ok, thank you for your help. I’ll submit the item for repair/replacement and point to this thread for how we went through troubleshooting.

Can you please push the fix for my EB3A unit. I have the same issues. EB3A2326005360185

Thank you!

@ivanpatino Kindly provide me with the firmware version of your device as well, thank you.

Used my EB3A to supply ac power to a small freezer 120 vac and ~94Watts, unit failed with a FAULT Overload A001. Please advise.
ARM: 2062.03
DSP: 2056.13
SN: EB3A2327001158851

@2048action The firmware will be pushed for you to test. Looking forward to your update.

since this seems to be a fairly common issue and a firmware fix is available, would it be beneficial to push the update for all eb3a users?

1 Like

@Scott-Benson I’m sorry for the inconvenience. We have received both positive and negative feedback on this firmware. Therefore, we believe that this firmware is still in the testing stage and will not be pushed to all EB3A users for the time being.

I purchased my unit in Nov 2022 and planned to use it as a UPS on my home workstation (minisforum pc) and a couple of monitors. It worked fine for a couple of weeks before it started acting up with random power failures. I hadn’t discovered these forums then, but I found them now and see that this problem is rather common (sadly). I need a reliable UPS as I cannot afford to be “down” during work hours. If the EB3A is not the proper solution and Bluetti has a better solution, I’d appreciate an exchange for something reliable.

In the meantime, here’s my info as, perhaps (not holding my breath) a firmware update will help.

Post 1 of 2 since I, apparently can only post one image per post as a “new user”.

Post 2 of 2 (second image)

@BLUETTI_CARE - See my two posts above, please.

@RPPing Thanks for your information. The firmware will be pushed in 24 hours.

So, just got mine, tripped an overload notification in UPS mode too.

Noticed that the charge level dropped and the unit was warm even before the overload triggered.

Not sure if the system is continuously switching back and forth to battery if the power is “dirty”.

For the record:
ARM 2062.04
DSP 2056.13

@Traumadog The firmware (ARM206205、DSP205616) has been pushed. Looking forward to your update.

It triggered again last night, screen had a 76% charge shown with the overload indicator on, even though the power did not go out. Reset it and it still showed 76%.

Just did the firmware updates, and the device now reads 38%, down from 76% with no load.

Will see how it works.

As an aside, I took the unit off Eco mode. Are you supposed to hear a fan running? The air movement is really minimal.

Edit: as I wrote this, there was a click and the charge level jumped from 40% to 100%.

Edit 2: Sat plugged in over past 2 hours, with AC turned on but no load. Unit is warm to touch, without fan running. In looking, it seems like there is some warmth from the left side of the unit, especially in the center of that small grille. The fan is still. And looking at it, I wonder if that fan should be an exhaust, not an intake.

Same issue for my EB3A SN EB3A2218000020011. Current firmware is ARM v2057.11 and DSP v2056.10

Please push a firmware update for this unit.

@ntsu82 Please update to DSP205616、ARM205712 and test.