EB3A shows overload when not overloaded

Fairly new EB3A, plugged into 110vac outlet, fully charged. While plugged into the ac outlet, I turned on DC and left overnight charging my cell phone on the wireless charge pad. Next morning display shows 74% and OVERLOAD in red on the display. Normally the EB3A is off (ECO) in the morning and the phone is charged and the display is at 100%. There was no load on the unit except the wireless phone charge pad. I removed the 110v grid power and put it back in, unit charged to 100% and all seems normal. So why did I get a battery discharge and overload indication?

@DaveP Can you provide me with your machine SN code? I’ll have an engineer push an update to you. See if the problem still occurs after the update

The number is 90135QC22371258

Firmware code is ARM v2062.02
DSP v2056.10

I’ve tried Firmware upgrade on the app and that’s all there is.

thanks for the quick response.

@DaveP SN code is located at the bottom of the machine, 13 Arabic digits, can you check it again?


@DaveP SN code has been received and I have submitted it to the engineer for you. The update is expected to be pushed out within 8 hours, so please watch for the notification then.

Nothing heard from the engineer, so no updates have been installed. The problem surfaced again. Overload indicator on, “AC” flashing and charge level at 96% although unit has been on grid AC continuously. Only cell phone wireless was being used overnight. Neither AC nor DC buttons would respond. Unplugged from grid then reconnected and it seemed to reset. Still, something’s not right.

fwiw, I have the exact same problem. Almost every morning I see the flashing overload.
ARM V2057.11
DSP V2056.10
I have no idea how to update the fw, the app doesn’t seem to have an a check or update buttons.
This isn’t a new issue for me, I’ve seen this since I bought it from amazon Oct 11/2022.

On the app today there’s an “upgrade” to the DSP from 2056.10 to 2056.12. It’s taking a long time ‘preparing’ and not updating…yet.

Just updated. Needed get user name corrected,

@DaveP Has the problem been solved after the firmware update?

No issues on the first day. I’ll let you know if it
happens again. Thanks for the help.

1 Like

A new firmware has been pushed to your machine. Please update after connecting with Bluetooth.

Thank you. I applied the update and I’ll continue to test it over the next couple days.

1 Like

How long until this kind of update is available to other EB3A users? The unit going into overload while acting as a UPS seems to be a common issue.

@Autosaw I have given feedback to the R&D team on this issue. Will let you know once the problem is fixed :)

Is 2056.12 a new firmware for everyone? Or only certain units with issues? I just bought 3 of these units and intent for them to be used as offline UPS for my networking modem and switches. But they are all on 2056.10 DSP and there is no update option in the app.

It seems that the EB3A Cannot remain plugged into AC without anything drawing power from it, otherwise we see the Overload error.
I had the battery plugged into AC for a couple of days while connected to the car Fridge. This worked fine.
Then I just unplugged the fridge, so all I had was the EB3A connected to AC, it only took about 18 hours until I saw the Overload error this morning.
I wish there was a way for the app to notify me of this, because even though I have nothing drawing power from it, it was down to ~80%, I don’t know how to explain this.

@snowstorm @reapur
Can you please share the SN code of EB3A?
It would be good to provide the BMS and DSP version numbers as well. I will submit to the R&D department

Hello Bluetti, I’m not exactly sure which the SN code is.
Would it be in the picture I posted a few of posts above this one?
If not please tell me where to find it.