Bluetti eb3a continously disconnects AC output with silent mode on

Hello guys, I recently updated my eb3a unit DSP firmware to v2052,10 and now when the silent mode its on the DC and AC output disconnects continuously. This happened after I updated the new DSP firmware. Anyone has a solution to this issue?? Maybe there is a way to downgrade the firmware, because everything was fine till I updated the firmware.

1 Like

@Emi Welcome to the community!

1 Like

@BLUETTI you have any solution for this issue?? My unit uses European output 220v. Since I recently updated it bad stuff are happening, today when I wake up it had a high temp warning on the display, all this started to happen after I updated the DSP firmware

@Emi did you trying to uninstall the firmware? If that doesn’t work try to reset complete unit… sounds like the firmware was interrupted while it was installing.

@BLUETTI today at night the unit showed me the short warning, all this issues after the firmware update, please let me know if there is any way to downgrade the firmware to the DSP software it had??? :bangbang::bangbang::bangbang::bangbang::raised_hands::raised_hands:

@Emi We are very sorry for the inconvenience.
Based on product failure-related issues, our care team @BLUETTI_CARE will assist you in resolving them.

@Emi Please provide me with the SN and the BMS version of the EB3A, then I will check with the tech team. Thank you.

Hello guys, thanks for replying. The SN of my unit is 2242000640075. About the BMS version I have ARM v2063,02 and DSP v2052, 10. If you need any more information let me know.
It’s confirmed, after the DSP update the unit disconnects continuously when using battery with silent mode activated and can’t recharge normally through AC it always stops at 99 percent and the high temp warning it’s displayed and of course it stops the charging process. Hope you guys can help me out. The unit still on warranty and I can take it back to the seller.

@Emi I have submitted the request, and the firmware will be pushed in 24hrs. You can downgrade the firmware when you see the version for upgrading.

Thanks, I’ll keep you posted!! :clap::clap:

Hello guys, the update appeared with the number DSP 2052.97, and my unit it’s currently on DSP 2052.97. I downloaded the update and installed but it appears that doesn’t install correctly on the device because the number version doesn’t change on the app, and I continues to show me the new update. Also the issues with the unit continued, so everything indicate that the update it’s not installed. I already tried the process several times and I had the same result.
What else can I do??

@BLUETTI the update to downgrade the DSP firmware to the previous version didn’t work. I need help with this guys. What else can be done!!

the update to downgrade the DSP firmware to the previous version didn’t work. I need help with this guys. What else can be done!

@Emi If the downgrade can’t solve your problem, I think it is not the problem of firmware, but the EB3A. I suggest that you can contact the after-sale support and ask for a replacement.

I really don’t think it’s a problem with the unit, everything was fine until I updated the DSP firmware. Maybe if you guys roll out a different version with no bugs of the firmware everything can be solved??? Let me know, because it’s very disappointing that and upgrade that supposed to make the device work better does the contrary and makes it work worse. :pensive::pensive:

@Emi I’m sorry for the inconvenience. Try the following: disconnect the input, turn off ECO and power lifting mode, then use EB3A with a slightly larger AC load (e.g. around 300W) until the EB3A runs out of power and switches off automatically. Nest step, please disconnect all loads, wait for an hour or so, re-charge and see if it is fully charged.

I already discharged completely the unit and the issues continue. The main two problems it has its that, now every time it recharge from 50 percent and above never goes to 100 percent battery without triggering the high temp protection. On the other hand, only with silent mode turned on, some time when start to recharge, the unit disconnects and connects DC and AC output continously, and that it’s really bad for any device connected. I really think it’s a firmware bug because on the same condition with the older firmware everything was going great.
Please, check with the IT team if there is a new update or a firmware for my unit with no bugs.
Thanks for answering, this situation it’s uncomfortable for both of us :pensive::pensive:
I still optimistic that the problem will be solved with your help :clap::clap:

@Emi I have communicated with the IT team, and they replied that if you followed the steps mentioned above (do some cycles) and tried both old and new firmware but the problem can’t be solved, we suggest that to ask for a repair. I’m sorry for the inconvenience. You can message me with your order number and I will contact the CS Department to help you.

1 Like

dont think so . i have the exact same problems at the exact same circumstances @ this dsp version !!! pls fix