B300 no longer works after AC200Max firmware update

I updated my AC200Max to 1017.03 and it will not detect my B300. AC200 works fine on its own but B300 just flashes green light and I get BMS error code.

It’s there a way to update firmware on B300?

Normally, 034 appears if the firmware update was a fail. Please check the below and try to update the firmware again.

  1. Please remove all inputs and outputs, such as PV, mains, and loads.
  2. Upgrade the APP version to the latest, and then upgrade the firmware again
  3. Set the screen-off time to “Never”
  4. If the phone is connected to WiFi, try turning off WiFi and using data to upgrade again; or try turning off and on the phone WiFi.
  5. Clear the APP cache and try to upgrade again.
  6. Try downloading the APP again
  7. Try another mobile phone, preferably an Android device.

If 034 still appears after your firmware upgrade is successful, please check whether the extension cable is plugged in properly or change an extension cable to test.


How do you update the firmware on the B300. When I use the app to update it will only update AC200Max, which is working fine.

Hi @bluetti_draneymecom
You should be able to update the B300 firmware when they are connected to your AC200Max. What @BLUETTI_CARE is metioned is the update of the AC200Max. Because B300 dont have any screen.

Im using my B300 with a EP500Pro without the ability to update my firmware, so i cant share any screenshots. Normally the B300 Units should be shown in the App along with your AC200Max. The Problem i see here is that AC200Max doesnt reconize the B300 and dont display them in App, so you cant update the firmware on theese.

Since the problem ouccured after updating AC200Max, i assume the AC200Max is the problem and not the B300.

After following the Instructions from Bluetti, did you update the AC200Max again?


PS: Please @Selfmadestrom when answering. Thanks!

The AC200Max is updated and working fine, I can not update the firmware as it is already on the latest version. When I plug in the B300 and turn on the power the button on the B300 blinks green and the AC200Max does not recognize it any longer.

I have a feeling there is a problem with the BMS of the B300. I was wondering if there is a way to reset or update the firmware on the B300. It can not be accessed from the AC200Max as far as I can tell and I didn’t know if there is a way to update/reset the B300 so it can be detected.

@BLUETTI_CARE @Selfmadestrom

There was a similar thread to your with a couple of people experiencing the same problem. I updated my ac200max shortly after the update first became available on iOS. It worked fine afterward. I purchased a b300 a couple weeks later and it has worked just fine along with the latest update.

Question. Did you unplug your b300 when updating your ac200max? If not, I suspect it should be disconnected when updating the max.


Did the cable was lock entirely? Do you have another extension cable? You can change the cable to test again. Also, could you please provide me with the firmware version of the battery pack so I can check?

Yes, B300 was unplugged when I updated the AC200Max.

1 Like

I’m pretty sure the cable is in good order. When I plug in the B300 now I will get the code posted above, which tells me it is making good connection and the problem is definitely related to the update event. Battery Pack 1 BMS firmware is v. 1017.03

B300 used to show up under Battery Pack 2. This screen shot is with the B300 plugged in and powered on and is not detected.

I have also noticed that if I turn both units off, plug in the B300 and turn it on the AC200Max will boot up and show the 034. BMS Communication Error. It will also prompt me to update the BMS but it hangs on the screen shot below. After I give it a LONG time and wait it will eventually say “update cancelled”. Then the app will show a 0% charge and the 034. BMS Communication Error will alarm again. After several attempts of closing the app and trying to update it will eventually transfer the update to the unit and reboot. After reboot I still get the same results. AC200Max working fine with B300 blinking power button and not detected.

Could the firmware on the B300 be bricked?

when its stuck there, please try again what Bluetti care write. Most important is to clear the App cache. Are you on IOS or Android? @bluetti_draneymecom

You can also see BMS current Version v0. So the firmware isnt correct installed

@Selfmadestrom, I have completed all of these steps and is how I originally updated the AC200Max. I am using iOS. I think it is important to understand that I initially completed the upgrade as @BLUETTI_CARE suggested. The only reason the latest posting was attempted is because I have tried EVERYTHING since my original update (as @BLUETTI_CARE suggested) was completed and I can no longer access B300 through the AC200Max.

Again, BMS firmware is correctly installed on AC200MAX. (Version v1017.03 see 2nd picture in thread) I believe it shows V. 0 in the screen above because of how I booted the system. I booted with both units turned off and I turned on the B300, which made the AC200Max turn on and initialize. It appears as though when you do that it by-passes the battery on the AC200Max and it starts reading BMS information from the B300. This leads me to wonder if there is a way to recover an obvious problem with the firmware on the B300. Otherwise I will need to return the unit and have it replaced.

Thank all of you for your responses and your patience, I really would like to fix this without a return and appreciate your help.

1 Like

@bluetti_draneymecom Please disconnect AC200MAX and check if the B300 can be charged or discharged then we can know if the battery is broken.