AC200MAX failed BMS firmware update error 034

Followed instructions in the app to update the firmware, soon after I pressed update the unit started beeping, checked screen and saw an alarm was present, 034 BMS communication error. Unit won’t respond to any buttons, app says preparing update for two hours no progress green led around power button flashing

1 Like

I’m letting you know that I’m having similar problem after attempting BMS firmware update from v1017.02 to v1017.03 using Bluetti app (iPhone, Bluetooth connection) on a brand new AC200MAX. The units starts beeping and the power button flashes green. I get error codes 034 and 026. The firmware update progress stays at 0% despite waiting for an hour. Multiple reattempts at firmware update always fails. With firmware update failure, the unit is useless - cannot get DC or AC power.

1 Like

Hi @tshank90 , Are you getting BMS communication errors after upgrading ARM? Is it still possible to connect to Bluetooth?

Did you get the error after pushing the firmware through separately?

Error 034 occurs only after BMS firmware update from v1017.02 to v1017.03 via Bluetti app (v1.3.4 on iOS). The iOS app does not give option for ARM or DSP firmware upgrade. The AC200Max unit shows the following current versions installed (ARM: v4030.15, DSP: v4005.07, BMS: v0). My iPhone shows Bluetooth connected to the unit. I have reattempted firmware update several times after rebooting both the iPhone and AC200Max unit, turned off Auto Sleep on both iPhone and AC200Max unit, cleared the cache on the Bluetti iOS app, and cleared all alarms on the AC200Max unit. Each time, I can get Bluetooth connectivity. During BMS firmware update, the iOS app shows the progress bar momentarily complete 100% (presumably downloading the firmware); the progress bar then reverts back to 0% indefinitely, and the AC200Max unit starts to beep and give error 034. Checking on the iOS app’s cache, it shows it had downloaded 514.88kb data (presumably the downloaded firmware). I am using iPhone 14 Pro Max, iOS v16.1.2 (most recent updated version).

I was Informed by one of the group experts on the Bluetti Facebook page that the firmware upload issue was due to an error with the 1.34 version of the phone app, a new Android version 1.35 has already been released and the Iphone version is awaiting approval by the apple app store, In my case I used a friends Android phone with the new app and was able to complete the update, My AC200Max is now fully functional. Thank you for responding!


Hello! I have the exact same problem as you did, but the android phone method doesn’t work for me for some reason. Can you please go into more detail about how you pushed the update again after the first one failed? When I now connect to my AC200MAX with an android phone and 1.3.5 app version it shows BMS version v0.0 and there is no update button.

I would say keep trying, but first go into the app and clear the cache, it took two tries before the update completed for me.

I am having the same problem word for word as you described. Same software, IOS, phone, etc. Just got mine yesterday and worked great for a few hours until attempted firmware update.

1 Like

I’m having the same problem and attempted to use my sons phone. Still no luck but I had to login before it would give me the Firmware option.

Yeap, if you connect to the unit directly without logging in, it only allows to change the sleep timer. I’ve got a response for Bluetti Europe at Facebook where they asked for my device’s serial number and told me that the engineers are working on a fix for this issue.

Have you removed the old 1.34 app and then installed the new 1.35 app version? The firmware update problem has been confirmed that it is due to a problem within the app. The reply I got from Service was ridiculous, they wanted me to plug and unplug external batteries that I don’t have and never mentioned.

1 Like

I actually took a friends Android phone that had no Bluetti app installed and right away installed the correct 1.3.5 version. Didn’t help though because there were no update button.

As of just now there is no 1.35 IOS version. I did get a response from Bluetti stating my ACMAX200 would have to be returned. Hoping to get a refund. Owned less than 24 hours before it bricked.

1 Like

You have to log in to your account

The new iOS app is awaiting approval.

I have been informed that Bluetti engineers have found an issue in the 1.3.4 version of the Bluetti app that is causing failed firmware upgrades.

Please do not upgrade your solar generator using the 1.3.4 version of the Bluetti App.

A newer 1.3.5 version has been pushed that fixes the problem. The fixed version for Android is already available on the Google Play store. The iOS version is pending review on the Apple App store and will be available as soon as Apple approves the update.

Any device that failed the upgrade can be recovered by updating the firmware again using either the 1.3.3 or 1.3.5 version of the app.

Hello! Do you have any progress in solving your issue?

No not yet. I was told yesterday that I would be receiving an RMA in 24-48 hours. Tomorrow afternoon will be 48 hours. I’ll keep you updated.

The 24-48 hours promised to get an RMA number has come and gone. I emailed Brenda, whom I spoke with 2-days ago, and I am still waiting for a reply. I was hoping a lot of the negative feedback about the lack of customer support was in the past, but they have yet to do what they said they would. I’ve paid for a AC200MAX 61-pound brick. I will continue to press to get an RMA and eventual refund. What remains to be seen is how painful the process will be. I will keep you posted on my experience, good or bad.


I have been in contact with Bluetti customer service, and they have asked me to update the Bluetti App to the latest version, which was quoted to be v1.3.6 (maybe on the technical team side), but the latest Bluetti App on iOS is still v1.3.4 in the United States, which I am hoping will be updated soon. I too have requested return of my AC200Max unit and had responses from sales and customer service side, but I am holding out next few days to see if I can update to v1.3.5 (or v1.3.6) when made available on iOS. Also, I no longer have the option of BMS upgrade when I go into the Firmware Upgrade menu of the Bluetti App, which I am assuming has been disabled on the Bluetti server side due to ongoing issues.