UPS Problem on EB3A

Today I received my new EB3A and was hoping to use the ups function for my modem and router for when blackouts occur. Plugged the AC cord in an outlet and clicked on AC for the ups feature to show and plugged the items in. It worked for about 15 minutes or so before I noticed they were both off, then checked all the connections and pushed the AC button back on again - around 15 minutes later the same thing occurred. They were drawing 26 watts when running.

I was about to give up but decided to use something more simple - a table lamp that draws 40 watts. Before doing so I went into the app and changed the Eco mode to off (it was on by default). So far several hours later it’s working fine without shutting off, so maybe that Eco mode was the problem, I don’t know.

Just wanted to share in case others came across the same problem. My 2nd EB3A should be here next week and I’ll try the ups feature with the modem and router with that one (but first turning off Eco). Good luck :slight_smile:

3 Likes

Shortly after writing the above post something weird began happening. The fan on the unit kicked on (the irritating buzzing noise that others have reported), so I looked on the app and saw the Grid began drawing some 200 plus watts, while the AC going to the lamp was drawing the normal 40 watts, and the battery was then at 99% instead of 100.

I have no clue why this happened, so immediately shut it off. Guess I won’t be able to use these EB3A’s as a UPS device after all - drat!

2 Likes

On my 3rd test of using the UPS feature here’s what happened:

I’m testing again with a fan drawing 27 watts and it’s been running for an hour now. Within 6 minutes the battery went to 99% and the grid watt went up to top it off. I have a feeling Bluetti needs to work on the UPS function of this unit, or that something is wrong with mine.

Edit Add On: After that initial battery drain while on UPS , the fan ran at 28 watts but for only 5 hours and then it stopped. The AC light was still lit and the unit showed being in UPS mode, but there was 0 watt going to the fan. Either my unit is buggy or the UPS feature needs more work.

2 Likes

Serious problem with my EB3A when using the UPS. I, like Jayling, was going to use this for my modem & router as a UPS. After I charged it and hooked it up, I started randomly loosing Internet. So after some troubleshooting, I removed it from my modem and router and plugged in a 60watt incandescent lamp while using the EB3A as a UPS (plugged into utility power). Randomly the relay could be heard switching and when that happened, the lamp went out for about 1 second and then came back on. So that is why the EB3A was dropping my Internet connection because the modem and router were getting rebooted. Either I have a defective unit, or the UPS design doesn’t work correctly. Waiting to hear back from tech. support. Has anybody else experienced this problem?

3 Likes

Ah, so it’s not just me. In a way that’s a relief. Either we both have dodgy units or something isn’t quite right with the UPS function on these. The main reason why I ordered 3 of these (2 haven’t arrived yet), is for the UPS ability.

Ranger, I’m not sure what firmware you were on but mine was delivered with the .2. I did the 3 tests while on that firmware which all failed eventually, exactly like yours. Today I updated the firmware to .5, and the same thing happened - a brief random disconnect.

2 Likes

I’m still on the .2 firmware. I wasn’t going to do the upgrade until after I heard back from tech support. Plus, I don’t see any release notes so I can’t be sure I want the firmware upgrade. Now I know that the .5 won’t fix the problem, I’m in no hurry to do the firmware upgrade. I’ll let you know what tech support has to say about this problem.

3 Likes

I tried UPS mode with a fan drawing less than 30 W, and it cut off in less than an hour. Trying again on high at 45W. The minimum draw for continuous needs to be 0W or user selectable. A UPS needs to be, you know, uninterrupted!

Update: It went off. After going off the output screen says 6W and the case is warm. Unplugging the A/C input takes the output to 0W. This thing needs an update for sure.

2 Likes

Oh man, i created an account just to join in the convo. Driving me crazy! Brand new EB3A and on UPS bypass my PC randomly turns off! I played with making sure not a bad strip , tried 2 different AC sources (wall outlet and pure sine wave off an inverter off my other Solar setup) but I agree, it the AC will cut off just enough to reboot whatever you have on the AC outlets! I’m only drawing 150w from the EB3A. Can confirm the UPS Bypass has issues with low loads like 30W.
Anything else than a computer not a problem or but not good when using a computer. Kind of bad the UPS BYPASS does not work as advertised! I do not really know if the EB3A is meant to be used 24/7 as a poor man’s UPS (no filtering like true UPS). So I am now resorting to putting a cheap low wattage 300W UPS (like a cyberpower) in between the EB3A and the computer just to stop the random reboots. Sound counter productive but I would like to use the solar input from my panels off grid as much as possible (hence the silly idea of putting a UPS after another UPS! I won’t know how much it will draw.(hopefully not much more after the battery on the cheap UPS is full and acts like a bypass)
I am on the latest firmware (2057.05) ARM (2056.05) DSP.
The only think i can think of is the EB3A has no ground on the AC output. I wonder if this plays a factor is the weird issues when using network/computer equipment.

2 Likes

Ground on output should not be required. Devices with two prong plugs should work just like grounded devices.

2 Likes

Well so far we’re up to 5 people who are having the same problem with the UPS function on their EB3A’s - one person who commented on my thread over at Reddit on the Bluetti page had the same issue and the four of us here.

I do have another unit about to arrive tomorrow, so we’ll see how that goes. I’ll update here and over at Reddit.

1 Like

Yes, please update. Mine just shut down my computer again tonight. So frustrating!

1 Like

Just an update of more information. Over at the Bluetti Portable Power Station Club on Facebook, there are many other users having the same problem with the UPS dropouts as us. It’s been reported to support and they’re working on a fix. There is one person who was able to get an early release of the new testing firmware .08 and he reported that it basically resolved the issue - his testing had zero network outages. Another user was testing firmware .09 and .10 while they continue to work on the problem.

So, it’s a work in progress, which is good news to hear. :slight_smile:

4 Likes

Thanks for the update. Promising for sure!

1 Like

I got my second EB3A today and looking at the Firmware Upgrade page on the app, it only shows the .02 version with no way to upgrade to any other, it doesn’t even list the .05. I wondered if someone who hasn’t upgraded to .05 could check theirs to see if it’s still an option for you or not. Thanks!

Weird as I got my EB3A a week ago and it was on .02 and I upgraded it to .05 as it was available then. I wonder if they pulled the firmware because of recent issues?
My app is on android thought, is yours Apple?

Vinman, I’m the same as you - the one I got last week I was able to upgrade from .02 to .05, but the unit I got today doesn’t list anything except the .02 that I have. Maybe they took the firmware upgrades off the app for now since some people were bricking their devices, and how they’re testing new firmware versions to solve a multitude of issues. I’m not sure.

So good and wierd news! So perfect timing. On my app the .09 ARM and .10 DSP firmware update is avialable. I just downloaded it no issue with the update.
Prior to updating on .05 i had a high temp warning but it could be due to me charging from 2% to 100% but at standard rate! Wasn’t the .02 and .05 supposed to have this issue? Is so seems true as it just occured to me. After updating to .09 and .10 and the unit i think restarted and showed 2% and quickly went to 100% (sort of like deja vu from my last charging cycle). I unplugged the AC input and the high temp went away. As soon as I plugged in back the AC cord the high temp warning came back and so it is not charging at the moment via AC.
Gonna do a full power down of the EB3A right now and reboot. Hopefully it gets the high temp warning out.

Edit: Okay so I was able to make the high temp warning go away by removing PV and AC source and shutting the EB3A off. Waited about a minute and turned it back on and put back the AC source input and now the temp warning is gone and it is charging again.
I will monitor to see if the UPS BYPASS reboot issue is gone with the .09 and .10 firmware.

2 Likes

Vinman, I sure hope the new firmware does the trick for you. I made an error about not having access to the .05 on my new unit - my vpn must’ve blocked something so I changed location and the .05 was available & updated successfully. I’m on an iPhone (IOS) and there’s no further updates of .09 or .10 available for me. I wonder if they showed for you since you’re on a different phone operating system.

Perhaps. Yeah just as I read your post about the .05 not being available to you did a firmware check and it was available. Maybe give it a day or so and hopefully the new firmware will show up on your app. I also posted my experience on the FB group and reddit to get the word out the new firwmare is out.

2 Likes

@Vinman just curious… are you running from a iPhone (iOS) or other phone??