Short? or what?

EB3A2224000322650 (probably, difficult for me to read)

Very strange problem showed up this morning. Display does not show until I plug in AC or DC charge cable. When it shows up it indicates 100% charge … which cannot be right, because I know it was discharging 12VDC for about 9 ~ 10 hours yesterday evening … it should be reading about 50 ~ 60%. Also DC 12VDC is not working anymore … DC power indicator lights up then about 10 ~ 30 seconds later a ‘short’ indicator on the display panel comes on and the DC Power indicator starts to flash. If I turn off the DC power, I cannot turn it back on until I remove the AC Cord or DC Charging cord (which ever was connected) … AC output works only when the AC Cord is plugged in and UPS light is on. DC output does not work at all.

I cannot get it to accept a charge now, when I plug the AC Cord into a ‘Watt Meter’ it shows a draw of 9 watts, but only the display seems to be working … unless I plug a 120VAC device in which still works.

The EB3A was outside powering several Surveillance Cameras from about 4PM to just after 1AM when the cameras went offline. I have used the EB3A several dozen times to do this in the past without a problem … it usually powers these same Cameras for about 25 ~ 30 hours before shutting down.

I am wondering about two things:

Maybe an insect crawled in one of the vents and got itself ‘connected’ across a battery terminal and shorted out one or more of the battery cells? Or, maybe it got wet inside … there was a very heavy Dew last night, there were water droplets on the outside of the case … but that now seems unlikely because all of those have dried off a few hours after I brought it inside and the symptoms persist.

How long is the warranty … I bought this unit in July 2022 … don’t know if it is still covered and am now contemplating opening it up to see if I can find a problem but don’t want to do this if still under warranty. IF you know the length of the warranty please let me know.

If you have seen something like this happen with your EB3A and know what the cause is / was please let me know.

Update … only 15 minutes later.
I used a shop vacuum to suck air through the side vent … and shook the EB3A case several times in case there was some loose debris inside, no result.

Then I put the vacuum intake over the exhaust fan outlet … the fan began to spin quickly and the EB3A began to charge immediately. ??? not sure, but maybe the fan was ‘stuck’ and when it started to turn the ‘short’ indicator was reset then everything started to work again.

In any case it is charging now, I tested the 12VDC output and it is also working again.

Seems pretty strange to me that it wouldn’t charge or even display the correct charge level until the fan started to spin. Is there a sensor that can detect a fan problem? Seems unlikely to me.

Does anybody from Buletti have an idea of why it might have behaved this way?

1 Like

Good to read you got it going again!

Strange behaviour indeed. I wonder if it was the fan or a sensor…

I think it may be possible that the fan was stuck or jammed, preventing it from spinning properly. And then when the vacuum forced the fan to spin, it might have reset an internal sensor or triggered a mechanism, resolving the ‘short’ indicator and allowing the device to function again.

Or if it was the fan sensor, I believe some electronic devices have sensors to detect fan failures or irregularities in fan speed. So if the fan sensor detected a problem (possibly due to it being stuck), the device might have shut down or displayed errors to prevent damage. And when the vacuum forced the fan to spin, it might have signaled to the sensor that the fan was operational, allowing the device to resume normal operation.

If it was outdoors it seems quite likely to me that an insect crawled in. Maybe, if you have it outdoors regularly you could put some kind of insect-screen over the air inlets/outlets to prevent that from happening again.

I’d be curious to hear what @BLUETTI_CARE @BLUETTI make of it.

@BPR I’m sorry for the inconvenience. Please provide me with the firmware version, and then I can check if there is firmware that can solve this problem.

Sorry for the delay. I did not see this message until now. I expected to get an email when message replies are posted, but did not get any notification. I only found this message when I logged on today.

I have two EB3A devices … I believe this one is s/n 22240000322650 with firmware:
ARM v2057.11 & DSP v2056.13

I also have s/n EB3A2321001164714
ARM v2062.03 & DSP v2056.13

It could have been either one of these devices that presented the failure described above. It is most likely older of the two. After it started to work again, I charged it and put it one the shelf and used a Marine Flooded Cell Lead Acid Battery with a solar panel charger to run the IP Cameras and did not think about checking in for messages about the EB3A again until today.

@BPR Thanks for your information. We will push a firmware for you to test.

Correction s/n 2224000322650 (was too many 0’s)

@BPR Please update the firmware to ARM205712 and DSP205616. Looking forward to your update.

I tried to update firmware using iPhone … didn’t work. Then tried using Samsung Tablet … didn’t work.

Current firmware ARM 2057.11 and DSP 2056.13 … no idea how to find the ARM 205712 and DSP205616 firmware files, do I have to download these from somwhere?

How do I upgrade firmware … is there a webpage that shows me how to do this?

@BPR Please check the below step:

I do see a ‘bind’ option, only unbind. I am signed in. There are only two lines displayed … ARM version and DSP version … the current levels are displayed, there is no ‘Download’ option available.

I do see a similar home page when I log int, and do select the settings, then the Firmware Upgrade from the bottom of the settings page … but do not see an upgrade or download option that can be selected.

Should I expect the download option to show up later?

Oops … I meant that I do NOT see a ‘bind’ option, only ‘unbind’

@BPR It may be that the data has not been synchronized yet. It is recommended that you try again tomorrow.

OK, it is tomorrow … and I did see the ‘upgrade’ option for both firmware packages. I did upgrade a few minutes ago and was very surprised by the change in the battery SOC display. Can you help me understand why:

a few weeks ago I charged the EB3A to 100% and put it on the shelf and did not power it on again for more than 2 weeks. A few days ago when I noticed your reply I powered it on and the SOC reading was 99% … then changed to 98% a minute later. I didn’t pay much attention to it for the past few days, but this morning when I noticed that the firmware updates were available the SOC reading was 83% … but I have not used the EB3A to power any load during the last few weeks, it was probably powered on with no load for about 4 hours because the ECO setting was on and delay was set to 4 hours.

Then … immediately after the ARM firmware upgrade the SOC display showed 35% … it is charging (AC input) now and the fan just turned on, it is drawing just over 100W.


  1. why the substantial change in SOC display value immediately after the firmware upgrade?
  2. is it possible that the reason the EB3A original shutdown at the top of this thread occurred because the battery was actually depleted and the SOC display was not accurate?
  3. what are the implications of these short history for the lifetime of the battery? … has it been depleting its actual SOC too low until this most recent firmware upgrade?
  4. how much battery SOC value drop should I expect to see when the EB3A is powered on without any load over a 4 hour period?

one more update, re charging
Immediately after the ARM firmware upgrade the SOC display and App SOC showed 35% … the charging rate is set to silent.
I plugged in the AC cord and the EB3A began charging at slightly over 100W … about 10 minutes later the fan turned on … the SOC slowly incremented from 35% to 58% over the next 20~30 minutes … then jumped to 89% and the charge rate dropped to about 50~60W … within the next 5 minutes the SOC reached 98% and about 5 minutes after that reached 100% and charging stopped.

I suspect that the logic in the EB3A was re-calibrating the SOC measurement because of the drastic change from 58% to 89% … does this seem correct to you?

@BPR The ARM firmware of EB3A includes the calculation of SOC, so after the firmware is upgraded, a complete charge and discharge is required to correct the SOC.

Thank you, that makes sense. And does re-assure me that my battery is likely OK. I will fully discharge it to complete the SOC calibration later today.

Hello I’m having the same problem my display isn’t accurate it will go from 100% to 25% then dead, or 100%-35% Dead. if i can get an firmware update maybe that will help.
ARM Version v2062.05
DSP Version v2056.13
S/N 2238010154142

@ChrisTheGr8est For the problem of incorrect SOC, I suggest that you can do a full cycle of charge and discharge. When you do the full cycle of charge and discharge, please ignore the SOC. Please completely drain the battery until it automatically shuts down, and then charge it with AC until it is fully charged and automatically shuts down.

In addition, the firmware DSP205615 has been pushed, please update it to check.

1 Like

I installed the firmware then proceeded to drain the battery from 100% till it went dead wich was at 32% and plugged in the charger and it started at 32%. I was using a 350watt load it lasted 24 minutes the display said it would last 1 hour. I’ll charge it again and discharge it.