Firmware update fail and consequences

Updated the app and noticed that there was a firmware update- the update timed out - now I am unable to use AC which means that I cannot use my BLUETTI as a UPS or change it - I am flummoxed and desperate


Have the same problem. It just rendered my EB3A useless.

1 Like

Same here at EB3A ! Didn‘ they test their updates :rage: What is now to do ?

I now have a rather expensive paperweight

1 Like

@bluetti_startledemugmailcom @bluetti_ralimayoyahoocom @bluetti_steenlynetde
Are your mobile phones IOS system? The Tech team found the problem. There is a bug in Version IOS 2.0.0 and IOS 2.0.1. When the firmware is upgraded, it will be stuck at 0% and then fail. This problem is urgently fixed and will be fixed in iOS 2.0.2, and it is expected to be updated tomorrow. I’m sorry for the problem.

All fixed now - thank you

This is why pre-release testing of all features (firmware upgrades, AC/DC controls, etc) on both iOS and Android devices is so important, especially as more and more people use your products. It creates unnecessary frustration and problems. I hope your app team will consider this for future app updates.

@bxm6306 I have reported this problem to the APP department and hope that they can do more tests for future app updates. Thanks for your precious opinion.

Unfortunately I’m have the same problem after updating. iOS version is 2.0.2, but - red sign and BMS invalid and no chance update Bluetti EB3A.
What should I do?

@Yar Could you please take a photo and provide me with the SN aDSP version so we can push a firmware for you? Is your device 230V?

Yes, 230 volts
ARM current version-v2063.02
DSP current version-v0
Unfortunately, new users can only put one embedded media item in a post.
So that foto is ok?

@Yar Thanks for your information. The new firmware will be pushed later, You can try to update it.

Pls inform me when I can try

@Yar Please try to update the firmware to check if the problem can be solved.

Unfortunately the same problem, I tried in Bluetooth and Wi-Fi, the arrow in Firmware updates is inactivated

@Yar Did you log in with your account?

Yes, I used my username

Also I log of and login

E mail the same in accounts