EP500 Won’t Charge from wall

Does anyone have this issue? My EP500 will only charge from the wall (grid) at a rate if 3 watts. The battery has full discharged at this point and low voltage alarms go off forcing me to turn the unit off. I now have a $3000 box that does not work. The unit worked before at a rate of 500w but this is no longer the case not sure if a new firmware caused this or not. PV charging works fine so it seems to only be a AC charging issue. Appreciate any feedback. Going to call Cust Service tomorrow. 3k Box

Can you try charging to say 5-10% using any other source and try AC again? I wonder if there is some cut off where AC doesn’t work. Not normal, but just saying. If it will accept a charge via DC it is not totally broken. Send a email to service and see what they say.

Hi @Fotoboy,

Sorry for the inconvenience.
Could you please provide a video showing the problem?

@Fotoboy Please also provide your SOC, it should be full or 80.
At the same time, You can customize the working mode of EP500 and tweak the equipment’s parameters such as voltage, frequency.
JP Output: 100V/50Hz
AU Output: 240V/50Hz
US Output: 120V/60Hz
EU/UK Output: 230V/50Hz
After these are done, please try to recharge again. If it doesn’t work, the video should be provided.

SOC @ 9% and no matter what ups mode I run the unit in it won’t charge more than 2-3 watts from the grid with the fan running continuously. When I first got it, it charged at 500w to get to full charge. As I usually run in PV priority so I did not notice until poor weather than Grid power would not support PV

Need your help on how to resolve and next steps. Photo attached as video will not go through.

Steve Cross

Settings are correct for my US location.

Hi @Fotoboy Steve,

Please set the SOC (lower one is 41%, the higher one is at least 80%) according to the video I provide, and take a picture of the page. Please try to recharge once again.

Did the changes you requested but still no increase in grid charging watts

@Fotoboy Please press the middle of the screen and show me the voltage and current.

Please follow these steps:
setting-next-working mode-standard mode-yes

I tried Std Mode and all the others. They all appear to work properly and turn the unit on for grid charging at the appropriate time but something is still limiting the incoming grid wattage to 2-4 watts. I guess the question is to you, what hardware or firmware is cable of doing this? You can see from previous images that the unit is seeing the correct 120v/60 grid power source from the grid so this should exclude any home outlet or power cord issue, right? So there is some internal mechanisms limiting grid power. Let me know if there is anything else we can try and if not, what are the next steps to repair or replace the unit.

Images of the unit in std mode and no change in results

My EP500 is doing the same thing, No Grid charging watts, when the SOC is set to 40%. I tried many different things to charge the battery and only the solar input seems to work. Then I plug it into the wall over night and the battery gets charged to 100%. Next I put a KILL-a-watt meter on the plug to the EP500 and the readings were 900-1100 watts, but the EP500 said “0”. So I think Bluetti needs to fix their software !

Hi there,

Thank you for your feed back.
We are doing a video about SOC now and it will be posted on our community later.

Based on your manual and drawings, it looks like I could plug the EP500s in two seperate 110 plugs as long as they are connected to different circuit breakers. The circuit breakers must be next to each other, L1 and L2. I want your permission and OK so I do not void the warranty. If this works then you can add it to the video that you are making.

Try setting “Battery SOC Low” to 0% temporarily?

After a firmware update I had some charging issues, and I had to temporarily set the Low SOC below the current percentage to get it to work again.

I’ve tried everything. The unit DOES react to a setting that tells it to charge and the cooling fan turns on and grid pwr shows it’s charging at 2-4 watts only but it should charge at a rate of at least 500watts to get to the SOC % requested. I pushed this up to cust service on Monday 12/5 but no response. I will continue to share in this post on how they respond to a customer service issue like this

1 Like