EB70 Short error after less than 2 days of use

I bought a BLUETTI EB70 station from your store. My order for SPF-EU-13976 was placed on November 21, 2022 at 10:55 pm.

I used the station for less than 2 days and while using the EB70 it just turned off and did not want to turn on again. AC and DC stopped working. The flashlight doesn’t work either. Only a low-power laptop power supply was connected to the station.

Tried to simultaneously press 3 buttons, AC and DC buttons and other combinations of buttons, but unfortunately nothing happens.

The station responds only when the power is connected. The screen lights up but the buttons don’t work.
I send you videos and photos.

Please let me know the return procedure and the address where to send the station.

Also sent an email to sale-eu@bluettipower.com support on January 30th, but no response yet.
@BLUETTI @m.briney Guys need your help.

@taf1kkk @MaximRybalko @hellix38 @SerhiiDan @anotherOne @reddogaleks @Sergiusx @RomaNN @88sia88 @UnOuter
Guys, I see you are also facing the same issue. How are you making progress in solving the problem?

Всім привіт. Приймайте в клуб тих, в кого теж short error message ((
Як ваші успіхи у вирішенні даної проблеми?

@Yaroslav_S @Yuriy77 @Stas @Maksy @adenys @Alex1 @kirilvit @stymur @hellix38

Guys, I see you are also facing the same issue. How are you making progress in solving the problem?

Всім привіт. Приймайте в клуб тих, в кого теж short error message ((
Як ваші успіхи у вирішенні даної проблеми?

Hi! I had a long discussion with the support/sale department (approximately 1 month, e.g. sale-eu@bluettipower.com), where I put all the requested information like what is wrong, what is broken, tips on how to fix it, photos, etc. As a result, I received a return DPD label, after I found a way how to send it to Germany (DPD does not work in Ukraine now), fixed it by sending a package to Poland, and after to DPD. Now I am waiting for a replacement.
Привіт, довга дискусія з саппортом, один імейл в тиждень. Як результат, домовились про повернення при умові, що всі гарантійні умови збережені, та всі аксесуари на місці. Після отримання ДПД лейбли на повернення, була проблема відправити його. Так як дана річ відноситься до критичної інфраструктури, і вивозити з України її заборонено, хоча вона не працює((( Я про відправку офіційними перевізниками (наприклад НП). Тому знайшов людину, яка особисто доставила пакунок до Польши (Краків) у відділенні даного перевізника. Тепер чекаю на повернення. Якось так.
Всім гарного дня!

1 Like

@SerhiiDan Thanks mate! Дякую друже!
@reddogaleks Скажи, будь ласка, ти відправляв Укрпоштою? Чи через якогось іншого перевізника?

Where did you get this information about the prohibition of exporting such types of goods from? I never heard about it.
My Bluetti EB70 is on its way to the Bluetti German warehouse. Yes, neither Nova Poshta nor Meest express do not accept such type of parcel (return item) for processing. But our native Ukrposhta does it just fine. It costs about $80 you and preperly filled EMS declaration, but still this is the only (I aware about) way how to do this. With proper declaration type (return item) no German customs fees will be collected as well.
The only difference from your order is mine was made via Amazon so conversation with Bluetti representative happened there as well with much faster answers (once a day)
You can contact me on Telegram by finding my account by the same reddogaleks username I use here, if you want to know more about my case

1 Like

@Fhloston Sorry to hear about your troubles man. I absolutely love my EB70s workhorse units so its a bummer to hear about your issues. So none of the outputs will turn on when pressed? And the units screen only turns on when your power source is connected to the input? The combination of buttons, as far as I know, dont do any sort of “hard-reset” and only toggle on the frequency modes and eco mode. And that “short circuit” error code should disappear/clear itself when the unit outputs are turned off/on. I would start off by unplugging the charging brick, and if you are able to discharge the unit (turn on any outputs), I would run a constant load on it until the unit hits 0% and turns off the output/load. Then try charging it via a car charger or PV/Solar within that 12-28v range. Those t200 charging bricks have been notorious for having issues unfortunately.

I also noticed your unit is currently on 60hz… Thats common here in the US but maybe you need to have yours set to 50hz?? you could try changing that to see if that might help too?? Heres how you would do that according to the user manual…

How to operate on power station to turn ON/OFF ECO Mode
and change the working frequency:
To Enter Settings Mode: Turn “AC” mode to the off position.
Press “AC” and “DC” buttons at same time for 2 seconds to enter
“Settings” mode.
To Change Frequency Setting: Once in “Settings” mode,
press the “AC” button to switch frequency of the AC output
ports to either 50 or 60 Hz depending on your location.
Eco Mode: Once in “Settings” mode, press the “DC” button to
turn ON / OFF the ECO mode.
Exit Settings Mode: Long press the “AC” and “DC” buttons at
the same time for 2 seconds to save and exit the settings mode.

Hope this helps. Keep us posted and if it doesnt @BLUETTI will respond and get things taken care of for you.

1 Like

@m.briney Mike, thanks for the answer, mate.
The European version runs at 50 Hz (you can see it in the photo).
When connecting any device, there is no voltage on all AC and DC outputs, so there is no way to discharge the station.
I checked the voltage at the output of the AC adapter – everything is working fine.

I’ll try to use your instructions, but none of the buttons work.

@Fhloston Gotcha. Sorry, couldnt make out the 50hz on my phones display. Alright, so with the ac charging brick disconnected, you are not able to get any of the output buttons to turn on? Does the display even light up when those buttons are pressed at all?

1 Like

@m.briney Absolutely right. If the AC adapter is not connected, the screen does not light up and none of the buttons respond to pressing.

1 Like

@Fhloston strange! And they wont turn on when you have a charging source plugged into the input either?

1 Like

@m.briney Yes, when the power adapter is connected, there is no voltage at the outputs and the buttons are not pressed. I recorded a video – you can watch it on YouTube https://youtu.be/r9BnExaWBEM .

1 Like

@Fhloston Yea I watched the video but was just making sure, as sometimes the ac/dc output buttons can be a little finicky and need to be pressed individually for 2-3 seconds to actually turn on/off, and your video shows you pressing multiple buttons to engage the settings mode. Regardless tho, the screen like instantly shut off even after doing that, and between that and the output buttons not engaging at all, in my opinion, it appears that some connections from the buttons have either come loose from the pcb board, or theres something else going on within the bms.

And you said that you had emailed sale-eu@bluettipower.com correct? They are now back in the offices from their holiday break and getting caught up, so it might be a couple more days, but I will escalate this case and do what I can to make sure you’re taken care of.

@BLUETTI for attention…

1 Like

@m.briney Yes, that’s right, I emailed sale-eu@bluettipower.com but didn’t get a response from them. This failure, as far as I can see from the forum posts, is quite common.

Hello. You’re already in the club, my friend. How I solved the problem with my EB 70, I already wrote in another branch of this forum. With such an error, this station must either be repaired or replaced with a new one under warranty. I managed to do it. Despite this mistake, I liked the station, I bought another one, albeit less powerful (EB3A). It works very well, and most importantly, it charges quickly from the solar panel.

1 Like

Thanks mate for your reply. I’m glad that you were able to solve this problem.

За 1700грн мені відремонтували в сервісному центрі в Києві. Був заводський брак з шлейфом. Щось з ним зробили і все запрацювало взагалі без проблем. Виробник підтвердив заміну на новий, але відправити закордон цю посилку буде коштувати як третина самого девайса, тому дешевше було тут відремонтувати.


I’m sure you’ll be fine too

1 Like

@m.briney I tried to charge in the car – same story. The screen lights up but does not respond to any buttons. And there is no power at the outputs.

1 Like

Hi @Fhloston , Sorry for the inconvenience. Based on your situation we recommend that you return the machine to the factory for repair. I have also pressed support to make it a priority to process your email. Support is expected to get back to you within 48 hours.

1 Like