EB3A won't turn on and charge

Hi! I got a brand new power station EB3A from the official store and I can’t turn it on. It doesn’t react and when I plug in the charger to change it, it also doesn’t turn on. I have been charging (stable 220V) it from more than 24 hours already and still no reaction. I have contacted support, but didn’t get any reply. Can anybody help please?

Hi there!
Sure I will try to help you!
I experienced similar problems with both of my EB3A…
The solution is to charge the Power Station using the Solar Input for at least 24 hours!!
You can also use a Car Charging Apapter or a 12V Charger from an ihrer BLUETTI or Poweroak Power Station!
Good luck

‚Ihrer‘ means ‚an other‘!

Thank you a lot!
unfortunately, I don’t have any of that :(

Do you mean just charge it using input 12-28v, but not usual input 220-240v?

You can try both!
Normally only Solar-Input will do!

I have gone to the Electronics shop and found v12 wire. We have plugged it in and yes, the display and outputs started working, but the input is always 000 and once you unplug the wire, it turns off again. So, it gets switched on while 12v is plugged in but it doesn’t get charged. And in the mobile app I can see an error “Battery pack communication failure”

Simply keep the 12v wire connected and charge also by grid for at least 12 hours without touching any button!
I had exactly the same issue!!
Now the Power Station is working fine…

Hi Dietmar,

Thank for all you recommendations. We finally bought the 12v charger for it and for the first time I misread your last message and was sure that we just need to connect 12v wire and charge with it during 12 hours. So, apparently, it didn’t work. Then my bf connected the charger as well and it started being charged!!! Amazing!
But, unfortunately, we did touch all the buttons during this time and even charged my laptop from it at the same time. And now despite it is 100% charged, when we remove the 12v wire, it turns off again :frowning:
Is that critical that we didn’t leave it without touching aby button or we still can do that?

Hi there!
Just make sure that the Power Station has enough time to get fully charged by two Inputs without any load on the Output!
That‘s my guess.
Good luck

Having the same situation with my eb3a. It worked perfectly for 3 months, but yesterday I discharged it to 0%. After, when charging started, it immediately showed 100%, but without connecting to the grid, it turns off. How is your eb3a doing now?

1 Like

Have the same error “Battery pack communication failure” if charging via PV, inut shows 0W. If Grid, it has no errors, but the input is still 0W. The battery level stucks at 100%, but when grid disconnected the EB3A turns off instantly.