Eb3a shuts off after unplugging

Hello everyone. I have an eb3a that’s been rendered useless out of the blue. It displays 100% battery, but dies immediately after unplugging from mains or solar. It also displays “SHORT” when DC power is turned on. I tried to go through support, but it seems like they won’t do help or honor the warranty since it was a gift from a family member (who bought it new) but they can’t seem to find the original order number. Any ideas on hard resets or any other tricks??

1 Like

I have the same problem with my eb3a. Looking for a solution or fix please :pensive:

@Bogan If you unplug the charging cable, and you can’t turn it on anyway, you can try to turn on the AC and DC keys of the EB3A while the charging cable is plugged in. After 30 minutes to 1 hour, when the SOC drops to 99%, then unplug the charging cable to see if it can be turned on. Also, please provide me with the SN and the firmware version and I can check if there is any software update.

The S/N for my Eb3a is
ARM v2057.02
DSP v2056.02

I was able to get it somewhat working again after attaching the power supply from my EB70 to my Eb3a. (That and resetting the Bluetooth on my phone each time I want to connect to the Eb3a)
Now it will turn on AC and DC.
It seems to have cleared the problem.
I think perhaps this problem could be fixed in the firmware?
But it’s working again for now.

1 Like

Also, once I plugged in the power supply, it dropped out of UPS mode. Prior to that when I plugged in the A/C chord it would turn on UPS mode and I could turn on the led light but not the a/c or d/c. And it would turn off completely if I unplugged the chord. Now it works properly and the LED stays lit, the output works, and the battery shows 100%.
I hope you get a firmware update to fix this bug.

@Jim1955 Please try to update the firmware.

i had the same problem.
no, one step harder . it said something like "battery cant be recognized ".
and the same dc short Thing.
i can confirm, that dropping it to 99% fixed this .

@bluetti_chromenbgmailcom I’m sorry I don’t understand your meaning. That means that the DC short can’t be solved after doing what I mentioned? Could you please provide me with the SN and the firmware version?

Same here: yesterday 0% and power off, today i want to try to load via 230V:
Directly 100% and die Box is powered off, when i unplug the 230V AC Cable.
Box didnt load.
EDIT: Now it says 99% and 264W load via 230V
Where can i find the Firmware version in the App?

Greetings from Hamburg Germany

@hitower78 Kindly provide me with the SN and the firmware version of your EB3A and I can check if there is a latest one for you.

Same problem on mine. Leaving on a 10 day trip and now it’s not working? Looks like a couple of you managed to get it working. Thoughts?

@Akarocket Please provide me with the SN and the firmware version, I will send a firmware to you and you can test it.

youre method fixing this.
but the error is coming back . same way to fix it. my station was shutting down @about 13% battery remaining.

I noticed , that if the eb3a shows the temp error , its jumps from there to 100% without charging

never experienced that with the original firmware .

@bluetti_chromenbgmailcom Could you please provide me with the SN and the firmware version? Normally, if “temp” is reported, the temperature is too high, please place it in a ventilated place until it cools down before use.

sorry , but i dont care about the temp problem !

my device even shuts off at 48% battery. This is my problem ! And the amount of solar input , the random shut offs with the UPS @ silent mode and and and…

AND NO!! I DONT think the temperature is the reason for the warning …

or why is it shutting down @10 degree celsius + ventilator at the exact same lvl of percentage ???
it just dont care ! 34 C or 10 C . same
And why it never happened with the previous firmware ?
maybe coincidence.

pls no "did you plug the cord " -level answers .

@bluetti_chromenbgmailcom Please provide me with the SN and the firmware version. Thank you.


with the “glorious” 2052,10

If there is no input and AC or DC is not turned on, EB3A will automatically shut down after one minute. But you mean even if under UPS mode, EB3A will automatically shut down, right?

  1. Please try another load
  2. Unplug the load first, then turn on the AC. After 5 seconds, plug the load into the EB3A and try again.


yes, in the ups mode . and cant be turned on again than .
i call it “death mode” the hidden super feature. xD

and charging over the dc 8 port without any load managed to make thinks better .
even at 10% it didnt shut off (yesterday?)

will test today till death mode or maybe till 0% if it works and give a reply


@ 5% → shut down .

than it shows up with 100% and can’t hold it without ac input .

let dropping it to 99% fixes this like ever .

this is frustrating .