EB3A Problem with brand new unit

As much as I hate to air dirty laundry in public ,Bluetti deserves it.
Now on to the issue at hand, brand new EB3A updated and that went great on the firmware side.
Testing the features and yes, I know to turn the 12V on for the wireless charger to work.
The wireless charging doesn’t work on two different devices.

I tried calling and the voicemail is full and not accepting messages, emailed and no response.
Some might say, wireless charging doesn’t work no biggie. I paid for a fully functioning unit and that’s what I want. The lack of customer service after the sale is unacceptable no matter how you look at it. I will give one week for somebody from Bluetti to reach out, after that my credit card company will be getting involved and a chargeback initiated.

I’m not mad it doesn’t work. I work in manufacturing and am not perfect either, just the nature of the business. But the lack of customer service speaks volumes.


Hi @coolvdub , sorry for inconvenience.
Your EB3A is not working properly with the wireless charging feature, all other features are fine, is that right? If so, we would appreciate it if you could send us a video via wetransfer to see the problem more visually.
Thanks again for your understanding and cooperation.

1 Like

Couple of things to try: Did you turn on the “DC” button to turn on the wireless phone charge pad? Does your phone have a protective case installed? (Some cases inhibit the wireless charging and need to be removed) Try moving the phone in different positions on the pad. Lastly does your phone have wireless charging capability? (Had to ask…my phone for example does not)


Thanks for the additions, Scott.

What firmware version is available for the EB3A and how can I tell which version is in my device?

@Justacafe if you haven’t done so already, download the Bluetti app on your phone. It connects via Bluetooth. Once you do, go to the gear icon at the top right, and from that screen you’ll see Firmware Upgrades. The latest versions are Arm v2057.11 and Dsp is v2056.10.

When upgrading, keep the phone close to the EB3A and don’t interrupt the process or let the phone go to sleep, answer a text or a call, just keep the phone close. Once you do the Arm update the unit will reboot, then you can do the Dsp version. It should only take about a minute to do the upgrades. Don’t have anything plugged into the AC ports and some have suggested to not have the power cord plugged in either. Good luck to you. :slight_smile:

I will try to get a video next week, in the middle of a family emergency and had to travel out of town. What is wetransfer?

It will work but not through thick cases. Try removing the case to test, if it works then try disabling fast charge on your phone options with the case on. I have the same exact issue with my FOLD3.

Hi @coolvdub , Wetransfer is a video upload and sharing site. If it’s too much trouble for you, it’s okay to send it to us directly.

@Jayling - Thanks for the reply. I’ve had the app since I got the EB3A. When I click on the gear icon (settings) and click on Firmware Upgrades, the app just hangs and hangs and doesn’t do anything no matter how long I leave it. Not only that, it doesn’t show me the current firmware version…anywhere! In addition, I’ve tried to change the ECO mode from 4 hours to 1 hour and it will not change. I don’t get it. I’ve contacted Bluetti about this, but their customer service sucks!

@Justacafe - If your EB3A is working fine without the use of the app, I wonder if there’s something wrong with the app itself. Maybe delete it and download it again to see if that helps and make sure Bluetooth is set to On in your phone. Good luck!

I would agree. Delete the app and download again or download to a different device to see if there is a change.

I’m finally back, to answer some questions, no case on phone and it does wireless charging with a add on pad and a wireless charger I had to buy to prove my one plus buds pro would charge wirelessly and 12v was turned on. Hopefully Bluetti can tell me where and how to send the video I made directly to them. Please Bluetti, I don’t want to add another app on my device, so I would rather send directly to you.

Also completely discharged my unit and recharged hoping it would reset something, it did not.

Having same problem: wireless charging sketchy. Worked for very short time changing my iPhone, but failed to charge another ( newer) iPhone that Qi changes all the time. Have the app and latest firmware. Both iPhones out of cases.

1 Like

Have you tried turning on DC from the App? I had a similar problem and this seemed to work.

Same here, If its a android turn off fast charging in the settings this worked for me.

1 Like

Hello, I have just purchased EB3A. The wireless does not work with my iphone 13. Is Bluetti Qi Certified? I cannot find them listed on the WPC site… please advise, thanks

@Cdncamper Have you turned on the DC output of EB3A?
If your Iphone 13 has a case, please take off the case before charging.

Without sounding sarcastic…I can read. Please realize resorting to these product community chats are a last resort when one has a problem with a product.

I have; read the user manual, turned on DC manually and through the app, removed the case, downloaded the app, checked for upgrades.

I would appreciate an answer to the question regarding Qi Certified. Apple wireless search states their products will charge with Qi certified devices.
Thank you for your time and look forward to your reply.

While frustrating for a person such as yourself, most of these issues are resolved through proper operator use. A large # of users are unaware of how to perform some of the functions. When you start your question with “I have just purchased” there are basic questions that need to be asked in able to properly troubleshoot.