EB3A - no more Firmware updates via App?

Just received my EB3A, and Reviews from last week as well as Forum instructions for Firmware update show using the small gear icon in the App to see the firmware version and udpate it. But the commands are not available in the Bluetti app any more it seems (and also the layout looks different than two weeks ago in screenshots). After choosing the gear icon, I can turn on/off eco mode, set it’s timing etc, but no Firmware options are shown anywhere.
I tried it on Android and iPad, latest app version, German and even switched to English. No more Firmware updates on ipad or Android, it seems. Did they remove the feature or what am I missing here?
How to update the firmware now?

1 Like

Same here. I received mine today, and I see no option for updating the firmware. Is it because the firmware is already the latest version? Or is this just it for all time, with no ability to do firmware updates in the future, if there are any?

The one good piece of news is that it comes with the solar charging cables included.

Same here, I’ve had mine for about a week and I did notice the app appearance has changed also.
I would like to know the answer to this as well.

someone from bluetti posted in the forum under a “i can’t get a confirmation code email” type headline, that you shouldn’t update the app right now.

Hi @zap7 , The APP must be logged into the account to bind the machine and update the firmware. Is your APP the latest version? Or is it connected through someone else’s app share? You can refer to the following screenshot.

1 Like

Hi and thanks @BLUETTI ! My Android version shows up as 1.3.1 updated Oct 17th. I did not know it’s now necessary to register and account and bind the machine before having access to the Firmware upgrade.
After I followed your steps, it now works, the Firmware Upgrade is now visible + selectable:
1.) Register for an Bluetti account (from the App)
2.) Login
3.) Bind EB3A to the account

And this makes sense since otherwise, anyone near to any EB3A could connect via Bluetooth, upgrade the unit while you have devices or AC power plugged in and possible brick it.

Thanks a lot, this solves the problem! I already love my EB3A, used it to boil half a liter of water in my travel kettle in 6 minutes from battery power.

For one of the future updates, I would love to be able to set a bluetooth passcode. I completely understand that this will be to complicated for some users, but it would a great options for those of us who know how to handle it.
Have a great weekend and cheers,
zap7

Are the curent firmware versions as follows?
ARM v2057.11
DSP 2056.10

Those are the firmware numbers that it shows, and no way to update them, so I’m guessing (?) that therefore they are the current versions.

That’s the same firmware both of my EB3A are showing. I guess they auto update now, because those are different firmware numbers than both previously displayed and I haven’t manually updated them in over a month.

There is no option to update. Or im missing something? Iphone, app ver 1.3.1

Yes, exactly so. That’s what I’m seeing too.

@neverdie are you connected to your power station via guest bluetooth or by logging into your Bluetti account and then registering/binding your EB3A?

@bxm6306 I’ve tried it both ways. The first way doesn’t show any version information, and the second way (logging in and binding) shows what Profipoksija shows in his screenshot.

That’s weird then, sounds like an app bug to me as your firmware version is quite old.

What are the current version numbers, then, and how do I update to them?

Try re-installing the app and if that doesn’t help, write to service@bluettipower.com.


Current firmware versions for EB3A are:
ARM v2057.11
DSP v2056.10

Oh, I take it back. Those are the same version numbers that I have. They’re just presented in the way that Profipoksija shows, that’s all.

Same with android phone. App ver1.3.1 but no updates availible.

1 Like

I believe that “current” version is current for US residents. UK/EU seem to be forever stuck on ARM v2053.07 and DSP v2052.04 for some undefined reason. It probably explains why most of the folk complaining about poor solar performance are in UK/EU now, months ago it was US residents reporting poor solar charging (flashing Input and discharging instead) until they got the .11 and .10 updates.

@BLUETTI, are UK/EU users supposed to be able to upgrade to the newest firmware versions ARM v2057.11 and DSP v2056.10?

That’s interesting - I’m in Ireland and have bought two small panels for testing purposes and found that the EB3A was discharging significantly during the night. I put on a blocking diode and it didn’t make any difference.