Code 97 BMS temp abnormal

Getting code 97 and alarm immediately after plugging in bluetti pv350 to my brand new ac500 the very first time. Code won’t clear with cable connected. Plugged it in again and got the alarm plus code.
These connections cannot be connected wrong.
Searched thru forum and saw many many other codes but no code 97.
What to do?

@B2gx 097 menas BMS failure, and the problem may occur in the battery pack. Do you only have one battery pack? If there are multiple battery packs, connect different battery packs separately to see if an error is reported. In addition, you can put the machine in a cool place for three hours before PV charging.

There’s only the one b300s battery.
I tried unplugging everything and re-trying, but same.
The ambient temp was around 55 degrees so I assume the internal temperature couldn’t have been much different in that the unit had sat dormant all night.
It did charge ok with the ac connector the day before.
I will try tech support again tomorrow.
Yesterday I tried the number at the end of the users manual and after about what seemed like a 10 minute wait it said no support available call back later, (or something similar) and then hung up.
This doesn’t send me very good vibes.

This morning I tried again, a bit later. Plugged in the pv panel and everything worked great!
I suspect the problem yesterday was that it was cold. Even though the weather said it was 36, there was still some frost here and there. Perhaps the internal temp was too low. The users manual says it won’t charge @ 32f but there are “heaters”. Well apparently the heaters didn’t work?
I was impressed to see 400w on the meter though. These are pv350 panels. Good to see the performance.
The unit (ac500, b300s, and pv350 panels charged from 90 to 100% in about 2 hours.
I experimented with running a contractor’s level tablesaw off the system and this worked as though plugged in to the house wiring.
So far so good.

@B2gx Thanks for your update. I’m glad that the problem gets solved.

Not sure it’s solved. It seems there’s supposed to be heaters. Why didn’t they work. It wasn’t that cold. Still lots I don’t understand.

@B2gx If you have any other troubleshooting issues, please let me know and I will do my best to help you.