Can not change AC on/off and DC on/off bluetti ac200max

Hi, I can not chance DC on/off or AC on/off on the display.
I can change it only through my mobile phone app.

Whenj it is AC or DC is on, I can not change it over the Display to off. Same when AC or DC is off, the Display works well but AC or DC stays on on or off.

What can I do? Thanks. Guido

Hello @n66dles , is the AC200MAX display does not respond when pressed, or the screen does not turn on at all?

Similar Problem.
My Bluetti 200 Max is about 6 months old, and I can no longer change settings on the touchscreen.

It will not allow me to turn On or Off the AC or DC output, or change the screen time duration unless I use the App.
This problem started about 2 to 4 weeks ago when I went in morning to view the screen it was all

Jambled up. The unit should not have been low enough to turn off?

I started the charger and my screen became clear, but I could not turn the inverter or the DC output on.

Later fired up my app and noticed the app had been updated with new graphics, and I could turn things On or Off.

I need my touch screen to operate, if someone else needs control.

Can you help me?

Thank you,


1 Like

Same is happening to me, but with my EP500 Pro. I can only change limited settings from the lcd panel. I am forced to use the phone application.

The same, it stopped working a few weeks ago after updating my iPhone Bluetti application to the new one.

Hi @SteveS , If the screen is still not controlled after updating the software on the APP, then the screen is defective and you need to contact support to return for repair.

Hi @n66dles , Did you buy it from our BLUETTI DE website? If you have the order number, you can provide it to me and I will follow up with the customer service department for you.

Thank you for your confirmation, I have passed it on to my colleagues in the EBAY department, thank you!

Thank you for responding,
Here are my current versions.
Bms1 0.00
Bms2 0.00
Serial number 2220000528809
I tried updating the firmware, but not sure that it updated?
It never acknowledges that it is updating?
I tried hitting the update button on the first page that mentions firmware update, and tried hitting the button on the second page that says firmware update.
Is there a video for updating the firmware?
Thank you very much for your help.

Thanks for the confirmation, may I ask if you are using US 120V or European 230V? I will ask the engineer to push you an update.

hello, I have the same problem with my A200Max 230V EU version. I can make partial changes to the touchlcd, but I do not get them displayed.
also a factory reset, ac-out on/off etc… I can not trigger.
With the APP I also unfortunately can not do a firmware update, it only shows the installed ones. What can I do?

DSP Version: 4005.07
ARM Version: 4008.03
BMS Version: 1017.02
HMI Version: 6037.03
Is there a way to completely de-energize and reset the electronics?

greetings from Germany