Bricked EB3A just after opening

Right out of the box I attempted to do a firmware update. The EB3A was not connected to AC input, it displayed 74% charged batteries. I attempted to do the ARM update first and midway stopped responding and “timed out”.

Now the display just has 4 blinking LEDs going from left to right and the unit is not responding. This is my first Bluetti device and hoping to see if there is any hard reset to kick start this thing or if it is dead and I need an RMA. New product and zero information on the internet.

1 Like

Did you keep your phone close to the Eb3a and communicating with during the entire update process?

Yes I was sitting at my counter top and never further then 1 foot away at all times.

1 Like

Interesting. Please let us know what the resolution to the issue was.

I thought I saw something about a reset button. Ill go see if I can verify.

Nope, I think I was confusing w/ EF mini…it has a reset button. I didnt see one where i thit it would be on the EB3A. Sorry, getting my powerstation features crossed…

I really wish I had read this post first. EXACT same thing just happened to me. Delivered today and bricked within a hour from a failed firmware update. Was there any solution found?

I tried calling the support number, but either got a busy signal or “Steve’s” full voicemail box. Sent an email as well.

This is very disappointing, I was looking forward to using it.

1 Like

Perhaps you can help as well. What were the specific circumstances during your update? Phone kept by the eb3a during the entire process? Phone stayed active? Any other phone operations occurred during the update? Anything at all that you noticed odd during the process?

Nothing special. Phone was within inches of the EB3A and was always active. The installer got to around 30% (as I recall) and then timed out. The phone can still connect to the unit, but trying ARM firmware only goes to 3%. The DSP firmware will get to 100%, but never actually takes effect. No other operations from the app can be performed.

I did see on Reddit (might be from same OP) that if I let the unit run out of battery, then trying the firmware again could work. I imagine this will take days before I can test, but I’m hopeful.

Sounds like a simple reset/reboot button combination could have solved a lot of this mess.

I just has the same exact thing happen to my new EB3A. The details in the last post are same, first one went to 30% and timed out, leaving the 4 blinking line on the left side of display. When attempting second firmware got to 100% with dashes blinking on right side, yet it still show the old firmware. Now it sticks at 3%same as above post. I had the phone inches away, full charge, the EB3A just would timeout each time on first firmware, I even disconnected Bluetooth on phone for fifteen minutes. I can connect with the app, just will not upgrade firmware and the unit is bricked from any functions, light, ac, dc, display, just four blinking bars on left middle display.

1 Like

Apple or Android phone?

apple iphone 12pro, even deleted app and clear cache (hard power off), then reinstalled and same issue. all the unit does well is blink dotted lines on middle left of display, bricked and support call logged with no response yet.

Just received my EB3A. Look forward to @BLUETTI response to this experience. I just received my EB3A an hour ago.

I got mine 3 days ago and its working fine (for my purposes) without an app. so I’m going to wait it out until the issue is resolved.

1 Like

Update: After 2+ days the until finally ran out of battery and the 4 blinking dashes stopped. Unfortunately, plugging it back in now does nothing. It appears totally dead now. Will not charge back up.

On Friday I actually managed to get a person to answer the “customer” service option on the support line. She put me on hold for 15 min, and then said a engineer would call me back in a hour. To no real surprise, I never got a call back. Email support ticket from Thursday also has no reply. Bluetti Twitter account told me to “turn if off” for 20 min… not exactly sure you do that on a EB3A, and that account has not replied to me since.

At this point I see nothing that can be done other than return it, but I worry how long that is going to take to get setup, given the current rate of communication.

2 Likes

I received and updated mine before checking the blog. Fortunately mine updated quickly with no problems.

1 Like

Here is what I just sent to Bluetti support via email:

Greetings

Today I received a new EB3A. I have two problems.

  1. I did not receive an AC Charging cable in the box with the EB3A.

  2. After attempting to upgrade the firmware I received a “Main Relay Failure”.

This error came after successfully updating “ARM” to version 2057.05 but failing to upgrade the DSP firmware. It attempted to start the DSP but just stopped after 3%. I waited but there was no further movement in the upgrade.

I attempted to perform a reset on my iphone and restart the firmware upgrade. Again, nothing.

My new EB3A apparently has died. It simply says I have 65% charge even though after using my own AC Cable to charge this unit I reached a 100% level of charge prior to the attempted firmware upgrade. So it appears my EB3A has now been bricked.

I then attempted to contact your customer service phone number. However, I could not reach anyone either at customer service or tech support.

Please advise how I should proceed. Please HELP

Thank you

2 Likes

I am in the same boat as the others here. Same story lines.

1 Like

Can’t help on the non function issue but the power cord is placed in the very bottom of the box and the EB3a sits on top of it. Not real obvious and thought that may be your power cord issue.

1 Like

Update #2: Got an email from support at 4AM on Monday. They asked for a video, which seemed odd for a dead unit, but I recorded one anyways. Also supplied the serial number. After replying back first thing Monday morning, I’ve not heard anything since.

Sent a follow up email last night requesting either a fix, a replacement, or immediate refund. No reply yet.

I’m disappointed to see more and more people on here having the same issue. I really wanted to like this product, hence why I ordered minutes after it became available. Knock on wood, no issues yet with my AC200MAX and B230’s from last year.

If anyone else with the bricking problem gets useful feedback from support, please share with the rest us.

That is frustrating. I ordered an Eb3a that will be delivered tomorrow. I ordered it through Amazon just for the ability to return it easily and with their assistance (arm twisting) if anything went wrong. I received a pre-release unit for testing and it has a loud buzzing from the fan control board when the fan begins to ramp up. I ordered the second unit to see if I had a lemon or what the experience will be.