Bricked EB3A just after opening

I’m putting $1 on it happening on your second unit as well. Just a hunch.

Good to know someone had good experience w/ the firmware process.

When u r emailing support they usually look at the emails on China time so it can take 24 hrs or so to hear back. Just fyi if u r new to bluetti support.

$1…So that means you have low confidence the replacement will also be a dud so that is positive, right?? :wink:

I think it’s more likely than not because it’s an underreported issue but little confidence given the novelty of the EB3A.

1 Like

No, he thinks that my new unit will buzz and make an irritating noise from the fan regulation circuit and will have the same issue my pre-release model had. If that is the case, I will promptly return it.

1 Like

@Scott-Benson Ive not had any issues w/ EB3A i ordered from Amazon but so far all ive done is charge it (ECO mode/UPS on) but no noises. And I powered 50w tv for a few hours (dropped to 20% charge & turned off tv and recharged via AC - love having no brick)

I’m finally able to post here; had to use an alternate email address to do so, because my official Bluetti account was being blocked. I did this already once and it didn’t work but after someone at the company’s Facebook Messenger sent me a reply, asking me to sign up again, miraculously I can now post - on the secondary account.

I’ve had the same experience that everyone here on this thread has had. Even worse probably. When I got my unit and charged it up to 100%, I took it to another room and plugged it in to act as UPS, performed the requisite firmware upgrade, both ARM and DSP, and everything looked fine. Woke up in the morning to a total brick. Quickly checked the app and it showed 0% power in the unit before the app died. I was never able to connect to the unit via the app after that.

Over the course of the next several days, I attempted to make contact with anyone at this company, beginning with both telephone numbers. Both voicemails for customer service and tech support are so full they can’t take messages. It is impossible to get the help of a human. I sent tweets. I posted on the Facebook thread for this unit, on the official Bluetti page, and finally got a response on Facebook Messenger. However, they appeared bewildered and clueless that this was a widespread problem and assured me that I would hear from someone at the service email address. Of course anyone reading this is probably ROTFL at hearing that. For a brief shining moment I thought there was hope when I plugged the unit into my car’s cigarette lighter. The display came on, and showed a collection of zeros for everything except the battery, which showed 99% and “30 hours” underneath. I took a snapshot and posted it on Facebook. I tried to connect via the app, and it saw it for a brief second before it said “timed out”; thereafter it did not see it. Now there is nothing that on the unit that shows any sign of life. Whether being plugged in to DC or the AC charging cable, even the display will not come on. No combination of holding the buttons down can restore any life to this. So I finally packed the unit up on Friday, having only had it long enough to make sure it was charged up and the light worked before it became completely useless. Now it will probably be a struggle getting an RMA number, but this experience has spooked me. This was my first Bluetti, having heard much about their products, and I was eagerly looking forward to relying on this unit for what it said it could handle. They should have been better prepared, and made sure that all firmware upgrades worked before shipping the product out.


If only they had sent some units out to beta testers that could have used the product to identify issues that needed to be resolved before production and shipment.

1 Like

Hi @Dondep2, We are very sorry for the inconvenience. Regarding the problem you described, did you update your firmware to the latest version? If it still doesn’t work after the update, please contact our customer support department via
There will be a dedicated person to follow up for you, thanks for your kind understanding.

1 Like

What’s the verdict with your new unit’s fan?

Got it last night and there is a minor buzzing sound but not nearly as loud as my original unit. The fan operates strongly when needed and I have no complaint. I did perform a full charge followed by a full discharge and when attempting to recharge from 0%, I could get no charging or function. I was able to upgrade the firmware and as soon as that was completed, charging began. That was a little discouraging seeing basic such as AC charging not being functional right out of the box on a product that is released to the general public for sale.


I was able to charge my EB3A but with all the issues im reluctant to do firmware upgrade at the moment.

1 Like

Hi @roxie60 , Thank you very much for your feedback. The technical department is still optimizing the firmware, you can also wait for the latest version to be perfected before upgrading.
We appreciate your patience and understanding!

1 Like

Hi @BLUETTI , do you have any plans to publish firmware release notes to customers? This is something a lot of us would greatly appreciate!


I second this! Especially since the EU Models are on a different branch! Our most recent versions are ARM v2053.07 and DSP v2052.04 so the confusion is rather annoying.

1 Like

We definitely need patch notes. With all the problems over the years, we can see what has been fixed and discard any reported bugs that give us cause to worry.

I updated 4 x EB3A in the past 2 months without issues.