Bluetti app v2.0.3 crashing after clicking warranty button and trying to scroll

When I click the warranty button in the Bluetti Android app v2.0.3, the app freezes and crashes.
The crash happens when I let the warranty information load and when I touch the screen to scroll.

I’m using a Sony Xperia XZ1 Compact smartphone with Android 9

When I open the app again and click warranty again, Android tells me that BLUETTI keeps stopping | App info | Close app | Send feedback


@TheQuickFox Does the problem of APP crashing still happen now?

Yes, it still happens. The warranty information page loads. When I touch the screen to scroll it crashes.

I have forwarded the problem you encountered to the tech team, and once there is a solution, I will let you know.

Here the same problem, also on other pages, for example extend warranty, register product, refund and for example “Service - FAQ - Solar Panels - PV420 - How do I choose solar panels…”…

Upgraded to new Bluetti Android app v.2.1.0. Same problem.

@TheQuickFox Thank you for your continued feedback.
If it’s convenient, could you provide a video of screen recording? (Given that the forum can’t upload videos directly, the recording can be uploaded to Google drive or YouTube after completion)

May I know your phone model please?

Yes of course, thanks for the quick reaction!
Also new app v2.1.0, my phone is an Oppo Find X5 Pro with Android v13. And because you asked I also installed the app on an Oppo Find X2 Pro with Android v12, there the app works perfectly!
So it’s not working on the Oppo Find X5 Pro. What happens: When I select Warranty in the Home screen the first “page” is displayed, but when I want to scroll (so sweep) the screen becomes blank and immediately back to home screen. Selecting “About Bluetti” (and other mentioned before) same. Sometimes the result is “x close app” because the app keeps closing…

No, my phone has no screen recording feature.

Info received. The tech team is already in the process of troubleshooting. I will let you know when there is a response.

I updated to Bluetti app version 2.1.1 and it still crashes in the same way.

I may have found the cause. On desktop I notice the ungodly amount of 3rd party scripts this page is trying to load. Here my NoScript extension on PC blocks most of them but on my phone I don’t have that so it tries to load them all. On a decive with just 4GB of RAM. Perhaps the browser engine just runs out of memory and gets terminated by Android. You can try removing the 3rd party scripts on the page and I’m happy to test if it still crashes.


1 Like

@TheQuickFox Thank you and feedback has been received. I have forwarded your testing suggestion to the app development department.
They’re still in the process of debugging it.


I updated to Bluetti app version 2.1.2 and it still crashes in the same way.

Updated to 2.1.3. Still crashing as before. Is this actually being worked on? I wonder because I see many new versions come without fixing this issue.

Updated to 2.1.4. Still crashing as before.
Has it any use to keep mentioning them? I don’t see any fixes in the updates I keep installing.

The technical team has simulated your phone’s version situation:
Android 9 was released quite a while ago, and the technical team has also tried to reproduce the problem using an Android 9 phone, but they were unable to reproduce the issue. However, this does not actually affect the use of the device-related functions of the app. The warranty and other buttons extract details from the official website page.

Can you try upgrading your phone’s Android version and try again?

Same problem here with Android 13 and BLUETTI App 2.1.4.
After clicking a new page opens, but when I want to scroll up the page crashes, offers to clear the cache and I am back on the start page of the app.
Always the same behaviour after several attempts.

The latest version 2.1.5 has been released. Can you update to this version and see if the situation has improved?