Bizarre behavior of SOC indicator on my new AC200P

(I posted this in response to another post which mentioned erratic behavior of the SOC indicator in someone’s AC200P. Then I though maybe I should have started a new thread about the issue, so that’s what this is. Sorry for the redundant post.)

I just received my AC200P with three SP120 panels ten days ago. Since then I’ve used and carefully monitored the system every day. I have seen the “state of charge” (SOC) indicator behave in an strange way that seems wrong. One time I shut the system down (everything off) for the night at 88%. The next morning I plugged in the solar and, as expected, the unit came on and showed 88%, again as expected. But then about 30 seconds later the display jumped to 100% for no apparent reason (the unit had been discharged to 88% the previous evening – it was not fully charged). When the display showed 100% (even though the battery was not fully charged) of course no input from the solar panels was accepted. Eventually, by drawing power from the AC outputs, the SOC figure came down and the solar input came back. But this was a disconcerting experience.

A day or two later a very similar thing happened. I had discharged the battery down to 60% on the display, and was charging it back up with the AC adapter. It went from 60% to 90% smoothly as expected. Then, while I was watching the display, it suddenly jumped from 90% to 100% in an instant, and this of course shut off input from the AC adapter. Again I drew power from the AC output, and eventually the unit began charging again.

I have been mystified by these experiences, and there may have been more such events that I didn’t observe. I can’t spend the whole day just watching the display!

Yesterday I tried cycling the battery by running it down to 0%, and then charging it back up to 100% using the AC adapter. This seemed to go smoothly, and I have not seen another bizarre jump in the display since then, but it’s just been one day and if it happened, I probably wouldn’t have seen it. Still, I’m hopeful that by cycling the battery fully I have re-set the SOC calibration and fixed the problem. But actually, I have no idea if that is the case.

If anyone has any insights or suggestions for this issue, they would be much appreciated.

I just found this site yesterday and I read a lot of posts. I am very happy that this site exists and very much appreciate the generosity and helpfulness of many of those who post here. Thank you all very much.

I have the same issue. But it looks like it only happens when SOC is over 85%. In that state, SOC may jump up a few % a day when power off. I drained to 0%, charged up to 100% and drained down to 90%. It still happened. But if I use it and let it drain down to less than 75%, the SOC seems to be stable. Bluetti offered to replace my unit but I felt that could live with it and avoid the hassle to initiate the replacement.

Hi RogerD,
The issue is persisting for me also, even after deep cycling the battery as I described, and as you did. It may be a very common issue which many users have not yet noticed because if you’re not watching the display when it jumps, it might not be evident to the user that this has happened.

I have also decided to keep the unit because I think the situation is manageable, a return is a big hassle, and it seems likely that a replacement unit will have the same issue. My hope is that there really isn’t any problem with the battery, and only the SOC calibration is off. There is, however, the problem that the unit will not accept a charge when it reads 100%, even though the battery may not be fully charged. That’s a bummer.

Bluetti extended my warranty by half a year, so I guess it’s now 2 1/2 years instead of 2 years. So that’s good as far as it goes, but it really doesn’t address the issue at all.

I’m having the same issue. I started another post before I saw this one. Today I discharged it to 0% and I’m in the process of charging it. According to bluetti this is call deviation and told me to discharge and charge it up with an AC adapter.

When I fully discharged it seemed to have the correct wattage but I don’t have a meter to fully test it.

Hi Wex,
After I cycled the battery (100% to 0% back to 100%), the SOC indicator seemed to behave better – for awhile. Then it went back to doing sudden jumps – usually from about 88-90% and jumping up to 100%. It does this fairly often, but not every time. Sometimes it goes up gradually through the 90s, which would be more as expected.

I did some research on how the SOC (state of charge) of a battery is determined, and it’s a little complicated and not necessarily very precise. Especially with the no-doubt cheap SOC indicator on the AC200P. (I would assume that the military and NASA have very accurate SOC meters, but they probably cost more than the cost of our whole unit.)

But here’s the part that still perplexes me, and I don’t know the answer. When it jumps from, say, 90% to 100%, which is the accurate number? They both can’t be accurate, so at least one of the numbers is off. If it’s the 90% that is off, and the 100% is accurate, then it’s good that the unit shuts off all input (from solar or AC adapter) to prevent overcharging the battery. But if the 90% is accurate, and the 100% is wrong, then the unit is shutting off charging input even when there is still more battery capacity that could safely take the charge. This would not be good because it would be wasting battery capacity.

I don’t know if this is a clue, but I’m sort of hoping it is: After it jumps up to 100% from wherever, when it is then discharged through normal use, it goes down gradually through the 90s. I have never seen it jump down. My thought, then, is that the 100% is accurate. If so, then everything is working fine except the SOC indicator which is, at best, only approximate. But maybe good enough for general use.

When I inquired about the issue with Bluetti, one of their customer service reps said that the SOC indicator was “imaginary”. (Interesting word choice.) I think someone probably looked up in a Chinese-English dictionary for “not real”. I think they probably meant “approximate”.

1 Like

I wonder what the voltage is supposed to be for every cell at 100% because that would probably give us a better clue

Here’s mine at 1%

Here it is at 0%

I’ll update later what the bms says at 100% soc. If a bunch of us all share what it is at 100% I think we’ll know if it should go in for warranty work or not. I also agree that the soc is approx. you make a good point that if it’s 100% and reading wrong, no harm no foul, but if the contrary it won’t let it charge up all all way. Additionally a watt meter would be helpful

The cells can go out of balance, and we can assume that even if some of the cells are not fully charged when some of the other ones are full, then it would react and say ‘100%’, and would explain the behavior. As mentioned, cycle charging once in a while can help calibrate things.

Unfortunately Bluetti has removed the screen that shows the voltage of each individual cell of the battery, so it’s not really possible to monitor any out-of-balance situation of the cells anymore. I think this is a very unfortunate change to the user interface.
For me, cycling the battery seemed to help reduce the problem, but only briefly. Soon the issue reappeared, and has stayed.

Have you contacted bluetti regarding your warranty?

I did contact Bluetti about the issue when I first noticed it. They just told me to cycle the battery (0% to 100%) to “calibrate” the SOC indicator. As I mentioned previously, this seemed to help briefly, but then the SOC indicator “jumping” to 100% returned, and now occurs intermittently.

I’m not sure if this would be considered a defect as it is probably a characteristic of all AC200P units, though some users may not have observed it because you would have to be watching the display when it happens to catch it, and it only occurs at certain values, and then only intermittently.

However, Bluetti did extend my warranty from 2 years to 2 1/2 years, for whatever that’s worth.

My battery SOC jumps from 81% to 100% while charging after less than 2 months of use (see video - 11:53:15am @ 81%, 11:53:16am @ 100%). I noticed the jump in SOC early on when I received the unit, but didn’t think much of it. When the unit kept losing its charge overnight or after turning it off and on, I started to monitor the system via webcam (sorry for the blurry video, it is hard to get the webcam to focus on the bright screen) to get the proof I needed. Cycling the battery only fixes the SOC temporarily. Bluetti needs to enable the BMS Maintenance screen so we can figure out if any of the batteries are failing.

i thought the BMS was changed due to supply issues and it lacks the connectivity to the mainboard, it cant be ‘enabled’.

i think you charge to full and drain to empty then charge to full then it learns capacity accurately, have not tested yet

I use my ac200p in my van. I charge mostly off of my solar panels, but I have a cord I plug into sometimes at work. I noticed that the ac charger would start out fine, putting out about 455 watts, then drop off until it was only putting in about 30 watts once the battery was about 50% charged. I thought maybe it was the cold. It’s been getting chilly at night, but never below freezing in my van. I plugged in when I was over 60*F and it still happened around 50%. I tried turning it off and the SOC jumped to 100%. Hopefully that was just a glitch. It’s been up and running for almost a year now and this is the first problem I’ve had.

1 Like

Hi there,

Sorry for the inconvenience.
What’s the color of your power brick’s light when it is only put in about 30 watts?

I am having the same issue it stops charging at 56% it will charging at 460watts and then once it hits 57% it drops to only 5-10watts and the charger light goes from red to green

Hi Plpez,

Sorry for the inconvenience.
Please try to recharge again and see if the light’s color is still green. If it’s still green, please contact our customers service.

So I fully discharged it and charged it up and now it will charge up to 70% and stop there, so I will fully discharge again today and see where I can up to now , but it is getting annoying

I am having similar SOC. Issues . Unit won’t charge above 73% . adapter stays green.

And BMS cell status is all out of balance

Do I need to return the unit ?

Sorry image a but washed out there . The soc is 73 % and the AC adapter input is only 11w with green light .

BMS cells

Interesting side point is cell screen can be reached despite no navigation by tapping left hand top corner of the BMS maintenance screen repeatedly