AC500 shut down AC inverter with codes 004 and 098

The AC500 with one B300S battery had been running flawlessly for a number days in standard UPS mode and then kicked the inverter off last night with error codes 004 (battery voltage high, hardware) and 098 (BMS over voltage). The only input was 30 amp AC grid power and the only output was the AC TT30 plug to my generator transfer switch.

I cleared the codes and shut the unit off overnight and then restarted it this morning and its working fine so far but I’m a bit leery of putting any critical loads on it at the moment.

It may not be related but I had upgraded to the latest firmware a few hours before the shutdown. Prior to that the unit had worked fine for at the last 3 or 4 days using the above configuration.

Any ideas?

Hi @eric102 , Sorry for the inconvenience. Can you please provide me with the SN code of the machine and the software version? I can submit it to the relevant engineer for analysis

Thanks for the quick reply. The SN is 2234000345209. Software versions are: IOT 9041.02, ARM 4044.04, DSP 4045.05, BMS 1022.08. After yesterdays restart its been working fine so far.

Hi Eric, thanks for your confirmation.
Our technical engineers are expected to push you an update within 48 hours, so please keep an eye out for it and update it then. Thanks again for your kind understanding!

1 Like

Thanks, got them this morning, DSP v4045.06 and BMS v1022.09. Both seem to be running fine at the moment but time will tell as the previous versions would work for days before shutting the inverter down.

1 Like

I just opened a support ticket for the same exact thing. I’ve got the same software versions as the op before he got his fixes. Can you check your support email for my details?

Hi @glogulus , We are very sorry, but we do not have the authority to view emails from the support department.
Since you have already gone to write to them, please continue the email communication.
Or you can let me know your email address and I can have support prioritize your email.
Thank you very much for your understanding and cooperation.

I’m getting the same battery voltage high hardware 004 error

I’m having the same issue. I have tried calibrating by emptying battery and recharging with no load to 100%, unbinding and reconnecting to the device in aop.

IOT: 9041.02
DSP: 4045.05
ARM: 4044.04
HMI 6051.04
BMS: 1022.08

So same as others, but no updates in sight.

Update: DSP v4045.06 and BMS v1022.09 have been working well for about 6 days straight now. The AC500 has been in standard UPS mode with a 30amp AC input and its had various loads on it from 200w up to maybe 2500w. Hopefully it will continue so I can feel comfortable leaving critical loads on it when I’m not around.

1 Like

Hi @BLUETTI I haven’t heard back from anyone from service. Can you grab my email address from my profile so I don’t have to post it on a public forum?

Hi @ycoco , Sorry for the late reply, has the problem of reporting errors been solved now?
If NOT YET, please kindly send us your AC500 SN code and voltage version.
I can let our engineers push the firmware updates for you. Thanks!

What is the SN code of your machine? Is the 110V version correct?
If it is the same problem, we can ask our technical engineer to push a new firmware version to you first to try if it can be solved by upgrading.

Thanks @BLUETTI, my serial number is 223XXXXXXXXXXX and I think 110 volt for USA.

No I even switched batteries and it happened again. I tried discharging the first battery and charging it with no load that was suggested in the forum in a separate attempt prior to changing to the new battery.

The firmware update has been pushed to completion. Please follow the steps to update.

Please kindly send us your AC500 SN code and voltage version.
I can let our engineers push the firmware updates for you.

I got the updates! We’ll see how it goes for the next week or so. Thanks!

I;m now at 4405.07 DSP and v1022.09 BMS.

Not sure what voltage version is I can’t find anything labeled with that. Here is the version info and serial number from screen.

Here is the other version number I can find resent because it only lets me send one image at a time

My US 110 volt AC500 just gave the 004 error code and I found this thread. I currently have DSP Version 4045.05 and BMS version 1022.08. It reset and is working now but… @BLUETTI how can I get the firmware updates?

On a side note, I have the AC500 plugged into grid power with the Working Mode set to “Customized UPS” with the Time control off and the “Battery SOC High” limit set for 70%, so I leave battery capacity to story power from the Solar panels. When this 004 code tripped, I noticed the overall SOC was at 100%. I only have a single 370 watt panel connected right now, just for testing while I build out my array. I’m guessing the firmware allowed the grid to charge the SOC to 100% instead of stopping at 70%. (I confirmed the setting is still at 70%.) I’m adding this detail for your reference but since it sounds like there is already a firmware upgrade available, I’m hopeful that will resolve both issues (or may be the same one).