AC500 fails with 012 BUS Voltage High error

I just received my AC500 yesterday and one B300S battery. I connected my home server, desktop, network, printer, etc. and planned to use it as a UPS during periods of active grid power. Twice within the last 24 hours the AC inverter shut off with error 012 BUS High Voltage. My hardware experienced a hard shutdown immediately both times. This is not a UPS. It’s a very interruptible power supply that is significantly less reliable than the grid. At worst, it should revert to grid power in this scenario. I had to clear the code before the AC inverter would turn back on. Is there anything that can be done? The controls are very limited in the menus. I’m leaning towards a return and trying a different brand. This is completely unacceptable behavior for a device that considers itself a UPS.


From the manual: Error code 012 | Bus Voltage High | Please contact with the dealer if the error still
exists after rebooting the unit.

thanks for the response. I emailed Bluetti 12 hours ago but have not heard anything back yet.

Please make sure you include this photo of the error condition, and the serial number of the device in your e-mail to Bluetti support.

You also may want to include information on the software versions. I don’t know if the technicians will need that but better to include too much than too little information.

1 Like

Hi @backyard_glaciers , Sorry for the inconvenience.
Yes, regarding this AC500 reporting error 012, you need to contact our support department and they expect to get back to you within 72 hours. Please kindly wait, thanks for your kind cooperations.

It’s been more than 48 hours now and I’ve still not received any response from to my initial email.

The unit has failed 3 more times (on non-critical AC loads) with the same error message since then.

Just documenting for everyone else who is thinking about buying one of these. The service is as bad as the product it seems.

Welcome to the world of bluetti.
My Ac300 was also very unreliable and i couldn’t use it for nearly a month until a update fixed the problem.

1 Like

72 hours have passed from my initial email to No response yet. The unit fails consistently every few hours with the same 012. BUS Voltage High error. There’s no chance of it working correctly at this point and I didn’t just pay $4500 to do their beta testing. I’m seeking a return and never purchasing from Bluetti ever again. I hope it doesn’t come to disputing the credit card charge.

I think that the AC500 was put on the market too early, there is still a lot to do to make it more reliable. I would add that the French customer service department should provide training on the Bluetti range of products. I have repeatedly asked questions without getting an answer.
This is why I will not buy it for the moment.
The 220V 32A socket is not functional according to what I have read!

There is no 240V outlet on the AC500 (in the US at least). In the US version it’s a 50A 120V plug.

Support has asked me to verify that I’m using 120V input and then asked to leave the device turned on without the AC grid input. So far it has stayed on for more than 12 hours without the fault. (in the degraded state of not having grid power, of course). I sent my serial number and a technician is supposed to follow up with me.

Bluetti do not answer their US customer support number. They ask you to leave a message. Their mailbox is full. You end up only getting responses via email from 10pm to 6am in the US because it’s being handled by someone in China.
I regret ever getting involved with this company. They are asking for pictures of my serial numbers before an RMA number will be given. Umm, you sold me the product. You didn’t keep YOUR receipt of sale? You don’t know what serial number you gave me!?
How are they allowed to sell on amazon or through paypal? The whole company seems like a scam at this point.

I received RMA numbers and shipping labels. They determined the error I was receiving was a hardware fault and not correctable with updated firmware.

They’ve had my return for 7 days now, still no confirmation of receipt or refund processed. I filed a dispute with PayPal.

Wow, @Jean-pascal I have the Australian version, with 240 volt 32amp outlet and have been chasing support for the correct plug to fit the outlet, as I have had my changeover switch wired to take the 32 amp feed to handle the claimed 10kw peak load capability. If you are correct I will be seeking a refund

Hello Tezzawhit, Can you give us some feedback when you have tested the 220V/32A plug please?
I also hope that the “shutdown” problems mentioned on the forum are now corrected by a new firmware.
If so, I will be tempted to buy an AC500 next.
I currently have the AC300 which works very well.
It’s a pity that the 220V/32A connector is an option, it should come as standard with the AC500.
Good day to you

Hi @Jean-pascal, I have now found the 230v 32amp listed as a feature of the Australian Spec unit, and have sent this to them.

I did find a wiring diagram with a reference to the plug and socket, but now cannot find it.

We currently have a split circuit to the sub board, and an automatic voltage sensitive relay, for emergency stand by power, that will keep the power to the refrigerator, freezer and lights and ceiling fans, however I had engaged power saving so the first time it had a power outage, the AC output on the AC500 had turned off.

In testing this has worked well with about a 1kw draw, so if we resolve these issues, we will add two more B300S, to give 9kwh, which should get us through the night for extended outages, and run off solar and petrol generator during the day.

I will post when I get a response

Regards Terry

1 Like

I contacted support 6 days ago to ask the status of the refund. Still radio silence. Today is day 5 of the PayPal dispute, still no response from Bluetti there. Next stop is credit card dispute. Next stop after that is lawsuit.

My 2 battery system just gave the same error after 4 days of full operation.

1 Like

I’d recommend taking a picture of the error, sending the serial numbers from the bottoms, and getting in touch via email with support as soon as possible. Support told me this is not something they can repair with a firmware update.

1 Like