AC300 no longer works

My AC300 and two B300 have been working for about a year in an off-grid setup. A few weeks ago, the unit stopped working. I press the power button, but nothing happens. When I run a generator to the AC Input, I can only turn on the AC300. It starts up but, but does not take any charge from the solar panels, nor does it recognize the batteries. It shows me the following error codes:

  1. DC input Voltage Low
  2. D-BAT Drained
  3. BMS Low Voltage

What can I do to fix this? I have tried calling Bluetti technical support many times, but noone answers and the “voicemail box is full.” I have e-mailed them as well, but nobody has responded.


Bluetti customer support still has capacity problems. The best way to get priority support is to be Youtuber with a decent audience. But posting here also works sometimes to get prioritized. The issue with support shortage remains, and every time one user gets prioritized all other users get de-prioritized.

But back to your issue: Do you have a way to attempt to charge your B300 battery directly? There have been some users reporting a problem with the AC300/B300 combination where the battery was discharged too far for the AC300 to pick up the charging.

Have you double and triple checked the cable(s) from the AC300 to the batteries. A less than totally secure connection will cause problems.

Yes, I have checked and rechecked the cable connection and made sure they were all in the locked position.

I tried plugging some of the solar panels into one of the B300s directly but it does not seem to do anything. No lights and it won’t power on. I don’t have an AC cable for the B300 or the car adapter.

I have the same problem. AC300 with 2x B300.
I tried to load the B300 separate with a car adapter, but it doesn´t work.
B300 is in “Standby-Mode” (LED is flashing).

1 Like

If you can get your hands on a T500 power adapter that might do something. I noticed that the T500 charges at 4.56 amps. Maybe you could try going into the settings on the AC300 and setting the “Max. Grid Input Current” to 4 amps or 5 amps. I doubt it would change anything, but maybe the default 15 amps for grid input is too high when the battery is too far drained. Maybe if you input a lower level of amps the B300 BMS will allow a charge? I don’t know, but if you haven’t tried it already it’s worth a shot.

Thanks for that.
I tried different values between 1A and 5A, but it doesn‘t work.

I tried also a 12V-supply direct to the B300, but the Power-LED on the B300 are going to flash (slowly) after a few seconds…

I have the same problem, suddenly after 3 months of working well the Ac300 doesn’t function anymore. Tried everything but still it doesn’t work. Did anyone riceived a reply from Bluetti?

I recommend removing both B300 batteries from the AC300 , then connect only one B300 first and try to power the A300. If it works, then try again with the second B300 by itself. And if that works, then you may have a bad P090D cable. But if only one B300 works, then the the other B300 may be bad.

If the first test failed, then swap the cables. If it works then the removed cable is bad. But if both B300 fail, and cable swap fails, then the AC300 is bad.

1 Like

I tried all this before.
I don‘t think the ac300 or the cables are bad.

Without the ac300, I even cannot load the B300 with 12V.

Is there a reset-option in the B300 ?

I got a callback from technical support, they asked me to make a video showing the following:

Did you connect the AC300 with B300 correctly? Please remember to LOCK the cable by following the user manual or the video link: BLUETTI AC300 Battery Expansion - YouTube And could you send videos of connection for us to check please? Thank you.

If it still happens after you connect them correctly, please check the following things: (Check B300 alone with no AC300 connected please/Check all B300 separately if possible please)

  1. Can B300 turn on and off normally?

  2. Can B300 be charged?

  3. Can B300 's DC outputs work?

  4. Any cracks at the bottom of the unit? Any rattle or tink sound inside the B300?

After checking B300, please cross check each battery expansion port and try to turn on B300 first, then turn on AC300 after.

So, you may want to do the same and send it to them proactively to avoid one round trip email.


Once they’ve received the videos will you let us know what the problems is & the end result, please? Meaning how Bluetti handles your issue.

Yes, I will let you know. I suspect it will involve shipping them back.

1 Like

Thank you.
I made a short video and sent this to the customer support.
I‘ll keep you informed…


FYI, they had me ship back the two B300s for service. They think the AC300 may be ok.

1 Like

I wonder then does the ominous ‘D-Bat drained’ error code indicate external battery failure? The D might stand for ‘dumb’. I would be calling worse than that mister!

1 Like

I went through this in the spring and they actually sent me b300s by mistake which i then had to send back…

But y’all are correct, this seems to happen when the b300 is drained too low, which I thought there were supposed to be internal protection against happening… anywho, I just did it again over the weekend, they drained too low and now I have the same errors as above, as I did before.

I went through a 3rd party vendor i bought my system from and they delt with bluetti, I had no issues on that front

Looking forward to going through all this again… le sigh

I was watching a review of the b300s and AC500 and there is a setting to allow the battery to be drained beyond 0% (I forgot the name of the setting).Where I was going in relation with the b300,…If the firmware (BMS) is similar between the b300 and b300s then the b300 may have the ability to drain beyond 0% you just don’t see the setting in the menu on the AC300. This is all speculation. But if that were true then the b300 BMS would be allowed to drain past the point of recover-ability. Which is a bummer and means that you should not leave the b300 unsupervised for extended periods of time.

That is a little terrifying. I’m certain I would not have bought these if I knew about that issue. I’m surprised that would not have been fixed by now.

It makes sense though in retrospect. Both my batteries died around the same time. Mine were in an off grid setup connected via solar. The temperature dropped for a week or so below freezing, so maybe they stopped charging due to the low temp and drained to 0… Would be nice if there were a setting to cut off discharge at x% or so to prevent that from happening. These things discharge a lot (i.e. 20% per day) just sitting idle with the inverter on.

Agreed. I was posting in another discussion about how my b300 batteries don’t charge/discharge in sync. Customer support said it’s because a different chip was used in the two different batteries in my case (which is denoted by the BMS firmware version). The question is, was the chip change because of this battery issue (allowing the batteries to drain passed 0%)? Or was the chip change because they can use the same chip in both b300s and b300? So they’re cutting cost by only sourcing one chip for two different products. I will keep a close eye on my b300 batteries. I don’t want the pain of having to get one replaced.