AC200L Custom UPS with Time of Use

It appears the logic for when to charge via grid is somewhat broken. If SoC < SoC_low AND “Charge from Grid” is on, it should charge from grid even if Time of Use is enabled and it is “Peak” time. What I am seeing is SoC < SoC_low only charges from grid when time of use is disabled.

If it only charges with grid during “Off Peak” and SoC drops to 0% during “Peak”, the power supply WILL be interrupted, which is bad for a UPS.

@tripzero Welcome to the forum! :raised_hands:
During the discharge period, when SOC < SOC_low, the machine will stop discharging, and then the grid will bypass the load. Unless the load power is relatively large and requires both the grid and AC200L to supply power at the same time, the battery power will run out.

This is true only when Time of Use mode is deactivated. There may need to be one more setting in Custom UPS mode: Emergency grid SoC charge level set that behaves the same as the SoC setting in the PV Priority UPS mode. Emergency Grid SoC setting would override time of use mode and keep battery at that SoC level until other settings are active.

The test for current behavior is simple: Activate Custom UPS with Grid and Time of Use enabled. Delete all schedules. Set SoC_low to 99 and put a load on the battery. Because there is no Time of Use Schedule, system assumes Peak and Grid will never activate. Now turn off Time of Use and grid will activate.

@tripzero
Under custom UPS mode, when the battery level is too low, it will be forcibly charged to 4%. However, we are sorry that we currently cannot achieve the function of setting a specific SOC.

I did confirm that the unit forcibly charged once reaching SoC of around 0%, however, all AC and DC loads were turned off. The behavior should be to keep active loads on while charging to 4% or the SoC_low setting.

As it works right now, I cannot use Custom Mode. PV Priority Mode will probably work for this use-case, but no time of use :(.

It will force the charge to 4% after it reaches 0%. But it won’t turn off the output unless the machine has automatically shut down.

I observed it deactivating outputs twice yesterday. Is anyone else seeing this behavior?

Steps to reproduce:

  1. Custom UPS mode, Time of Use on (with schedule), grid on, DC and AC outputs on.
  2. Discharge to 0% during “Peak” schedule
    Observation: Outputs turn off, Grid input on to 4%

@tripzero
Charging to 4% is an action taken to protect the battery. In your case, it’s indeed that the battery ran out and the machine automatically shut down. Even after charging and turning it on again, the output won’t automatically turn on.
You can try turning on the ‘Charge from Gird’ option.

I have Charge from Grid ON, it just doesn’t do anything unless Time of Use is OFF like in your image. If you turn Time of Use ON and set a PEAK schedule, Charge from Grid does nothing. This seems like a bug because it causes SoC to drop below the setting and eventually interrupt the loads.

After turning on “Charge from Grid”, you also need to turn on the time control mode, for the machine to charge.

Do you mean Time Control UPS mode?

I think they were referring to using the “Time of use”, along with the Grid charging, and SoC settings in the Customized UPS mode. I have an AC200L, and have just begun to use the customized UPS mode on it a few days ago. How I use the AC200L is to power counter-top kitchen appliances, like a pressure cooker or mini oven. I cannot directly get solar power to it, so I charge it from my AC300 daily as it needs once solar has largely charged the AC300 and during peak solar hours (I have an outlet nearby to plug the AC200L into). But I only wanted it to charge via 3 amps (~360 watts) between 11 AM and 5 PM, so I set up customized UPS mode on it, as shown in the app screen capture, and that has been working. One point though, I found I needed to use the “Standard” charging mode. I had tried “Silent” and that did not seem to work.



and



Now, I have not had it get down to the 5% lower SoC, but what it is supposed to do is to switch to grid power at that point, even if it is in a peak period. So I cannot confirm it does that yet (I’m sure it’ll happen eventually).

I do have it in Silent charging mode. Are you saying when you had it on silent, the unit wouldn’t charge if SoC dropped below the SoC_low setting?

I just changed to Standard charging and set my SoC_low setting to 34% which is below the current SoC at 33%. Grid does not activate unless I change the schedule from Off Peak to Peak or turn off Time of Use altogether.



Hi @tripzero
After review by the technical team, the issue you are referring to does exist and is pending further optimization.
The team has now documented it and submitted it to the software team. It is expected to be fixed in the next release (but I’m sorry that there is no exact time yet).

2 Likes

(edited to correct my response due to my initially misunderstanding your question)

Yes, sort of. I noticed that it would not charge at all during the off-peak hours. So, it should charge, in my example, between 11:00 AM until 5:00 PM, and it should charge up to the upper SoC limit (99%), but it would not. When I set the charge mode to “standard” then it does charge during off-peak hours as intended.

I have not had my AC200L fall below the lower SoC limit of 5%, so I do not know for sure that it will use grid power to run the loads once that limit is hit, even during peak hours, but I would expect it to do so.

And it looks like Bluetti has determined that to be a specific issue to correct, so that is good! However, I ultimately didn’t care if the fan would be running more during the charging (and hadn’t intentionally put it in silent mode either, that’s just where I had it from the last time I was using it), so I put it on standard charge mode, and then it worked.

1 Like

This issue is resolved with the latest firmware. The behavior appears to be to use grid passthrough when SoC_min is reached until other conditions are met where it can fully charge. This is what I would expect. Great work team!