AC180 does not allow standard and turbo charge from generator

good morning everybody

when I charge the AC180 unit on the boat with a 220V diesel generator (Cummins ONAN 7,5 kW) I am facing the impossibility of charging with both Standard and Turbo mode.
The unit rise the charge power up to 1.000 W and then the charge is cut off. So, I can only charge in Silent mode, but the 300W are too low to have a reasonably fast charge.

I do not have any problem when the boat is connected to the “land grid” in port so I do not understand which could be the issue, considering that the electrical system is exactly the same…

by the way, I was wondering if it would be possible to add to the APP a fourth charge mode, a “custom” mode where it would be possible to set a max power level by the user.
apart from my personal reason, I guess that this could help also many other users, that may want to avoid to high loads…


@NanShan Please turn on the Grid enhancement mode to test.

1 Like

thanks for your prompt reply.

I have already tried with the grid enhancement mode with no positive result.

I guess the generator 220V electrical system is not exactly the same than the “land grid” one… but I do not have the detailed diagrams

1 Like

@NanShan Thanks for getting back to us. Could you please provide me with the SN of the AC180, then the technician will check and see if a firmware update can solve it.

SN AC1802313000655924
fyi, I have applied all the updates available through the APP prior the first use.

by the way, no chance to add a “cstom charge” mode in the APP?
point is that the jump between the 300W and 1.400W is relevant and might be worth to have an intermediate level…

1 Like

@NanShan Thank you. For the “cstom charge” mode, I will give feedback to our R & D department. But currently, it can’t be achieved.

1 Like

noted, thanks in any case for the support

Newer Bluetti power stations will reject AC charging if the incoming power has too much total harmonic distortion (THD) aka is “noisy/dirty” or if the generator’s output is not pure sine wave output . From the specs of the Cummins ONAN 7.5kW it does output pure sine wave but it might still be too noisy which could originate from other devices connected to the generator at the same time like motors or pumps.


many thanks bxm6306.
I will try then to connect the AC180 charge cord to a dedicated plug (for example the water heater has a dedicated plug and switch).
is it reasonable to help to avoid/reduce the THD?

@NanShan I’m sorry. Could you please provide me with another information for the firmware version?

unfortunately I do not have it now with me, so I cannot check the firmware version.
I performed the firmare update on the 16th June 2023.
will be back to my AC180 by Friday and will share the info required

PS: not to stress on the APP improvement side, but in the EcoFlow APP for their Delta series already implement the feature of “charge-limiting” power… so I hope also Bluetti would seriously consider to proceed with this APP upgrade…

@NanShan OK. When you’re back, here are another two pieces of information we need to check with you.

  1. Standard charging and turbo charging can’t work. What’s the specific phenomenon? Is it cut off directly, and the power remains at 0? Or when the power reaches (for example, 1000W), it suddenly drops, and then slowly increases, repeated 3 times before it is completely uncharged? Then start charging again every 2 or 3 minutes?
  2. Is the gear of the generator set to the maximum?
    With the information, the technician can check the problem more clearly. Thank you for your patience.
  1. AC180 was about 30% SOC. when standard/turbo charging I see the power quickly increasing 300W-500W-700W(maybe…) let’s say around 1.000W I hear a “click” and the power suddenly drops to zero. this repeated 3 times, followed by the final drop to 0W and the “grid” led that started blinking. I do not know if it starts charging every 2/3 minutes because, after a couple of trials by modifying the charge mode via APP with the same effect, I just set the charge to Silent mode, the only one functioning.
  2. yes the gear of the genset is set at maximum, I commonly use it with high loads, such as induction cooking 2.200W, microwave 1.400W, coffe machine 1.200W… often connected while is running also the water heater (800W) and the battery charger (400W)
1 Like

@NanShan Thanks for your detail information. If there is any update, I will get back to you ASAP.

@NanShan Please check the update from the tech team:
When the generator is charging AC180, when the output power reaches 1000W, the generator will automatically switch to a higher gear, and during this switching process, the output voltage of the generator will drop, so AC180 will recognize it as a weak grid and Disconnect input. If the voltage drop lasts for a long time (such as 500ms), then there is no way to charge it. Because there is a switching time requirement from grid-connected to off-grid under UPS mode.

Here is a solution: We can send you a software update of adjusting the power of standard charging from 1000W to 600W or 800W, then you can use your generator to charge it. Is that OK for you?


thanks again for your support.
I made fruhter trials in the past weekend… with the same results. in the APP I received an Alarm Message: “Grid Oscillation” that seems to confirm your analysis. honestly I did not noticed the alarm the previous week…
herebelow the info regarding the firware version, as you asked previously:
ARM v2074.05
DSP v2078.04
BMS v1033.05
I accept the solution you have proposed of adjusting the standard charging from 1000W to… let’s try with 800W, will then made the test and will come back to you.
just let me know how to proceed with the sw update

1 Like

@NanShan Thanks for your support. The new firmware has been sent, please try to upgrade it. If you have further problem, feel free to let me know.

perfect, thanks.
I will be able to perform the upgrade on Friday/Saturday.
I will update you in any case after the test.

@NanShan looking forward to you update.

here I am with the update.
so, firmware upgraded to v2078.05
unfortunately, problem NOT SOLVED
below the details:
1st test, “land” grid connection, standard charge (AC180 @ approx 65%) running with no problem at 880/890W. it then seems that the firmware update is performing as expected with a limitation to max charge power (a bit higher than 800W)
2nd test, genererator grid coonection (ONAN7,5kW), standard charge: the charging power is NOT limited to 880W, but continues over the 1.000-1.200W, with the “original” problem of charge disconection etc. etc.
can you understand why the power limit is working ONLY with land grid and with the generator no limit?
tried this several times, including grid enhancement activiation

1 Like