WIFI will not connect on new App as of 6/11/23: Information Only

On my EP500 Pro after downloading the latest Bluetti App I could not connect with WIFI. I performed the following to try and resolve the problem.
Turned off and on the WIFI on the Bluetti.
Checked my phones WIFI to make sure that it was on and turned it off and back on.
I could connect with Bluetooth with no problems.
Tried several times to connect with WIFI but received Connection Timeout.
Uninstalled the App and reinstalled the App.
Tried the same above processes with same results.
I restarted my phone and had same failure.
After trying all of the above and more In the App, I went into Add Device, Add Device Manually and I could see my device in there. I clicked on the Device SN and it said “Device Bound”. I did it again and it came back with the same response. I went back one screen and clicked on the Device picture and went into Connection Method Cloud. It came up showing that I was getting wattage from the Grid and showing the Load wattage. I did not get any Connection Timeout messages.
I began to try to break this in various ways by restarting the phone, getting out of the App and coming back into it. turning off and on the WIFI on the phone and the Bluetti, restarting the EP500 Pro, and other methods. Everything that I did would not break the WIFI connection. I have only been testing this App for several hours now. I have not had any timeouts or disconnects. It looks very reliable at this time.
It appears at least with my machine that Bluetti has a problem with the Device Binding in the latest App. I have an Android phone and was getting the App from the Google Play Store. I have never had this problem with previous versions of this App on my machine.

IOT: 9014.10
ARM: 4034.09
DSP: 4033.14
'BMS: 1008.02


@Jerry822 Thanks for your feedback. After the new version of the APP is released, the IOT service is also released, so it needs to be restarted. After the IOT service is restored normally, the IOT board will automatically reconnect, but there will be a small number of devices that cannot be connected, so it is necessary to re-open the WiFi on the display to restart the IOT board.

My WiFi connection is now working
The problem was your misleading instruction about the network configuration.
The App displays: “Please enter your WiFi password”
This is a totally wrong instruction. :-1:

Correct is: Please enter the WPA number (network key) for your router. :+1:

I entered the key to my router and then immediately had the WiFi connection with your APP.
My FRITZ!Box Router 7530 FR _ WPA number: 9704 9618 1106 8973 8022

If BlueTTI writes this in English in such a misleading way :face_with_spiral_eyes:, then I am not surprised that many people have this problem with the W-LAN connection. :woozy_face:

Klaus Winterhalder
15. June 2023