Whoa, Touchscreen now works, all the things I could not do, now works; AC/DC on/off, change current input limit.👍

At first the touchscreen went dark, so I powered everything off and back on, and now it works like it’s supposed to.


I think that for many malfunctions it is good practice to perform a reboot first, especially if the malfunctions occur after a firmware update or setting of various parameters.
Basically the same as recommended for a PC.
The factory reset could also be performed as a last resort.

1 Like

Well, the Touchscreen problems were from day one, where I could change certain things only through the App. I filed the problem with support, but nothing fixed it. I was under the impression that it needed to be replaced and I was in no hurry to ship the unit back.

They must have done something on their end because the APP also had a minor change; they changed where “Factory Reset” was listed because I could not find it at first. (It never seems to do anything.) This was like the 4th time I powered down (for other reasons), so that wasn’t it.

I was missing the option Firmware Update in the App after an update.
After restarting the App the Firmware update option was back.
Perhaps it is also good to go through the parameters after any update, to see if they are still correct.

Yeah, I had trouble finding it too. You have to connect through Bluetooth instead of the Cloud to see it in the menu.
From the Home page, tap “My Devices,” then the 3 dots at the top right of the screen. This will bring up a small menu at the bottom. Choose Bluetooth.

1 Like