Problem with displaying the real charge percentage on the eb3a display

I’m having trouble displaying the charge level on the EB3A charging station display. The station turns off completely when the charge drops below 20%. But when I put it on charge and turn it on again, the charge is shown at a level of more than 50% immediately.
After that, the station quickly gains a charge from 50 to 99% and then charges at 99% for 40 minutes approximately…
In general, it is not possible to rely on the display at all.
Maybe someone knows how to solve this problem?


Charge completely, and drain the battery completely without interruption, recharge to 100% without interruption and repeat. See if that solves the issue.

1 Like

@bluetti_zolotayagoryachkagmailcom At the time when SOC is below 20%, what device did you load with EB3A?

Upgrade the Firmware with the App!
Use dual input for fully charging- by Grid AND Solar-Input, for example with a extra (Car-)Charger.

@Dietmar Has the issue been resolved with a firmware upgrade?

As I am using Dual Charging: yes!
It seems to be a Duty to use the Solar-Input at least!

@Dietmar Thanks for your feedback.

Unfortunately, it didn’t help.

It’s always different gadgets. Sometimes - MacBook Air, sometimes - different phones.
This problem was from the very beginning when I bought the station. Like half a year.

Hi! Firmware is up to date. And I have no other options for charging than from the socket.

@bluetti_zolotayagoryachkagmailcom Could you please provide me with the firmware version and the SN of the EB3A so we can check if there is a firmware for upgrading? Is your device 230V?

ARM V2063.02, DSP V2052.10.
SN: 2236004317392.
It says 220-240V.

@bluetti_zolotayagoryachkagmailcom Thank you. I’m sorry the tech team confirmed that the firmware is the latest one. You can try to do several charge and discharge cycles to correct the SOC. If it can’t be solved, please contact the support.

1 Like

Hello, I have a verry similar problem with my bluetti EB3A, It turns off at about 16% then when I plug it in, it immediately starts to charge from 47% to 99% where it takes very long to fully charge to 100%. I tried fully charging it in standard mode than discharging it on a constant rate several times and the problem persists… Serial EB3A2227000747827 Firmware: ARM v2053.07 DSP v2052.10

I also have the other isssue I see mentioned a lot in this forum with the unit periodically turning AC off in UPS mode…

Please help, thank you !

Update, so after I wrote the above I tried to completely discharge it again at a constant rate, with just a light bulb pulling 158W, nothing else. This time it went down a little bit further than usual, down to 9% where it switched off… When I plug it back in it says directly 100% and now no matter what I do it will not start charging anymore, neither from the socket nor from PV… it just says 100% and AC invertor only turns on in UPC mode, if plugged in, as soon as I take out the power chord it turns off… The battery is empty because I just went an entire 2h cycle with the light bulb to discharge it, but it will not charge anymore because it thinks it’s at 100%. At this point I do not know what to do anymore but wait for your reply.

Contact Bluetti support for a replacement

Ok I did wrote an email, is that the best/quickest way to do it? Asking about quickest way to get a response because it so happens I noticed the company is in Germany and on Sunday I am travelling to the south of Germany (Stuttgart area). Maybe if I get a response in time and they have a service or an office in that area I can take the unit with me… Even to mail it will be much cheaper to do it from there. Would be nice if I get a reply before I leave…

I am not sure how responsive the customer service is in Germany but as a customer I would expect a response within 24 to 48 hours.

What is the current firmware for the EB3A