New AC300 Firmware - Keeps timing out?

Hi All,
I see there’s new IoT Firmware available for the AC300, but everytime I start it, it seems to time out. Any ideas? Thus far I’ve made it a maximum of 49% while downloading before timing out.

Been trying different things - powering bluetooth on off on both the phone and the AC300 etc - no luck. Tried my iPad and iPhone etc. All running iOS 15.2 with latest Bluetti app - version 1.1.1.

Thanks!

So I’ve been trying this on and off for the past week - I’ve probably tried to update the firmware 50 or more times (lol I know!) and just tried again this morning on a whim… and it it worked! I’ve made no changes on my end (no app updates, phone updates, etc) so guessing it was a backend BLUETTI change - but regardless, it updated correctly!

Thanks!

1 Like

Good job! You are :+1:. If other customers have the same issue, you are welcome to share your experience with them

I am not sure what you are saying here. I too am having a repeated timeout for both the ARM & DPS updates. My AC300 is connected both to BT & WiFi. The IoT update worked just fine. mbezzo did not “find” a solution, he performed what to me would be an ANNOYing amount of tries, and it happened to work. So I would like to know is mbezzo being congratulated for trying 50+ times and getting lucky, or did I miss something?

yup, it was a complete PITA but for what it’s worth since that initial issue it has not had a problem (and there’s been several firmware updates since then). So, NO idea how/why it was so problematic to start with, but it has been smooth since. And yep, the Bluetti comment make zero sense - but I just presume that was a bit of a language barrier issue…