New AC200MAX shows 0 watts being consumed

Hey Folks,

I’ve just received a new AC200MAX, not matter what I connect to it the device and the app show 0 watts being delivered even though the devices I connect all work (yes the AC is on :-)) I’ve connected 4 devices at the same time, heat gun, heaters, battery chargers and they all work, but the unit shows zero watts being consumed. I’ve tried unplugging everything and rebooting the unit to no avail. I’ve reached out to bluetti support but am not getting a response and now the support threads are all locked so I cannot post there. I’ve also tried calling and just get a “full e-mail box message” I’ve tried scouring the internet for solutions but really cant find anything. I’m hoping someone here has a suggestion :slight_smile: Thank in advance for your help!!!

Hi @chaddell , sorry for inconvenience.
AC200MAX works fine right?
If so, this should be a problem with the screen display. Can you please provide us with the serial number? Also, could you please share your email address?
We will ask our customer service department to follow up with you as soon as possible, thank you for your cooperation.