I need to lower Max Grid Input Current

Good day,

My newly purchased AC300+B300 arrived a couple of days ago. While doing the initial charge I’ve noticed that the outlet gets pretty warm/hot. I am planning to do full discharge/recharge with a watt-meter this weekend to check the battery capacity and can imagine the outlet/wiring will get even hotter during the full charge cycle time (the wiring in my house is kinda old as well). Therefore, I would like to lower the Max Grid Input Current (seems like 10 Amps is the minimum possible). So I need the safety password.

I am more than familiar with electric theory and fully understand the consequences of setting the current input too high (in-wall wiring heating and possibility of fire, damages, injury and death).

I wrote an email to BLUETTI support, but no reply so far. I would really appreciate if someone from BLUETTI support could provide me the password before this weekend, so I can recharge my AC300+B300 at a lower current after full discharge.

You can set the max grid input current down to as low as 10A. You will have to email them to get a password as that setting is locked for some reason. The default is 15A.

I have an AC source that can only supply 800w, so I asked to lower the range so it can be set to 5-30A, but didn’t really hear back.

Have you considered rewiring the outlet circuit all the way to the breaker? I did some rewiring in my home that is 45 years old just to be sure for the AC300 and B300 set to work correctly, including a new L14-30R outlet and a new 40 A breaker.
Edit: I forgot to write that my home is 100% reinforced concrete, so if I can do my own modification, so should you.

i asked for a password on a friday night via email and heard back on monday evening. service@bluettipower.com

Thank you for all you helpful replies, people, I really appreciate it! BLUETTI did reply to me in an email just today with the password. And I do plan to rewire the house (or at least a few of the most loaded outlets), but at this time I’m just trying to test the battery capacity of the new unit asap.

1 Like

I do believe Bluetti should drop the password requirement for people who want to LOWER the amperage.

I need some more help. I have tried to use the code and for some reason the default 15 Amp number does not change. I entered the code and the password dialog went away. I also accepted the disclaimer (clicked “yes”). Then I press on the “10A” button (system beeps and “10A” button changes color as it’s pressed), but nothing changes and the Max Grid Input Current is still displayed as “15A”. I also installed all the latest updates. Any idea why the default 15A does not change for me?

Edit: I have also just tried to enter 10 as a “Custom” setting. Still no change and the default 15 Amps is displayed. Wondering if it’s a bug in the latest firmware or if it’s a hardware issue with my unit.

I have tried a few things by now (fully shutting down the system, disconnecting B300 from AC300, holding the the amps preset buttons instead of just tapping and more) but the default 15 Amps value just does not change in the input current settings. I also watched a video where a person was adjusting the max input current on AC300 and the value changed on the display immediately as he was pressing the buttons.

I am really hoping it’s just a bug in the latest firmware update. Wish I have tried changing the input current before I installed all the latest updates to confirm or deny this theory. I will try calling support tomorrow to see if it’s a known issue with latest firmware or if my unit could be defective.

I would really appreciate if someone with AC300 and the latest firmware could maybe confirm or deny the same behavior on their system.

I have the latest firmware (at least the app says so) and I was just able to change from 10A to 12A and back to 10A as a test.

Thank you, Tim! I’ll be calling BLUETTI in a couple of hours to see what they say.

One other strange thing I’ve noticed about my unit: when I connected it the first time, the battery was at 60%. Then in a matter of 5 minutes the charge went to 95% (unusually fast). Then it slowed down at 98% for 45mins+. I’ve read in other threads that charge can be off due to calibration, but was still wondering why it went from 60 to 90+ in a matter of few minutes and if there’s a problem. Now taking into account that input current doesn’t change, I wonder if it’s related and there is some issue with my unit.

Let me know what video you watched showing the reset process. Send me the url and I will watch to make sure I am doing correctly. I seem to have the same problem as you are describing.
I updated my firmware when setting up initially.

Update: I have wrote an email to BLUETTI with all the details. Also I have tried to drain the charge a bit and see how much power is drawn. I wanted to determine whether the input current is changing and only the screen does not update or if the current does not change at all when pressing buttons. I have determined that it’s the latter, that the input current does not change at all. I connected the system through a watt-meter to AC outlet and the current drawn was 1650+ watt and did not change when I was selecting different amperage.

Here is a video of trying to change the input current:

I wrote an email with problem details and video to service@bluettipower.com last Friday, but hasn’t had any replies. @BLUETTI may I please get some kind of status update on this issue?

Hi @premudriy,

Sorry for your problem.
Pls provide your email address, I will ask my colleague to check it.

@BLUETTI I have sent my email in private message to you. Thank you!

have you tried going back one screen after entering the number your want? I think that might have worked for me-there was something funny about it but I don’t remember exactly what.

I tried everything I possibly could. I was hoping that maybe the current is adjusting, but the numbers in UI don’t. That wasn’t the case as checked via a watt-meter. I tried to hold buttons, go out to parent menu and back, rebooting and many other things. Nothing worked.

I also have received an email from support today and they are suggesting currently to perform the factory reset. Except that I don’t have factory reset option in settings and all the updates installed. I emailed support back with photos of my settings page. Something is definitely not ok on my unit because that option isn’t there. I’m hoping it’s just a software issue that still can be rectified somehow without sending the unit back. Maybe there is some secret startup procedure/buttons-dance that will allow me to perform an equivalent of factory reset.

Just an update on my issue: when BLUETTI support saw that the “Factory Reset” button is missing on my unit with all the latest updates installed, they have created an RMA for me. I have shipped the AC300 with all the wires back to BLUETTI. Support email said that once they receive my unit, they will send me another AC300 (hopefully soon).

1 Like

Update: I have received the replacement AC300 today and everything works well in the initial tests. I will do discharge/charge tomorrow to calibrate the battery percentage reading. I have also installed the latest updates again and re-tested all the outputs after that. The Settings menu definitely looks different from my previous unit and it now has factory reset and a silent mode options.

One other interesting thing about this new unit is that the fan turns on during charging and the AC300 stays completely cool during charge. In the previous AC300 I have not heard the fan turning on during charging at all (only during discharging) and the unit was warm. The HMI version in this replacement unit is 6029.09 (previous unit was 6029.04). I think BLUETTI either added a fan to the charging power supply in this HW revision or my previous unit had a non-working fan.

Overall I am very happy about this replacement unit so far and am very thankful to the BLUETTI support and everyone here who helped me.

2 Likes

Hi @premudriy,

Glad to hear that you are happy with our unit.
About the fan, it will turn on automatically if the unit reaches a certain temperature or watts.