How to apply "pushed" firmware upgrade for AC200Max

I’ve been in contact with Bluetti support and they’ve had their engineers push an update to my unit, however I’m having problems applying this update. It just sticks at 0% as shown in the photo at the following link.


The phone I’m using:

  • has the latest (Android) version of the app

  • has a strong wifi connection to our fibre broadband

  • has bluetooth enabled (connection to the AC200Max confirmed)

  • is right on top of the AC200Max unit (I’ve also tried it just 30-60cms away)

It just sticks at 0% no matter how long I leave it. I’ve tried rebooting the phone, uninstalling/reinstallling the app and unbinding then re-binding the AC200Max to the account.

Any ideas?

I’m letting you know that I’m having similar problem after attempting BMS firmware update from v1017.02 to v1017.03 using Bluetti app (iPhone, Bluetooth connection) on a brand new AC200MAX. The units starts beeping and the power button flashes green. I get error codes 034 and 026. The firmware update progress stays at 0% despite waiting for an hour. Multiple reattempts at firmware update always fails. With firmware update failure, the unit is useless - cannot get DC or AC power.

1 Like

That is exactly what my AC200max is doing after trying to install the BMS firmware update yesterday, mine will turn on and then go into alarm for BMS communication failure and also shows 026 in the alarm history screen. Mine was fully charged to 100% when I attempted the update using an updated iPhone 12, also tried my iPad and my wife’s iPhone. Frustrated to say the least, it’s only a few weeks old.

All same problems…
See you,

The same issue. Could upgrade it after 3rd retry. But it lost current charge from 93 to 52 %. Hope it back after recharge.

I just got my 200Max and the app said there was a upgrade to the firmware. I tried doing it, it wiped out my old version and comes up with a communication error.
I now have a 50 plus giant paperweight. The bad news I got it for protection from storms like the current one. Disappointed…

Turn it off/on and try to update firmware again. It helped me

I tried what you emailed me. It didn’t work. The current version is 0.00, battery listed as standby and I continue to get a BMS communication error #34.

I wish a person could go to their website and download any of the software needed to run this unit.

Thanks for trying to help me.
Larry Moore

The Apple App Store now has the updated Bluetti App version 1.3.5. Unfortunately, the iOS update did not solve the firmware upgrade issue, as I am still having 034 BMS Communication Error after updating my Bluetti App to version 1.3.5, clearing the Bluetti App cache, and attempting BMS firmware upgrade. The Bluetti App will show the BMS Upgrade progress bar momentarily flash to 100% as it downloads 514.88Kb of data and then hang indefinitely at 0% with the AC200MAX unit beeping approximately 45 seconds into the firmware update process. After attempting this several times without success, I am concluding that upgrading the Bluetti App to version 1.3.5 does not solve the 034 BMS firmware update problem, at least for my iPhone 14 Pro Max running iOS 16.1.2, which is the most updated iOS version presently. Please let me know if there are any firmware upgrade success stories from iPhone users out there.

I have the same problem with AC500. At the end of charging cycle, pv or ac, the 004 error appears and the ac to my fridge and freezer shuts down. I received a 1022.09 BMS update from bluetti service and when I tried to upgrade the communication times out and fails. I sent a video, they are looking into it.

I have been seeing multiple forum entries now with AC200 Max units becoming inoperable after trying to do updates. My unit is functioning fine - I received it in Sept 2022 and will NOT be attempting any updates until i am confident these issues have been resolved. I hope these issues are addressed by Bluetti as soon as possible.