EP500 Pro - LCD display not really working any longer (system stuck)

The LCD display of my EP500 Pro is half-functional only since today: I can switch through the different tabs/menus and individual settings, but changes to settings are not becoming active. Like if the system is stuck or something. Resetting the device does not work either as I face the same issue with not accepting my commands/settings in the reset panel.

Connecting via Bluetooth does no longer work either, via Cloud only for now.

The firmware version is: DSP 4055.02, ARM 4039.05, BMS 1020.01, HMI 6036.06

Any help is welcome,

kind regards, mistersixt.

1 Like

Hey @mistersixt
Did you try to turn off the unit completly? Not just the “off” Button, the Master Switch on the backside too. Would give it a try, leave it for a moment in this state and start the unit again.

I dont know how theese units are constructed inside, computers cant save their BIOS Settings if the Bios Battery is empty. Maybe somthing like this can be the case here too?!


Yes, tried this, too, the problem remains unfortunately.

I found two reports from two other users that mentioned the very same issue (on Reddit), and it turned out that the LCD display probably needs to be replaced/repaired).

@BLUETTI_CARE Can you assist @mistersixt with this case?

1 Like

@mistersixt For the problem with the screen, please provide me with the SN and I can send you a new firmware to test if it works. In addition, for next problem,

did you try turning it off and turning it on again to check if Bluetooth can be connected?

I have found in the meantime that I can connect via Bluetooth every tenth attempt or so.

The LCD display issue with not being able to pass setting changes to the system remains also (tried switching off/on the device of course, several times).

@mistersixt Please provide me with the SN and I can send you an ARM firmware, then you can try to update it to check if this issue can be solved. If not, the unit needs to be repaired.

So… I was in contact with BLUETTI_CARE, provided the SN and further details… they promised to provide a new firmware, which might fix the issue, but the app is not showing any firmware update since the last few days, and BLUETTI_CARE is no longer responding to my messages.

This is a bad service!

In the meantime my other Bluetti device, an AC300, is having the very same error with the display: stepping through the menues does work, changes to the settings are not becoming active, the display is “ignoring” things.

Two Bluetti devices, both are half-functional only now, and the BLUETTI_CARE isn’t of any help.

This is very frustrating.

In China, there are public holidays until October 6. Maybe that’s the reason. I’m also waiting for the solution to a problem

@BLUETTI_CARE @mistersixt

@mistersixt Sorry for my late reply. I am 3 days off because of a public holiday. We did push a firmware of ARM 4039.06, please follow the below steps:

Thanks for your patience. I am checking with the technician. I will update you ASAP.

I was offered a new ARM version (4309.06, came from 4309.05), and the LCD display is working as expected again, that update fixed things (for now).

@mistersixt Thanks for your update. If there is a further problem, feel free to let me know.