EB3A won't turn ON AC mode with AC cord plugged in


I have a problem with two of my EB3A power stations.

Both of my grey EB3A have the following problem:

  1. When I plug in the AC cord, the EB3A turns ON but the UPS icon is not displayed and I cannot turn ON AC Output by pushing the AC button. I cannot use AC devices with the EB3A.

  2. If I unplug the AC cord, push the AC button, the EB3A turns ON. If I touch the AC button again, the AC inverter turns ON and AC is displayed. I can use AC devices with the EB3A.

  3. If I am using the EB3A battery power, AC inverter ON, and devices plugged in and then I plug in the AC cord, the AC inverter turns OFF, AC is not displayed and pushing the AC button does not turn the AC interter ON again. I cannot use AC devices with the EB3A.

I have another beige color EB3A. With the AC cord plugged in, AC inverter is ON and UPS is displayed. The EB3A operates correctly and I can use AC devices withit. No problem.

What is the problem with the two grey EB3A and how do I fix them?

Hi @Greg1

Have you check for a update in the Bluetti App? EB3A got really much updates the last time.

Otherwise maybe @BLUETTI_CARE can help you with a warranty inquery

@Greg1 Could you please provide me with the SN and the firmware version of your EB3As?

hey , I am having this same problem after updating my firmware. can you guide me on how to rectify this problem?

@keane Kindly provide me with the SN and the firmware version of your EB3A and I will check if there is a firmware for you.

When you try to turn on the AC and DC keys of the machine while the charging cable is plugged in, after 30 minutes to 1 hour, the EB3A goes from 100% to 99%, then unplug the charging cable to see if it can be turned on.

I have the exact same problem. SN EB3A2311003498737 Firmware versions ARM 2063.02 DSP 2052.09 no option to upgrade available.

@asarium Thansk for your information. The firmware will be updated in 6 hrs.

I’ve updated the firmware but the symptom still persists, both via the app and using the hardware button AC output cannot be turned on when the AC input is connected.

Note also that when I turn it off entirely via the app, then plug in the AC input, there’s no “UPS” setting here in the display, which if I understand the instructions correctly, there should be.


  1. We suspect that the AC output frequency of the machine is inconsistent with the input frequency of the power grid.
    (Please turn off the power-lifting mode. Then in the power-on state, press and hold the AC and DC buttons at the same time to enter the setting interface, and then click AC to switch the frequency) .
  2. If it cannot be resolved, upgrade the APP to the latest version to test.
  3. If it still can’t be solved, please contact the after-sale support to repair it or exchange it.

That appears to have worked, thanks. After showing 50hz, when the AC plug is attached, it immediately goes to UPS mode, and I am then able to turn AC on even with the AC plug in. I also checked my inverter and verified that it is indeed 50 hz constant.

@asarium I’m glad that your problem has been solved. If you have further problem, feel free to ask me.

@Greg1 Hi, did you solve your problem, could you please share some updates?