EB3A Mppt PV input no longer working

Anyone else have their MPPT PV input no longer work? Had the unit for 2 months now and all was well but seems the MPPT input no longer converting the high voltage to usable amps.

  1. On latest firmware DSP 2056.10 ARM 2057.11
  2. Confirmed good solar panels (the one that has been working 200W and others that are on my other solar setups).
  3. With inline power meter I can see the input is at 22V but the mppt is only drawing .5amps.
  4. Already cycled EB3A down to 0 percent and turned off unit. Charge back to 100 and discharge a bit and tried PV but same issue.

Seems the MPPT controller is not functinal. AC input works fine.

Emailed support but no response yet.

2 Likes

Have you tried changing the charging rate (Turbo / std )

Sadly tried it as well. Seems not a general issue with charging as AC input works flawlessly but the MPPT input is not doing the conversion of the high voltage to amps. My PV (even at direct overhead sunlight) stays at a high voltage but the amps draw into the unit is only .5amps max. If you check my previous posts on this forum, I’m pretty much versed into this unit but I can confidently conclude the MPPT controller in the unit has an issue.
Unfortunately during the past few months I enjoyed this unit but slowly lost confidence in the build quality of it.
Having to go through so many firmware updates and hearing more and more issues, I am slowly regretting this purchase. It would be something if customer support was responsive, but as others have mentioned, getting through the various contacts is slow to non existent.

1 Like

Hi @Vinman , Is there any error code reported by the machine? Can it charge properly with car charging please?

No error code is present. EB3A acts like normal except when charging via the PV input the voltage input stays high and amperage does not increase past .4 -.5 amps thus only producing less than 10W and the display register 0 Watts input.

I have tried different power sources, solar and adjustable DC power supply that I set for 12 through 20V but still no difference. I don’t have a car charger cable but I did hook it up to a 12v sealed lead battery I use in my other solar setup (known good) but makes no difference. Seems like the internal MPPT controller won’t budge from .5 amps and up and no conversion.

1 Like

Hi @Vinman , Have you tried charging with the adapter? Does it work properly?

Which adapter are we talking about? As stated before, the AC adapter works fine charging.

I’ve attached a pic to show what is happening. This is full sunlight 200W panel.

1 Like

@Vinman, I’m sorry to hear you’re now having trouble with your EB3A. I’m now having trouble with one of my three (all on the latest .11 & .10 firmware) with Inverter Overload error while drawing 43w on UPS & AC, which worked fine for a month, then all of a sudden it gave that error, so I relegated it to just sporadic usage and am using another EB3A. Now that troublesome unit won’t charge to 100% as it gets a high temperature warning around 98% or so, so I have to shut it off and let it sit for about an hour to cool down (while having been in an air conditioned house which was already cool) before it’ll charge again up to 100%. I do like these little power stations but don’t think they were ready for prime time, there’s just so many issues people are having now.

Right about these units being sold without being fully tested and not ready for prime time.

On the 98% issue and high temp. That is normal. When the battery charges especially from a low percentage state it won’t reach 100 percent without bombing out with a high temp warning. Let it be, the BMS will sense the temp going down and it will finish charging to 100 percent. It can take half hour min but the lifepo4 batteries warm up when being charged at such as high current.

Seems funny this is one of the selling points of this unit being able to charge faster than competitors but if the BMS stops the charge from topping off the batteries, then you are really not saving any time.

I think the latest firmware made the charging too docile and the firmware prior to that was too too aggressive. They need to release another firmware to find a balance. This latest firmware still has AC reset issues (when charging to 100 percent via MPPT and not AC).

This is my experience. My MPPT input issue, i thnk it is a hardware problem with the internal MPPT controller. I don’t think in my case software will fix it.

The frustrating thing is even though you get 2 year warranty, not sure how you Bluetti can honor that when they don’t seem to communicate with you when you email them for support. The phone contact is not working out. No one answers and the tech support mailbox is always full.

Unfotunately, the EB3A is crippled without the ability to charge via solar. Take that feature away and all it is a power strip with USB ports really.

1 Like

My eb3a does work with pv200 but only show max 100w…other hands connect to eb70s it shows 163w…dont know why eb3a is cap at 100w…

When mine was working i peaked at about 157W using a fixed 200W glass panel.

Is yours a portable folding type or fixed panel?

The EB3A although capped shoud be letting in more than 100W. Did you confirm your EB3A via the app is set for standard charge moe and not QUIET?

Having it on Quiet setting will limit the charge rate.

Mine is foldable…bluetti pv200

To update, support is sending me a replacement. I’ve already sent in my RMA and should receive the replacement tomorrow. I wonder if long term the EB3A needs some design changes. It has too much issues I am thinking that cannot be resolved by software patches.

Update:

I received a replacement EB3A yesterday. The MPPT charge port is working on this unit. It came with DSP and ARM .09.

To do some testing i updated only the ARM to .11 (because the flashing solar input problem) but kept the DSP at …09 so see what behavior is exhibited with the UPS bypass (resetting issue).

The high temp warning when charging from a low state percentage to 100 via AC is still present (stopped at about 87%) but I am leaning toward this being normal as the battery heats up so the BMS is going into protection mode. I did notice that with DSP .09 it is taking longer for it to resume charging to 100% when it cools.

Will monitor the next few days and see what happens.

2 Likes