I just ‘fired off’ an email to ‘Service’ at Bluetti asking for help on resolving an issue with a new EB3A I received just eight days ago that suddenly ‘Simply Froze Up’ and became completely unresponsive. Having worked in I.T. until I retired, it has been my habit to supply as much background information as possible in the hopes that we don’t have to go ‘too much back-and-forth’ asking questions and getting answers in order to resolve the problem.

The EB3A in question was set up ‘out-of-the-box’ exactly per instructions AND no firmware upgrades had been attempted, on the philosophy of “If it ain’t broke, don’t TRY to fix it!” (Or at least wait a while; I had done some checking around to see if anyone had been having problems with Firmware Upgrades on this unit and/or had any problems with the EB3A in general, and apparently there were some reports ON THE INTERNET (as opposed to this form) ‘in general’.

ANYWAY, in addition/in pursuit of a solution, I thought I would enroll in and post the email that I had sent Service at Bluetti just in case others might be interested in my experience with this unit to date, AND because someone might have some ideas or information that might help me resolve the problems I am having.

Below is the communiqué/email that I fired off to Bluetti. If anyone’s got any ideas, they would be appreciated. (NOTE: it’s fairly long, so be prepared…)

HELP!!! My Bluetti EB3A that I

  • Ordered Sunday, July 10, 2022,
  • Which was shipped (Email notification received) Tuesday July 12, 2022,
  • Received, unboxed, set up and put into operation Thursday, July 14, 2022,

…appears to have – this afternoon of Friday, July 22nd, to have ‘died’. (‘Malfunctioned).

Immediately below, I decided to go and provide CONSIDERABLE Background Information about the history of the unit – how I inspected it and set it up and have been using it since I received it on July 14, in the hopes that it might be helpful.

Please note that I did not attempt perform Any Firmware upgrades to the unit since I received it (as I will further outline below) as it is my habit to always check around to see if anyone’s been having problems in such circumstances with firmware upgrades and ‘wait’.

“If it ain’t broke, don’t fix it!”

Problem Summary:

  • Display Panel shows 0% State of Charge.
  • When plugged into 120 V AC, panel/remote Bluetooth App shows small charge APPARENTLY ‘going in’, but battery (indicator) never Budges off of ‘Zero’.
  • I suspect internally ‘Computer Lockup’/’Freeze up’ which might be rectified (At least temporarily) if the system could be ‘Rebooted’ but I don’t know how to do that.
    • (‘Come on guys’… There MUST be a way! No engineer would have designed this product without some means of doing this – perhaps some combination of button pressing and holding…).
  • Perhaps you have/the software/firmware has (simply) a ‘Memory Leak’ of some kind, somewhere?


Usage/Background Information/Current State:

  • Unit was carefully unpacked received, opened up and following all the instructions in the manual, was first charge up to 100% State of Charge.
  • Some ‘experiments’ were made to ‘familiarize myself’ with the unit. The Manual was 100% Completely and Carefully read before the unit was put into any use.
  • The Bluetti Android app was downloaded from the Google Play Store and installed – without a hitch – on my cell phone and one of my tablets. Using it, I was able to connect without any problems whatsoever with the unit. Very nice. Played around with the App a bit, but Did Not ‘Tinker’ with any settings WHATSOEVER!.
  • Everything seemed to be fine – could use panel buttons to turn on-and-off various outputs, the panel showed 100% state of charge, the LED LIGHT WORKED, I was able to turn on the DC outputs and enable and use the Wireless Charging Pad on the top of the unit successfully.
  • Everything was just fine as far as I could tell.

THEN – following the instructions in the manual,

  • UPS Bypass Mode: Connect the EB3A with the AC power and the ‘UPS’ will be on display.
  • Then turn on the AC output.
  • When on this mode, the AC power will directly support the loads on AC output ports and charge the EB3A. (As mentioned, it had already been charged up to 100% State of Charge and it was working fine).

I then put it into its Intended Primary Use as a UPS for a Desktop PC (AC power demands roughly 90 W average, 135 W MAX) and tested it.

  • When the PC was up and running, I pull the plug supplying AC power to the EB3A and – as I had expected and hoped, it worked as advertised… The PC continue to run without a hitch.
  • COINCIDENTALLY: around 3 AM on Friday, July 15th, we had a severe thunderstorm (Family Dog woke me up). While I was awake, we did have a very brief power interruption/’blip’ which lasted maybe three seconds or so before the power ‘came back up’ without any more plus subsequent downtime. I wondered…. If the EB3A had done its duty and if that particular PC was still up and running but I didn’t bother to check at the time.
  • A few hours later I got up out of bed I checked and – every PC in the house had been shut down by the power interruption and all the electric/digital clocks in the house needed to be reset.
  • However, the Bluetti was up and running properly AND the Desktop PC that it was hosting was up and running also. In its BIOS, it was not configured to reboot in the event of a power failure/come back on again so if the EB3A had NOT done its job, it would’ve been down also.

I was Very Happy. (In fact, I was planning on ordering – before the Introductory Offers expired – at least one more EB3A, perhaps two even – for use primarily but not exclusively as UPS’s… I’ve been waiting for someone to do what you did – provide that type of functionality – with lithium iron phosphate technology – for a long time. Both are ‘So Obvious(ly)’ things that would have Great Market Appeal.

(And please note/apologies offered: I also attached a complete history of email exchanges with ‘Bluetti Sales’ since I placed the order thinking it might also have some value. And, what EXACTLY, does ‘ARM’ and ‘DSP’ ‘Stand For’?)

Anyway, onward.

Everything was fine until sometime this afternoon – Friday, July 22, 2022 – eight days after the unit had been received and put into service.

I had been busy but it come to my desk/workstation and NOTICED that the PC connected to the EB3A was off/power down…

Long story short…’:

  • The EB3A in question appears to be ‘dead’/’frozen’ – ‘locked up’.
  • I CAN Activate/Turn On the Display Panel using any of the units ‘Power On’ (AC, DC) buttons,
  • HOWEVER, The Display Panel shows ‘00% State of Charge’
  • BUT:
  • One thing I can do still – I CAN still connect to the unit using my cell phone/the Bluetooth App:
    • The App (ALSO) shows 0% State of Charge, and/but
    • It seems to indicate that there is a small amount of power ‘going into the unit’ via the AC Charging Port/’The Grid’ roughly in the amount of 75 W plus or -15 W or so… continuously. (‘Bounces around’ a bit).
  • HOWEVER – the unit will not charge (at least as indicated at/by either the Bluetti app – regardless of how long the unit is plugged in, the State of Charge indicators – on both the one on the physical unit itself and the remote Android App – NEVER BUDGES ‘OFF ZERO’.

So here we are.

  • The unit is Completely inoperable, nonfunctional, and UNRESPONSIVE. Currently, a ‘paperweight’.

What should I do?

Before I close, a few final important notes:

  • I cannot ‘turn on’/’enable’ EITHER the DC and/or the AC outlets FROM/Using the Bluetooth app.
  • It APPEARS that I CAN ‘Toggle Back and Forth’ the ECO Switch on the Bluetooth App and the EB3A WILL RESPOND AND THE Eco-MODE INDICATOR ON THE DISPLAY PANEL WILL ALSO TOGGLE.
  • I can – at least per the Bluetooth App – change the ‘duration’ between one in four hours when the Eco-mode is turned on, but I can’t tell if it’s having any effect because the unit is nonfunctional in other ways.
  • The LED settings per the Android app are currently ‘off’ and I cannot change them to Medium, High or to SOS… – They persist in remaining ‘stuck’ on ‘off’.
  • ‘Power Lifting’ mode is/was – was never changed or tinkered with from its out-of-the-box setting of ‘Off’.

And finally, and perhaps? Most importantly:

When I received the unit, I noticed that – checking in the Android App – that there was apparently a Firmware Upgrade available (Actually ‘Upgrades’ ‘PLURAL’ – 1 for ‘ARM’ and 1 for ‘DSP’. (I’m not exactly sure though I have some idea/I could guess what each acronym stands for but that’s not relevant here…)

IN ANY EVENT, I DID NOT IN ANY WAY ATTEMPT TO DO ANY FIRMER UPGRADES. (I spent my career in I.T. and I am ‘Old School’– “If it ain’t broke, don’t fix it…!

Now that doesn’t mean I am not prepared to ever do Firmware Upgrades – I do do them to printers and drones and things like that

BUT, before I even attempt to do that, I always:

  • Check to see the date – if I can – that the Firmware was released, AND
  • Check around on the Internet, doing both general searches and browsing around in (appropriate) Forums to see if anyone else was having any problems with these upgrades…
  • Such as – a notable mention of something current – the company DJI who makes consumer drones – recently released some firmware upgrades for its latest drone the DJI Mini Pro ‘3’, which cause serious problems and in some cases even loss of the drone.
  • I didn’t check further when I observed that to see how those situations had gotten resolved and/or if they had… I decided to simply go with my “If it ain’t broke, don’t fix it!” philosophy…

So, to wrap this up, some final information:

  • What I presume is my units Serial Number: EB3A2217000362334
  • Firmware – Currently Installed/Upgrade Available (NOT INSTALLED!)
    • ‘ARM’: v2057.02/2057.11
    • ‘DSP’: v2056.02/2056.10

SO, bottom line:

  • What should I do?
  • I SUSPECT that the/a ‘COMPUTER’ inside is in some sort of ‘Paralyzed/Frozen’ ‘STATE’ and PERHAPS normal operation could be restored if somehow rather the unit could be ‘Rebooted’ BUT, I don’t know how to do that or even if it is POSSIBLE.
  • Plugging/unplugging the AC cord has no effect, all power output terminals/buttons to enable them are nonfunctional.
  • The LED light won’t even turn on!

Should I – PERHAPS – under the circumstances, attempt a – ONE OR THE OTHER OR BOTH – Firmware Upgrade?


This should not happen with the new unit to market like this (I know of course it’s not the fault of those who received this email)…


  • How to Install Firmware Upgrades PROPERLY (notwithstanding the fact that I haven’t even attempted yet, but there always should be), AND
  • Since these things are really Computer/Software Controlled Devices, there should always be a well-publicized method of Rebooting the device. Because I would bet – ‘dollars to donuts’ – that normal functionality could be restored (at least for a short time) – so that corrective action such as a possible firmer upgrade or something could be attempted.

Eagerly awaiting your response (as you can imagine!).


Hi @HammerToe , I am very sorry for inconvenience caused.
Can I know your email address please? We will check with support first and then have them prioritize your email.
Thank you very much for your cooperation and please accept our sincere apologies.

Good morning, it’s approximately 6:15 AM Central standard Time on Monday, July 25, 2022 as I write this. I just figured I would provide you with Yet Another ‘Addendum’ to bring you completely up-to-date with regards to the problems I have been having with the new Bluetti EB3A I purchased recently (as described below).

But, in the interest of efficiency, to summarize:

· The unit seem to work just fine – no problems WHATSOEVER – out-of-the-box. reasons I decided to purchase one of these (since I already own a Jackery 1000 AND a Jackery 300

o Advertised UPS Functionality. Wow! That was something I originally had hoped I could use my Jackery 1000 for AND… I suppose I COULD BUT: a combination of Slow Charging AND unavoidable efficiency losses going from AC to DC and through the battery and then back to AC again ‘didn’t make any sense’ AND then again/finally/lithium-ion batteries have only perhaps 20% or so of the Life Cycle potential compared to lithium iron phosphate…

o FAST Charging: Never mind the desirability of this characteristic in and of itself, the potential to use the unit as a UPS ‘obviously’ depends upon ‘how fast’ you can charge it – because when AC power ‘from the wall’ is available, you do want to be able to ‘charge

it’ AT LEAST AS FAST as the device being serviced as a UPS can pull it back out again…

§ (Again, while it’s fresh in my mind – Hot Damn does this thing charge fast. After applying (the) ARM and DSP Firmware Updates as I described – with the Internal Battery essentially ‘flat’/but with the unit plugged into AC wall power, the darn thing started charging up and went up to 95% State of Charge within perhaps 60 minutes – certainly no more than about 70 minutes or so. It took perhaps another 15 – 20 minutes to ‘go’ the final 5% but… Who Cares? If you can cram 80% State of Charge in even in less than an hour, that is phenomenal).

o Lithium iron phosphate storage technology: definitely preferable for obvious reasons. Lithium-ion devices today are pretty darn safe BUT there’s always a possibility, and lithium iron phosphate you can shoot holes in without much risk.

IN ANY EVENT: as of ‘Right Now’/’As We Speak’ my EB3A SEEMS to be working normally again. By ‘SEEMS’, I mean – I haven’t had a chance to play with it anymore very much – it is back in Production Hosting a desktop PC drawing roughly 95 W sustained/135 watts peak, without any problems.

As of yesterday evening, I was still having some problems. Here are a few:

· Specifically the Input Wattage Display on the unit would NEVER display anything other than 000, even when the unit was plugged in to AC AND was driving the desktop PC in question.

· In addition, and perhaps worth noting – the Android App on my cell phone WOULD display properly…

· WHY there was a difference, I don’t know – but this morning – the Physical Units Input Display seems to be working properly again…!!! ‘Go Figure’.

· IN ADDITION – the problems I was having with a ‘Flashing UPS Indicator’ – Irregularly Flashing, I should add, also seems to have ‘gone away’, and is now ‘locked solidly on’ when functioning as a UPS.

· ‘Further in addition’: I just ran a test with a 100 what Incandescent Lightbulb ‘load’ and – concurrent with the resumption of normal/as one might expect Solid Illumination of the UPS indicator, THE FLICKERING OF THE INCANDESCENT LIGHT BULB/LOAD ‘IN SYNC’ WITH THE UPS INDICATOR IS NOW ALSO ‘GONE’…!!!

· AND FINALLY – just to add one more bit of Quirky Behavior which I’m not sure if I mentioned previously: even AFTER – YESTERDAY – WHEN I WAS STILL HAVING PROBLEMS WITH THE Input Power DISPLAY ALWAYS SHOWING 000, while I could get the units display panel to ‘Light up’ by briefly pressing the LED light switch and releasing it, IF – each and every time (I tried more than once) – the entire unit would shut down if I tried to enable the DC outputs. In fact, briefly touching or touching and holding the DC outlet activation button would completely and instantly shut the unit down. The only way to resume normal operation again was to unplug the unit from AC and plug it back in again…

o NOW, again – I can report this seems to be working normally again – I can enable and disable the DC outputs WHILE the unit is in UPS/AC mode WHILE PLUGGED INTO AC LINE POWER INPUT. I SUPPOSE – I could check it one last time right now as I write this to verify it yet again but I’m not going to risk it because I am writing this on the desktop PC in question hosted by the EB3A.

So, bottom line: for the time being, I suggest that PERHAPS it might be best to ‘put this on the back burner’ for a few days at least until I have had time to see how this unit performs in terms of stability over perhaps a week or so. Regardless of how it works out – problems are no problems – I will try to ‘get back to you’ with a final report BECAUSE;

· The problems I was having were really ‘very strange’… VERY STRANGE!

· The fact that the unit seem to work just fine for several days after I got it AND THEN, all of a sudden to wake up in the morning and find the PC shut down AND the unit shut down – with the battery ‘dead as a doornail’ (though with enough power remaining to power the display) AND COMPLETELY UNRESPONSIVE/INCAPABLE OF BEING RECHARGED… AND

· To have things kinda, sorta, return to normal AFTER the firmer updates, ONLY TO HAVE

o Input Power Display (all 000s, ‘all of the time’, ‘ALL OF THE TIME!’ AND

o A Flashing UPS indicator… Accompanied by

o A correspondingly flashing/flickering Incandescent Light bulb, flashing/flickering in sync with the UPS indicator, and finally,

o TO BE UNABLE TO TURN ON ANY DC OUTPUTS WHILE EVERYTHING WAS HOOKED UP AND FUNCTIONING IN UPS MODE (not clear what would’ve happened if the AC inputs had been disconnected) BUT TO HAVE ANY ATTEMPT TO ENABLE THE DC OUTPUTS ‘INSTANTLY SHUT THE UNIT DOWN’ with (obviously) the PC in question ‘crashing’, WAS REALLY, REALLY WEIRD… (And obviously not desirable).

But, as I said/propose: let’s give her a bit more time. I will use the unit as I plan to use it normally for the next few/several days and will see if anything happens that should not be happening.

Again, I SUSPECT that PERHAPS there might be some sort of ‘Memory Leak’ problem in the firmware. (I was a software engineer at one point in used to program/write code and so I’m somewhat familiar with potential problems that can occur). That’s why perhaps letting this thing just run for several days continuously and see what happens might be a good idea.

All in all, I am still quite impressed/intrigued – INTRIGUED – by this product offering of yours. It has/SHOULD HAVE Incredible Potential… ‘Like’: assuming UPS functionality was ‘done right’/properly implemented, WHY IN THE HELL WHAT I EVER BUY A UPS AGAIN? Never mind the other features/potential… A UPS battery would in many cases/for all practical purposes NEVER HAVE TO BE REPLACED?

A couple of questions that occur to me ‘while we’re here’ (Technical Questions)How Quickly – in milliseconds (I’m just curious) is the unit designed to switch over from AC line in power to DC power in the event of a power interruption?

o I’m just curious – doesn’t seem to matter in my instance because both my tests AND an actual 2 to 3 second power bump/interruption (lights out) in the wee hours of the morning resulted – ALL RESULTED – in my PC staying up and running… HOWEVER I HAVE SEEN PURCHASERS COMPLAINING IN A FORUM THAT/CLAIMING THAT THE UNIT DOES NOT SWITCH OVER ‘FAST ENOUGH’ like a normal UPS. (Perhaps it had something to do with the amount of load that the unit operating as a UPS was supposed to be hosting? I dunno… AS I RECALL/having read somewhere long ago – typical UPS switchover times should be no more than about 8 ms MAX and ideally 5 ms or better…)

· Reboot Capability?

o As I mentioned previously in other emails, is there some way/could there be a firmware upgrade into which a capability to Reboot The Device/System was incorporated?

o Now, maybe this makes no sense for reasons I don’t understand BUT – what with my programming background and experience – 26 years in IT – having been working with computers, building them even and configuring them and networking them, I know that a lot of problems can be cleared up by ‘rebooting’, especially after firmware/software upgrades.

§ Is this something you might consider building in to a firmware upgrade?

Anyway, thanks very much for your prompt replies, all things considered. I have a feeling with a new product launch like this – that this unit might be in pretty high demand and inevitably, people are going to have problems, most often because of a failure to RTFM… But obviously, some people will have legitimate problems.

Thanks very much again.

If you could provide answers to some of my questions, would be appreciated. In any event, I’ll get back to you within a week or so. Assuming everything runs reliably through to July 30, I think I will place an order for at least one more and possibly two more units to use PRIMARILY but not exclusively – as UPSes.


Grant Madison GM27Cap@GMail.com 204-668-1690