EB3A in UPS mode just quit charging

I have been using my EB3A (.10 firmwares) as a non-essential UPS, just to keep it charged and test it out. It ran fine for a couple of weeks plugged in and powering a 23W load that runs about 18 hours then the load turns itself off for about 6 hours. I went away for a week and returned to find the battery at 1%, A/C off, but the Bluetooth connection worked. I hit the power button and the screen came on and the UPS light came on after a second or two, but no A/C output. I pressed the A/C button and it started working. I think the input ramped up before I turned on the A/C output, but I’m not sure. The unit charged over-night and is working fine. I updated the firmware this morning and will continue to monitor.

I don’t think my power blinked while I was away because appliance clocks were not blinking, and my computer UPS did not log any interruptions. A UPS that interrupts itself is not a reliable UPS.

Is ECO mode on? You don’tt want it on if your load will cease as that will turn the EB3A off.

No. ECO mode and Power Lifting are off. I keep it in Silent mode.

It usually pulls 23W input for the 23W output. When the battery drops to 99% the input goes up to about 125W until the battery is back to 100%. This time it did not charge and drained the battery to 1% so I suspect that the A/C output stayed on until the battery got low. What would cause the input to switch off? I did not unplug it when I found it low, I just cycled the switches and it started charging again.

I updated to v2057.11 yesterday.

Hi @newcx , sorry for inconvenience caused.
From your description, it seems that the UPS is interrupted by a power failure. Perhaps there is a bug in our software.
Given that you have upgraded to the latest version yesterday, you can continue to use it and see if the UPS interruption still occurs.
Thank you for your kind cooperation.

Thanks for the response. I have another UPS that should log if there is a failure and it did not, so I don’t think there was a power failure.

Yesterday I checked it and found it off again and the battery down to 93%. This time I saw an “Overload” error on the app and the device screen. I hit power and A/C and it came back on and started charging. I turned the load off, 0W output, and this morning it was in “Overload” error mode again. There is only one device plugged in and it can’t draw more than 25W.

After I reset it again I changed the mode from Silent to Standard. Will update later.

Still working in Standard mode.

That’s interesting, Newcx. After 7 weeks of running one of my EB3A’s with the same load, a fan and led light for a total of 45w, I had an Inverter Overload occur yesterday. During the night I plug in the power cord but during the day (when this happened), I had solar incoming, and the EB3A was at 99% when this happened so the solar input was around 59w at the time. So after unplugging things and clearing the Inverter Overload error, I hooked it back up like it’s been running for the last month and a half, and within a short time I had another Overload error. So I shut that EB3A off and grabbed one of my others, and it’s running the exact same load fine, just as before. I’m not sure why this happened on the one machine as everything was running smoothly for weeks and weeks, until yesterday.

Jayling, I just found your original UPS post where turning off ECO mode seemed to work for a while. Mine has been running in standard mode for three days now with no new shut-downs.

Bluetti’s response above is just silly. “It seems that the UPS is interrupted by a power failure.” Uuhh, I thought a UPS was supposed to stay on when the power goes off.

@newcx, I’m glad you turned off Eco mode, hopefully that helps you. I don’t use Eco so that’s off and I charge in Standard mode. What’s so strange is receiving those Inverter Overloads twice while my normal setup was working just fine for nearly 2 months. I’ll try that device again later but for now I’m using one of my other EB3A’s with the same fan/light 45w (power cord at night, solar during the day) setup. Good luck to you. :slight_smile: