EB3A DC keeps displaying 'short'

I tried plugging in a tire pump that was rated for 15 amps into the cigarette lighter jack (was assuming that was worst case). When I turned the pump on, the EB3A immediately shutdown and displayed short.

However, it keeps displaysling ‘short’ and turns off DC after 5 seconds of it being turned on even tho nothing is connected to the DC jacks.

Have tried to let it sit overnight, updated firmware, and through the app with no success.

Is this defective? Or is there no protection from overloading DC?

Is not the DC max output 10amps on the EB3A? I think the initial surge (you stated the pump is 15amps max) is drawing too much so the EB3A is in protection mode until you manually turn off the EB3A and turn it back on (not just the DC button but shutting down the EB3A through long press or through the app).

Right, but with nothing plugged in at all still shows short

I think any fault condition requires the unit to be rebooted. Did you turn off the EB3A (you can use the app) and then it back on? I think it should clear the fault condition.

Thanks for the recommendation. It’s been restarted several times thru the app and front buttons. Still shows as short on starting DC

Then there must be some issue with the unit then. I say get with tech support.

Hi @ovel2clock, pleae try to remove all loads, reboot and see if “short” clears and works again. If it still occurs, reload other devices to see if they work again.
If the above does not work, please contact our support department via service@bluettipower.com as soon as possible, preferably by sending a video. Thank you very much for your cooperation.

@ovel2clock try draining the battery until it shuts off, and then do a complete recharge cycle via ac to recalibrate the unit. Not sure if you’ve done the firmware updates (currently at .10/.10) but have heard the EB3a needs this completed full cycle to recalibrate things internally. Keep us posted.

1 Like