Chineese language by default in English App for Iphone

Dear Team I am getting Chinese language in the App for iphone - please look at the screenshot attached
Is there any chance we can have it the message in English by default when English is being used as s primary language for the device ?

1 Like

@dzmitryj when you click on your unit, the language should be in english. If it isnt, click on the “me” button on bottom right, then click on your username/email on the very top, and change your “country/region” (3rd button down) to United States. I believe this should change setting to English.

As for the home screen, the chinese characters under your units battery percentage, is going to stay there I believe. At least it does with mine as well. No big deal tho but hope this works for you! Let me know if you have any questions

1 Like

Please try @m.briney 's suggestion first.

I have the same issue… Nothing helps to solve it. It’s weird that when I change the app language in iOS settings to German, for instance, it still shows Chinese characters.