Can't connect new AC300 to SSID

Hello, I just got the AC300+B300. I’ve downloaded the App, connected to the devices over Bluetooth, and updated all the firmware. When I try to connect it to Wi-Fi, the App prompt me first to "Enter the WiFi SSID’. The App then opens the Bluetti settings under iPhone’s Settings. Location, Bluetooth, Camera, Siri and Cellular are all already enabled, so I’m at a dead end. All of my home’s Access Points have 2.4MHz and 5MHz channels open that other devices are connected to so I don’t think that’s it. Any thoughts?

Hi @PaddlingUpStream

Thats kinda a “issue” thats permanently exists.

If your only see “enter SSID”, you should start the Integration in the App again, until you Wifi Network is autofilled.

You need to be sure, that your iPhone is connected to a 2.4 ghz wifi. Bluetti Units dont support 5 ghz. If so, it should also appear in the App and you need to type in only your password.


Thank you so much Erik for the feedback. I enabled a new dedicated 2.4GHz SSID on my office AP and connected my phone to that. I did an “unbind” action to remove the device, and then added the AC300 in the App again. Unfortunately, no change to the behavior. It’s still asking for me to enter the SSID, which then takes me to App Settings, but nothing to do there.

@PaddlingUpStream hmm okay. Just for conformation. You connect your phone via Bluetooth to the AC300 and also connected your phone to a 2.4 GHz Wifi.

The only thing that may can be a problem is the Wifi Channel. Some routers in Europe can use extended Wifi Channels such as channel (13?!). Theese are some special channels that dont supported by any device.

Check, if there is something like “extended Channels” enabled in your router config or set the wifi channel manually to 1 for example.

If this still not work, maybe @BLUETTI_CARE have any more ideas to this topic?

Please try the following steps

  1. The APP needs to be updated to the latest version
  2. Turn off and on again the Bluetooth and WiFi of the machine display and mobile phone
  3. Confirm that the WiFi password is correct, because even if you enter the wrong WiFi password, the APP will display “WiFi saved”;
  4. Does the WiFi name have special characters, such as “?” or“@”? You can try changing the WiFi name to test.
  5. Is the machine within the signal range of the WiFi signal source and router? If the machine is too far away, the poor reception signal may cause the connection to fail. You can enter “About device” in the APP to view the network signal Network Rssi. The larger the negative value, the worse the WiFi signal. Please move the machine closer to the router.
  6. Is the mobile phone signal poor? If the mobile phone signal is poor, it may result in the inability to remotely connect to the machine.
  7. Please provide the SN and IOT firmware of AC300. I can check if there is suitable firmware.
1 Like

@PaddlingUpStream Hi, I have an update. Please make sure you have turned on the precise location.

Thank you Selfmadestrom. None of the channel switches seemed to make a difference. I eventually uninstalled the app and set the “precise location” setting that Bluetti Care suggested and that worked. Thanks again.

Thank you. I uninstalled and reinstalled the app and tried Precise Location and it worked. I’ll assume the Precise Location made the difference. Is that an intentional restriction or just a quirky bug? If intentional, it’s worth calling out in your setup instructions. Thank you for the support!

1 Like

@PaddlingUpStream I am glad to help you. Thanks for your suggestion. I will report it to the relevant department.