Can’t create an account

New iOS app downloaded (1.3) and I now need an account. When I try to use my web site account or forum account, app says account doesn’t exist. When I try to create and account, I never get the verification code in my email. Please help.

Exactly the same issue here.

Tried again this morning and got the code email, so it’s working now. Hopefully everyone is able to create an account now as needed.

Verification emails are not working for me still. Tried 4 times so far on the android app.

Not working for me, either. The first time the login failed, I deleted the app and then re-installed. I registered and got an email verification request. I entered that, and when I try access my account, I get a “please enter a valid email address”. Repeatedly. Going back to registration, I get a red-backed message saying that my email address has already been registered. And more importantly, what happens when you are off grid and the phone can’t connect? AC200MAX display only access?

Dear BLUETTI backers,

Thank you very much for all the useful feedback above. We have submitted it to the relevant APP development department and they are working on it. We hope BLUETTI APP will be improved soon.

If you haven’t updated yet, it is recommended not to update the latest version and use the previous version.


Dear kristler…
Sadly I’ve had the same problem for the last 4 days, ever since they decided to “update” the app, only after having it updated barely a month or two ago! Why in the heck do they keep doing this? I cannot sign in, register, re-register, absolutely nothing. Worst APP ever! Tosses out my email address as not being valid. Usually never get the verify code, occasinally it finally did, but still tossed out my registration saying my email is not valid! WHAT?? They did just send me a useless code then, and then say it’s not valid? WTF!

Same problem here, over and over and over. So disgusting. I sent them a nasty-gram, only got a reply to register using my email. Duuuuh. I’m running mine off grid almost constantly, thankfully it DOES work without the ability to “watch it” or control it (what little I need to control anyway) while this useless app doesn’t work. I just have to always run down to the basement to check on it’s status. So frustrating. I wish they’d just leave things alone. The old app that was already “updated”, mostly cosmetically, a couple months ago was doing fine. Gimme a break.

Hi, just created an account in Germany AND in the US (same user, same PW) but cannot use the App in IOS, getting above mentioned “account does not exist” issues. I direly need a firmware update, as the EBA3 seems too not accept most solar panels on the market here: Offgridtec 100W and Nicesolar 200W under direkt sunlight, and the input is blinking. Whereas the output with a multimeter shows at leas 11W. Even if it is just 6W, the power station needs to work.
Also, it lost 10% charge when charging a Galaxy Pad from 91 to 100% with 8W. This seems quite much power loss. Is the power station defective? Just got it from amazon…
Thanks for help!