BUYER BEWARE! AC200max broke after a few days use

I bought an AC200max and B230 expansion.

I came home to see my B230 fully charged but the AC200max OFF. I tried to turn it back on and the green light came on but the screen just stays black until the unit powers itself back off.

Ive read other people have this same issue but nobody seems to have a fix and the problem remains unaddressed by bluetti in the manual or the website FAQs

unable to use this thing at all if it wont turn on, its a $4000 paper weight at this point.

unbelievably bad support coming from bluetti. no one answers the phones, no one returns calls or messages, and no one checks the company email account.

I got an email from bluetti asking me to review their broken product before I got a response from a human.

Not sure what I am supposed to do at this point.

Which email did you tried to reach them at?
This one seems to be best for service related issues

1 Like this email works well. I’m sorry to hear you’re having issues. The ac200p i have works great so dont get too bunmed, they’ll take care of you

Hello ryanx3d,
Sorry to hear about your experience, but your $4000 investment won’t become a paper weight, please contact us via and we will help you on this issue with replacement service.


I have now had two replacement AC200 units. Each one has had a glitch. Other than the down time, the company has been very responsive to emails but not on the phone. And their email responses come at all times of the night/day. It would be wonderful if the manual was more complete though–even on line. One does not even know the reasons for the fault list. I am still committed to the unit, my entire conversion was planned around it. I believe this is a journey for most of us including the company still. Hang in there. This forum which I have just found is a great resource

Hi @Karl,

Welcome to our community.
Thank you to all the people like you. Your support makes us move forward.
Any questions, please feel free to discuss with our members in our community.

Thanks. The forum helped me solve a problem that I have been chasing on this third unit. I composed several responses to questions but couldn’t actually post. They always went to draft. Where is the post button? It came up the first time but I used my phone. Does your site not like a Mac?

Karl Dortzbach
443 570 3668

They have a new direct line that might be able to help you better man. Here’s their number…

I’m on a Mac and it works great!

1 Like