Bluetti EB3A not Charging

Just brought the battery back from a camping trip. I plugged it into AC and nothing happened. No charge after 24 hours. It appears to be charging after I unplug cord and plug it back and push the power button on but the screen times out and nothing happens. Any suggestions on what to do here?

@Chazzy You can try to charge EB3A via car or solar panel. If car charging or PV charging works, the AC charging cable may be defective.

1 Like

Check to see if the circuit breaker button needs to be reset (push it) which is located to the right of the AC input connector on your EB3A.

Is it already charged or is the eb3a too hot?

Not hot. But I think this is what happened. I discharged the battery completely while camping. Came home and attempted to recharge with AC cord and nothing happened. 24 hours later still no charge. So I tried to charge via DC plug using EcoFlow battery. Kept the AC plug intact and charged (DC) with the EcoFlow. Lo and behold it charged right up in a few hours. Once charged up, I plugged in the AC cord and the display lit up instantly to show state of charge (100%). So I think I’m good now. I think the problem was I depleted all power in the unit, so much so that the firmware was not functioning. Once I charged it via DC, it had enough power to run properly. Does this make sense?

makes total sense. Good troubleshooting on your end. I run my units to 0% often, but always try to re-charge as soon as possible. If you were in this situation in the future, I would recommend car charging on the trip home or charge it just a bit to get it off the 0% state of charge. This causes issues for a wide variety of manufacturers and models and I see a good amount of issues caused by running too low. The situation would be improved I think if the units had a lower SOC limit that was user adjustable so that the last 10% could be reserved so to speak.

1 Like

I seem to be experiencing what Chazzy went through but I do not have any DC charging options available. What can I do? I have the solar charging cable but I did not purchase the panels as there was no need for it at that time.


  1. Please provide me with the SN and the firmware version of EB3A.
  2. Check if the Circuit Protector on the right side of the AC input port pops up. Press it and try AC charging again.
  3. Check whether there is a error code (when the power is on, press and hold the AC ON and LED ON buttons at the same time to check)
  4. Do you have T200S? If yes, you can charge EB3A with T200S to test.

Ok. My problem was AC was not charging because I drained the unit. I assumed it was not charging cos the Display screen showed a blank even after pressing the AC on/off button. And the SOS light button didn’t work either. So, I bought the DC car charger and plugged it into my car, and the Display Screen lit up and showed 43%, which meant the unit was charging, but the screen and buttons didn’t work. I took it back inside and continued to charge the AC, which now worked.

I suppose the DC charge was just to “boot” or “awaken” the system (???). Anyway, I updated the firmware, and all seems good now. The DC charger is useful after all.