Bluetti EB3A not charging (A082 Grid voltage Low warning)

Hello Everyone,
Please kindly help.
I just got the bluetti EB3A a few days now (29th Dec. 23) and the first time I plugged it to the power grid AC Socket it didn’t show any sign of charging. Only shows that the active ‘UPS’ indicator. On the bluetti app, it gives me a ‘AO82 Grid low voltage’ warning, but every electric devices seems to be running fine, the fan, my laptop etc. I also tried to charge it using an AC Generating set. And I get similar warning and the EB3A seize to charge.

Although the AC power output works absolutely well. At the time of purchase, the battery was at 65%. I used it to charge my laptop for a while and it showed the output wattage per time unlike the Input which is not showing when plugged in. Currently the battery percentage is 34%.
Also, I didn’t try charging the EB3A while using it charge other devices .
But getting it to charge is my major challenge.

Please any help will do

Hi @Adeoye1

different electric devices do have different operation voltages. Some devices can go lower than other.

Check, if the plugged cable is connected right and not loose. If possible, try to charge the unit with a other AC Outlet, maybe even a other powerstation.

Do you have a device to measure your Grid voltage? Check it in the next step to make sure your grid is really okay.

greetings
Erik

Thank you @Selfmadestrom for your response. Apparently grid voltage at my home is either low or unstable. Because this morning, I brought the device to my place of work to try it out and it charged without any issue.
I don’t have any device to measure the voltage at home but I know the power supply often fluctuates.
The thing now is what can I possibly do to solve the voltage issue at home for the EB3A to charge?. Because my sole purpose of buy this power device is to charge my laptop at home when there is power outage. Please any suggestions or advice

Nothing much you can do when you grid isnt stable enough, you cant charge you Unit.

You can buy one of the portable Solarpanels to charge the unit, but that is dependent on the weather.

@Adeoye1 It is possible that the grid input voltage and frequency are not within the range of the machine. You can try adjusting the frequency or changing the socket to test.