Bluetti app is down

Tried to check my AC300 data. NO DATA. Tried to add an EB3a by scanning the bar code, does not work. I know all the data is being sent to Hong Kong, China. I the link down???

Same here at my place… the app doesn’t work on my Pixel 3a instead on another phone (an old Huawei) it works regularly… (maybe Chinese phones use other servers ? ).

My phone is Samsung - Korea (North or South??)


Still won’t work.

No, it has been working for the last two years using Bluetti app. I reset the phone and it still does not work. Maybe the Chinese do not like the Koreans and I hate Apple too.

1 Like

In the end, the problem was solved by logging out of the app and then logging in.

1 Like

Sorry for inconvenience caused. This is due to a series of problems caused by the server migration, which is currently being fixed by our software team.


Are the Bluetti servers working again?

Logout and re-login solved the problem on my side

1 Like

Confirming that what FrankH said fixes the issue for two different AC300 setups.