Bluetti AC500 Powering On or Defective

I purchased the Bluetti AC500 and four B300S batteries through the Indegogo campaign. I received the Bluetti system about a week ago and plugged it all together. Unfortunately, when I push the power button, the four battery power lights come on (3 batteries have 4 led lights and one battery has 3 led lights) but the AC500 LED screen doesn’t power on. I cannot charge using the USB C ports and cannot connect with my Android app. As stated, there is no ability to reach out to Bluetti by calling them, so I hope this is a way someone from Bluetti can help me with this problem. Thank you!

Try unplugging all the batteries (after powering everything off ) and then only plug one of them in and it might work. If not move the cable to the other input port. My AC500 came with one battery and did the same as yours but after unplugging the battery and then plugging it into the other port it has worked fine ever since. Seems like once it wakes up for the first time there are no issues with which port the battery is plugged into.

Very much appreciate your directions eric102! I tried pretty much every combination I could think of with the top two batteries (I have this stacked right now), only using one battery as you suggested. The one battery light would come on again, however no AC500 LED screen. When I plugged the AC500 into the wall outlet, the battery light would go on, nothing else. When I plug the AC500 into the wall outlet with the battery or batteries hooked up, the battery lights come on, nothing else.
Hope I can get this figured out, it’s a little frustrating having four batteries and nothing to control them!
Bluetti?

Does power button on the AC500 light up when the B300S power button lights up? If not yours is acting different than mine.

I would assume you’ve already tried touching the screen to try to wake it up but that would probably only work if the AC500 power button was lit up.

Nope, power button light on the AC500 doesn’t light up, just the batteries. I tried touching the screen and nothing…
Thanks again for your thoughts…

Bummer, you might have a dead one. At least the batteries sound like they are fine, they come charged at about 60% which is 3 or 4 lights.

Hi @Suncoug , Are all your battery pack extension cables locked please?

If locked means that I have to slide the second thumb switch to disengage the cable from the AC500 connection, then yes.

Thank you for any help you can provide!

@Suncoug fast forward to 2:30 and see if this helps… The head unit should fire up after the connection, and b300s battery is “on”.

Mike, you are freaking awesome!
I watched the tutorial and determined that I didn’t “lock” the battery cables in place by pushing the thumb latch towards the connection. When I did this with one battery, the AC500 head unit functioned properly. I turned it off and connected all four batteries and got a BMS 103 connection error. I checked the last battery and sure enough, I didn’t “lock” the battery cable. While the battery turned on and appeared normal, once I latched it correctly, the alarm cleared up. I’m now rocking and rolling and very much appreciate the assistance! Hope this helps anyone else! Best, Harold

3 Likes

@Suncoug Fantastic news my friend! Now go enjoy that beast!!

1 Like

I had a similar problem with my brand new AC500 and 2 x B300s batteries. I hooked it all up and let it charge to full so that I could test it all out. A week later I came down to find that the batteries were drained to about 76% and were not charging. There were two faults on the unit. Battery Voltage High and a Voltage Sensor failure. I emailed Bluetti Support and didn’t hear anything back. So I emailed them again. Still no response. So then I found this forum and with m.brineys suggestion I shut down the system, disconnected all the cables and then hooked it all back up again. Voila! It started charging the batteries again.

Some key points to take note of that I hadn’t initially noticed.

  1. You must unplug the unit from the wall in order to shut it down.
  2. Although the “GRID” light was on, it didn’t show any wattage coming into the system.
  3. The battery “state” said “standby” instead of “charging.” (Don’t know if there is a setting somewhere to force them to charge?)
  4. the first error code (024) was dated back in August 2022, long before I ever received the unit in mid October. ( I would have thought any testing error codes would have been cleared before shipping)
  5. The second error code (004) was Oct 18th, probably the day I set the unit up. (But nothing came up on the screen when setting it up) Hmmm…

Final thoughts: Bluetti customer support need to step up their game! Not even a return email saying thanks for emailing we will contact you within XX hours. There should be a way to look up what error code numbers mean. The whole point of ordering this “very” expensive unit was for peace of mind in case of a power outage, but with problems right off the get go and non existent customer support response, peace of mind is the last thing I am feeling. Which leads me back to my first point, Bluetti customers are paying extra for “peace of mind” for an established company and the first way to maintain that peace of mind is through a robust product that just “works,” without failures, and the second is through robust customer support system for when there is a problem.

Hopefully, my system will just “work” from this point on and the initial failure was just a glitch.

I’m having issues too. Got the unit, took a week to figure out where and how I’d test it out. Put it in my shed connected to two solar panels that get limited sun but enough to power up the batteries each day after using the power at night for the lights. A week later the lights were not working, no power out of the AC500. Battery at above 70%. numerous errors codes that I could not clear. even after removing from all power inputs and outputs.

Called, and no one answers, can’t leave a voicemail, emailed them a few days later after the weekend and I got a response within a few days asking for the SN number and some more details. No response since 8th November. I’ve followed up twice and got nothing back.

I have even been stalking them on facebook and reddit… nothing but a message back to read the manual. This is not good customer service. Products have issues all the time, it’s just the way it is… but not being able to help me is really really bad. It’s how you fix the issue where you build confidence and customer loyalty.

I have two B300S batteries that I can’t use because the head unit AC500 is bad. I missed my 30 day return window because they are unresponsive to me. I’m now not sure what else I can do.