BLUETTI AC200PL when I plug in to grid, the station does not charge

Hi, i just bought a new BLUETTI AC200PL station. It works I have 55% battery, I can charge my devices through it. However, when I plug in to grid the BLUETTI AC200PL, the station does not charge and icon GRID not show. i can’t charge the BLUETTI AC200PL

Maybe i need new firmware ?

My BLUETTI AC200PL info:
AC200PL2402000338369
ARM v2140.04
DSP v2130.90
BMS v1056.02

Can you help me ?

Have you used the Bluetti app to connect to your AC200PL via bluetooth to check if it is in the correct Working Mode is set in Advanced Settings? If it is set correctly, also ensure that “Charge with Grid” is turned on in the Working Mode settings.

Thanks arron33,
unfortunately, it does not help - yes I can connect by Bluetooth and I have this setting, but it does not charge (
Also when I plug in to the grid I have this Voltage 6V


Ah, it shouldn’t be showing 6V even if it is not charging if it is connected to the grid. You should contact Bluetti support to see if they can send you a replacement AC cable to test. Here is what mine looks like when connected but not charging.

Hi @VitaliiUA , according to the screenshot you provided, we found that you have set the Customized UPS, is that so?
Based on the settings, the AC200PL only starts AC charging when the battery level drops below 20%. This design is intended to save on electricity costs by prioritizing solar charging when the battery is sufficiently charged. Can you switch to standard UPS mode and try again?
Additionally, you mentioned the Grid icon is not illuminated. Could you please confirm that you have correctly connected the AC charging cable? Refer to the attached screenshot and reconnect the AC charging cable.

We await your response and will continue to follow up on this matter.
Thanks to @aaron33 for the help and suggestions, they are very helpful.

Amazing it works, BLUETTI_CARE you made my day!

The reason was not appropriate numbers with AC charging cable connection
(1,2,3 was not in the correct place, in the documentation it was not indicated and these numbers were too small and not visible enough)

Thanks @BLUETTI_CARE for a Great support!
Thanks @aaron33 for your response and for trying to help.